Bug 8499 - (int-154785) Music stops when "low battery" hildon banner is displayed
(int-154785)
: Music stops when "low battery" hildon banner is displayed
Status: RESOLVED FIXED
Product: Media player
General
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal with 2 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-25 14:59 UTC by miniscalope
Modified: 2010-04-16 18:21 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description miniscalope (reporter) 2010-01-25 14:59:04 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM:
1. On a low battery device
2. Play a track with media player
3. Low battery hildon banner pops
4. Music pauses 

EXPECTED OUTCOME:

media player keeps playing the music

ACTUAL OUTCOME:
The music pauses

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

The best would be a special ringtone to say the battery is low, even in silent
mode...

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3)
Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Comment 1 Andre Klapper maemo.org 2010-01-26 12:33:07 UTC
Thanks for reporting this.

> EXACT STEPS LEADING TO PROBLEM:
> 1. On a low battery device
> 2. Play a track with media player
> 3. Low battery hildon banner pops
> 4. Music pauses 

As written before:
Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears)
This is missing here.
Comment 2 Paul van Tilburg 2010-01-26 14:11:43 UTC
I can confirm this problem.  The low battery warning sound pauses the player.
I am also quite, but not exactly, sure this was introduced in PR1.1.

While playing music you can here a beep when there is a new email or message. A
different kind of beep could be used, e.g. a double-beep, to signal battery
low.
Comment 3 Bartosz Taudul 2010-01-27 01:19:42 UTC
(In reply to comment #1)
> Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
> Connection Failed appears)
> This is missing here.
1. Play music using media player.
2. Wait for low battery sound to play.

Expected/actual outcome as in original report.
Comment 4 Andre Klapper maemo.org 2010-01-28 13:48:45 UTC
Thanks for the confirmation!
Comment 5 Andre Klapper maemo.org 2010-01-28 15:01:53 UTC
This has been fixed in package
mediaplayer 1.2-6+0m5
which is part of the internal build version
2009.50-5
(2009/2010 is the year, and the number after is the week.)
Note: This is NOT included in 2.2009.51-1.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 6 Andre Klapper maemo.org 2010-02-11 17:24:15 UTC
*** Bug 8840 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2010-02-25 23:30:07 UTC
*** Bug 9278 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2010-02-28 22:55:41 UTC
*** Bug 9315 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-04-16 18:21:23 UTC
*** Bug 9940 has been marked as a duplicate of this bug. ***