Bug 8492 - (int-155396) Change of country works only once a session
(int-155396)
: Change of country works only once a session
Status: RESOLVED DUPLICATE of bug 7515
Product: Contacts
General
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-25 13:46 UTC by Thomas.Renard
Modified: 2010-03-31 19:17 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Thomas.Renard (reporter) 2010-01-25 13:46:38 UTC
SOFTWARE VERSION:

2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 

1. Reboot
2. Start Contacts
3. Enter a new contact with country and save it
4. Reboot
5. Select contact, edit it and add address field
6. Change the country of this new address
6. The country list is shown - select some other country
7. Fill out rest of the address and name fields
7. Save and leave contact
8. Select any contact and select any country field 

EXPECTED OUTCOME:

The country list is shown - select other country - ok - save

ACTUAL OUTCOME:

Only the text field of the list is shown, no ok is possible - only cancel.
The country is editable once (!) after the next reboot.

REPRODUCIBILITY:

always - no difference if changing the locale of the device (tested with German
and English/UK)

EXTRA SOFTWARE INSTALLED:

Nothing which may affect contacts.
Comment 1 Andre Klapper maemo.org 2010-01-26 14:10:01 UTC
Cannot reproduce this, but the steps are also a bit vague, for example the
second contact edited: Does it already have an Address set or not?
Also, the exact countries and click by click steps with exact fields (e.g.
there's Address, Address (Home), Address (Work)) etc is highly welcome in order
to reproduce this.
Comment 2 JonWW 2010-01-30 01:15:37 UTC
I can confirm that this bug exists.

SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
 1. Open the Contacts Manager
 2. Select a contact with an address or add address to existing contact
 3. Click Avatar to edit contact details
 4. Scroll down to Country
 5. Click Country
 6. A scrollable list appears with all countries listed
 7. Click Done (no need to change country)
 8. Click Save
 9. Click Avatar to edit same contact details
10. Scroll down to Country
11. Click Country
12. FAIL: A text box appears where a scrollable list should be
13. Type a valid country name (one you know exists in list) or leave existing
14. Click Done
15. FAIL: You cannot save, change or delete country name
16. To change country name in same or any other contact a reboot is required

EXPECTED OUTCOME:
1. A scrollable country list is shown
2. Select country
3. Done
4. Save

ACTUAL OUTCOME:
1. A textbox with the country name is shown
2. Done just flashes when pressed
3. Pressing outside the textbox to cancel it
4. You are now unable to edit the country of any other contacts until after a
reboot

REPRODUCIBILITY:
Always – Only tested on English unit

EXTRA SOFTWARE INSTALLED:
MSN protocol plugin for Conversations and Contacts 0.7
Skype has been setup

As the OP did not report having these installed I assume they would not be the
cause

OTHER COMMENTS:
It appears that once the scrollable country list has been shown, then done
button pressed and the contact saved then problem is created. I would narrow it
down to the done button in the scrollable list because with out pressing this I
cannot reproduce it
Comment 3 Andre Klapper maemo.org 2010-02-02 18:47:11 UTC
JonWW, thanks for the perfect steps!
Comment 4 Eugene Agafonov 2010-02-03 10:23:10 UTC
It seems to me this bug is for Contacts, not for Calendar
Comment 5 Andre Klapper maemo.org 2010-02-03 13:19:25 UTC
Whoops, thanks for noticing!
Comment 6 Karl 2010-03-15 20:48:02 UTC
I cannot change the country at all. If I press the country field it opens a
text box but clicking "Done" or hitting the return key does not work.
Comment 7 John Veness 2010-03-27 20:00:18 UTC
I think this is a duplicate of Bug 7515, which will be fixed in PR1.2
apparently.
Comment 8 Andre Klapper maemo.org 2010-03-31 19:17:10 UTC
Oh right. Thanks for noticing!

*** This bug has been marked as a duplicate of bug 7515 ***