Bug 8484 - Having a modal dialog in background, Alarm dialog blocks power button => battery removal
: Having a modal dialog in background, Alarm dialog blocks power button => batt...
Status: CLOSED WORKSFORME
Product: Utilities
Clock
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: clock-bugs
:
: moreinfo
: int-148215
:
  Show dependency tree
 
Reported: 2010-01-25 09:09 UTC by AB
Modified: 2010-10-27 10:46 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description AB (reporter) 2010-01-25 09:09:28 UTC
SOFTWARE VERSION:
1.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Simply create an alarm (for example for 8:00 clock in the morning)
2. Power off the device
3. Go to bed and have a nice sleep until the alarm rings in the morning

EXPECTED OUTCOME:
Alarm rings, you can snooze, then push button to power on the device

ACTUAL OUTCOME:
Snoozing by flipping works. The "exit offline mode" is briefly shown (not 100%
sure, considering the time of day) and then nothing. Pressing power button
seems to start boot sequence (white light on for a brief moment) but fails to
swtich the device on.

REPRODUCIBILITY:
twice so far

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Happened while testing bug #8115
Notable difference is that the device is powered off, not merely offline, prior
to starting the test.
Charger was connected when alarm went off and light was green. Reconnecting
charger does not toggle charging light.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Comment 1 Andre Klapper maemo.org 2010-01-25 20:24:03 UTC
Hi, I cannot reproduce this, probably because this is missing stuff in the
steps to reproduce list, e.g. Offline Mode before switching off?

> EXPECTED OUTCOME:
> Alarm rings, you can snooze, then push button to power on the device

All of this works fine here.

> ACTUAL OUTCOME:
> Snoozing by flipping works.

So what did NOT work from your "Expected outcome" list?
Comment 2 AB (reporter) 2010-01-25 23:27:00 UTC
(In reply to comment #1)


> Hi, I cannot reproduce this, probably because this is missing stuff in the
> steps to reproduce list, e.g. Offline Mode before switching off?

Phone was in general profile, online mode.


> > EXPECTED OUTCOME:
> > Alarm rings, you can snooze, then push button to power on the device
> All of this works fine here.

Not here: after snoozing, the power button failed to switch the phone on. Had
to remove the battery and try again.

Maybe (early morning and all) I pushed the button for an insufficient time and
the boot did not start properly. I'll retry this case. Just a hunch: is the
pinpad modal too?
Comment 3 Andre Klapper maemo.org 2010-06-25 21:22:01 UTC
Has this happened again in 10.2010.19-1?
Comment 4 Andre Klapper maemo.org 2010-09-27 12:29:35 UTC
Closing this bug report as the issue could not be reproduced. Please feel free
to reopen this report if you can provide better steps to reproduce this / if
this still happens in 10.2010.19-1.
Comment 5 AB (reporter) 2010-10-27 10:46:07 UTC
(In reply to comment #4)

> Closing this bug report as the issue could not be reproduced.

Upgraded to PR1.3 and tried to reproduce: ignored alarm, prompt to power on, do
not choose, hear "bing", wait some more time, alarm is heard again after
snooze.
I guess we can consider it gone for good.