Bug 8478 - (int-154380) MicroB does not properly render Fixed Position centered div's
(int-154380)
: MicroB does not properly render Fixed Position centered div's
Status: RESOLVED WONTFIX
Product: Browser
MicroB engine
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: unassigned
: microb-bugs
: http://tf2.lowlagfrag.com/designs/
:
:
:
  Show dependency tree
 
Reported: 2010-01-25 01:38 UTC by bugzilla
Modified: 2010-03-13 18:19 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description bugzilla (reporter) 2010-01-25 01:38:23 UTC
SOFTWARE VERSION: 2.2009.51-1.002
MicroB v3.6 (1.5.6 RX-51 N900)
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Visit http://tf2.lowlagfrag.com/designs/ in MicroB
2. You will see the header is off-aligned, this is normal for small res (main
hack used by most sites to have fixed divs centered).
3. Most pc browsers {firefox, opera, safari, chrome}[ie is an exception] for PC
will correct the alignment when zoomed out, but MicroB keeps fixed render
point.
4. Scrolling, fixed div's blink and disappear, sometimes never reappear (this
is unusual for any browser)


EXPECTED OUTCOME:
Site renders content when zoomed out with new dimensions or adjusts fixed divs.

ACTUAL OUTCOME:
Zooming out, keeps area clipped and not aligned.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
10/10

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I was not sure if this should be the zooming component.
This is a common method of centering fixed div's on a site.
The flashing is undesired but not the primary issue of this bug ticket.
This bug relates to how sites are not properly rendered with fixed div's and
zooming.
It would be nice to have a solution that works well for small screens and fixed
renders but thus-far no other viable solution is available.
After this is fixed, I will open another bug due to slow top alignments after
scrolling (flashing) or not even showing up after scrolling.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Comment 1 Andre Klapper maemo.org 2010-01-25 20:44:42 UTC
I'm surprised that it works fine in Fennec Beta 1 here.
Also confirming this happens in MicroB in internal version 2010.04-4.
Comment 2 tuukka.tolvanen nokia 2010-01-26 01:20:02 UTC
(In reply to comment #0)
> 3. Most pc browsers {firefox, opera, safari, chrome}[ie is an exception] for PC
> will correct the alignment when zoomed out, but MicroB keeps fixed render
> point.

Right, the document width doesn't change (requiring a costly reflow) when
zooming. Don't know if there is / could be something more clever done with the
fixedpos bits in particular in that regard.

> 4. Scrolling, fixed div's blink and disappear, sometimes never reappear (this
> is unusual for any browser)

Keeping them put while scrolling brings about some perf challenges. They
certainly should always come back though.

(In reply to comment #1)
> I'm surprised that it works fine in Fennec Beta 1 here.

b1? rc1 never shows the leftmost parts of the fixed banner when zooming out,
afaict.
Comment 3 tuukka.tolvanen nokia 2010-01-26 01:31:26 UTC
A slightly different approach like
data:text/html,<img%20src="http://tf2.lowlagfrag.com/designs/template/top.png"%20style="position:fixed;margin-left:auto;margin-right:auto;top:0;left:0;right:0"><div%20style="height:2000px;padding-top:300px">bah
will end up a bit happier here -- compatibility-wise, it may well be a
different story.
Comment 4 bugzilla (reporter) 2010-02-01 06:53:19 UTC
(In reply to comment #3)
> A slightly different approach like
> data:text/html,<img%20src="http://tf2.lowlagfrag.com/designs/template/top.png"%20style="position:fixed;margin-left:auto;margin-right:auto;top:0;left:0;right:0"><div%20style="height:2000px;padding-top:300px">bah
> will end up a bit happier here -- compatibility-wise, it may well be a
> different story.
> 

That is not a solution as it is not just an image, and even then... wtf... :)
Sorry

I assumed the redraw was an costly function and that is why it did not occur,
but is there a way to incorporate some more intelligent means of detecting
width of site.  Like div-width plus abs(left)

For my sites, I will probably incorporate a solution using javascript, but to
my misfortune I do not control every site on the internet.
Comment 5 timeless 2010-02-01 07:02:40 UTC
intelligent width detection is an incredible waste of time and will be full of
fail.
Comment 6 Andre Klapper maemo.org 2010-02-10 15:32:16 UTC
This is a WONTFIX.
Comment 7 bugzilla (reporter) 2010-02-11 18:22:09 UTC
so your isolating support for sites with fixed center floats...  hopefully it
won't come more popular...  :(
Comment 8 bugzilla (reporter) 2010-03-13 09:58:23 UTC
Hey,
I just checked iPhone Safari and they do not suffer from this bug, they at
least render the pages with the full width and centering of static floats.

Do you really want webkit to make your browser look like a fool?
Comment 9 Andre Klapper maemo.org 2010-03-13 18:19:18 UTC
WONTFIX means WONTFIX, please do not reopen when not having any *technical*
arguments. Thank you. For offtopic $browser discussion please go to the forum
at talk.maemo.org.