Bug 8441 - (int-150298) Messages don't change to "read" status after being read
(int-150298)
: Messages don't change to "read" status after being read
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-23 21:38 UTC by Ben Smith
Modified: 2010-06-07 16:11 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ben Smith (reporter) 2010-01-23 21:38:29 UTC
SOFTWARE VERSION: 2.2009.51-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Receive new message after having updated the N900 Firmware to the new
2.2009.51-1
2. Read the message (either from tapping on it on the dashboard or going
directly to the "Conversations" menu)
3. Close message and return to "Conversations"

EXPECTED OUTCOME: the message I've just read should be in the Conversations but
not in bold anymore; hence, its status should automatically be as "Read".

ACTUAL OUTCOME: the message I've just read is in bold in the "Conversations"
menu, as if I had not already read it. The same thing happens even after a few
reboots, the read message is still set as "unread"

REPRODUCIBILITY: always with the new firmware installed

EXTRA SOFTWARE INSTALLED: no other software.

OTHER COMMENTS: I've flashed it 3 times: at first I thought something wrong
went with the 2.2009.51-1 OTA update, so I flashed it once and the fault was
still there; then I flashed it a second time, and it was still there; now I've
flashed the device with the new firmware but the bug is still there. 

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Andre Klapper maemo.org 2010-01-26 16:54:44 UTC
Thanks for reporting this.
What exact messages is this about? SMS, IM (if so, which service)? Does this
happen with all of them? If it's about SMS, what is your provider?
Comment 2 Ben Smith (reporter) 2010-01-27 01:54:25 UTC
(In reply to comment #1)
> Thanks for reporting this.
> What exact messages is this about? SMS, IM (if so, which service)? Does this
> happen with all of them? If it's about SMS, what is your provider?
> 

It happens with sms, as that's what I use. Moreover, my provider is Vodafone
UK. I really hope there's a fix for this.
Comment 3 Andre Klapper maemo.org 2010-01-27 19:58:45 UTC
Bug 8076 might be a duplicate.
Confirming.
Comment 4 Andre Klapper maemo.org 2010-01-27 19:59:16 UTC
This has been fixed in package
rtcom-eventlogger 1.1-2+0m5
which is part of the internal build version
2009.53-2
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 5 Ben Smith (reporter) 2010-01-27 20:26:43 UTC
(In reply to comment #4)
> This has been fixed in package
> rtcom-eventlogger 1.1-2+0m5
> which is part of the internal build version
> 2009.53-2
> (Note: 2009/2010 is the year, and the number after is the week.)
> 
> A future public update released with the year/week later than this internal
> build version will include the fix. (This is not always already the next public
> update.)
> Please verify that this new version fixes the bug by marking this bug report as
> VERIFIED after the public update has been released and if you have some time.
> 
> 
> To answer popular followup questions:
>  * Nokia does not announce release dates of public updates in advance.
>  * There is currently no access to these internal, non-public build versions.
>    A Brainstorm proposal to change this exists at
> http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
> 

I don't get it: the build I'm on is 51 and not 53 but you're saying that a
build after 53 (which hasn't been released yet) may solve it... But how do you
know? Do you know anything about it (e.g. release date, changelog, whether it's
been confirmed by Nokia etc). And besides, what's causing this bug? Could you
please explain! Thanks
Comment 6 Andre Klapper maemo.org 2010-01-27 20:37:26 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > This has been fixed in package
> > rtcom-eventlogger 1.1-2+0m5
> > which is part of the internal build version
> > 2009.53-2
> > (Note: 2009/2010 is the year, and the number after is the week.)
> > 
> > A future public update released with the year/week later than this internal
> > build version will include the fix. (This is not always already the next public
> > update.)
> > Please verify that this new version fixes the bug by marking this bug report as
> > VERIFIED after the public update has been released and if you have some time.
> > 
> > 
> > To answer popular followup questions:
> >  * Nokia does not announce release dates of public updates in advance.
> >  * There is currently no access to these internal, non-public build versions.
> >    A Brainstorm proposal to change this exists at
> > http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
> > 
> 
> I don't get it: the build I'm on is 51 and not 53

Yes, as 51 is the latest PUBLIC version.
2009.53-2 is an INTERNAL build version.

> But how do you know?

I have access to internal Nokia things and am the bugmaster here. :)
Comment 7 Ben Smith (reporter) 2010-01-28 14:19:46 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > This has been fixed in package
> > > rtcom-eventlogger 1.1-2+0m5
> > > which is part of the internal build version
> > > 2009.53-2
> > > (Note: 2009/2010 is the year, and the number after is the week.)
> > > 
> > > A future public update released with the year/week later than this internal
> > > build version will include the fix. (This is not always already the next public
> > > update.)
> > > Please verify that this new version fixes the bug by marking this bug report as
> > > VERIFIED after the public update has been released and if you have some time.
> > > 
> > > 
> > > To answer popular followup questions:
> > >  * Nokia does not announce release dates of public updates in advance.
> > >  * There is currently no access to these internal, non-public build versions.
> > >    A Brainstorm proposal to change this exists at
> > > http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
> > > 
> > 
> > I don't get it: the build I'm on is 51 and not 53
> Yes, as 51 is the latest PUBLIC version.
> 2009.53-2 is an INTERNAL build version.
> > But how do you know?
> I have access to internal Nokia things and am the bugmaster here. :)

Ok, thanks for the clarifications.
The last two questions though:
1. Since you're the bugmaster, have you got any idea as to when this internal
build version will be made public? Roughly?
2. Is there any workaround for this bug, as it can be a very annoying eyesore
unfortunately!

Thanks in advance for all your help.
Comment 8 Andre Klapper maemo.org 2010-01-28 19:05:02 UTC
*** Bug 8076 has been marked as a duplicate of this bug. ***
Comment 9 Andre Klapper maemo.org 2010-02-18 23:24:35 UTC
*** Bug 9142 has been marked as a duplicate of this bug. ***
Comment 10 Simon Williams 2010-02-19 04:25:14 UTC
While waiting for the new firmware, deleting the database file may be an
acceptable workaround for some people:
http://talk.maemo.org/showthread.php?t=41980

(You will need to reboot for it to take effect most likely).

Beware- this will delete all your SMS history. For all I know it could delete
other things that I haven't noticed yet!
Comment 11 Andre Klapper maemo.org 2010-03-15 20:52:26 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 12 Ben Smith (reporter) 2010-05-25 21:53:33 UTC
(In reply to comment #11)
> Setting explicit PR1.2 milestone (so it's clearer in which public release the
> fix will be available to users).
> 
> Sorry for the bugmail noise (you can filter on this message).
> 

thanks , I've just updated my N900 to pr1.2 and this bug is resolved....but
only for new messages received after the update. so basically, if I receive any
messages now and I read them, the status will change (as it's supposed to
do)...however, for messages that had been affected by that bug, they're still
unread....any workarounds? help please! =(
Comment 13 Andre Klapper maemo.org 2010-06-07 16:11:28 UTC
Closing again as you filed bug 10467 about this.