Bug 8428 - Carrier doesn't stop attempting to send USSD codes that aren't received (automated balance receipt)
: Carrier doesn't stop attempting to send USSD codes that aren't received (auto...
Status: RESOLVED FIXED
Product: Chat & Call & SMS
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified critical with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: communication-bugs
:
:
: int-144051
:
  Show dependency tree
 
Reported: 2010-01-23 00:37 UTC by Sam (ABUSED BUGZILLA; ACCOUNT SUSPENDED)
Modified: 2010-03-15 20:52 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sam (ABUSED BUGZILLA; ACCOUNT SUSPENDED) (reporter) 2010-01-23 00:37:54 UTC
Balance receipt is an automated and free service from many 2G/2.5G cellular
network around the world which pops up after every call or text message you
send. There are 2 issues I have seen.

First is that it CAN NOT be disabled from the network where it's
originated and second is that it's the same (Window/Screen/Text Box) which
appears while we get different info using USSD Commands. Since the USSD's
message screen is unavailable, my cellular network tries to keep on sending
balance receipt which N900 never gets and turns out to keep phone busy by
hopeless struggles. 

Now the main problem is that after I make a phone call the "automated receipt"
tries to pop up on the screen but N900 wont let which results as a constant
buzz from my computer's monitor and speakers (The buzz you normally hear while
the call is in progress OR when you're about to receive an SMS)

And it wont go away till I put my phone in Offline mode.

It appears that there's another problem attached to the lack of USSD command in
N900
Comment 1 Vladimir Oka 2010-01-23 10:19:51 UTC
(In reply to comment #0)
> ...

Can you specify your operator, country, and region/city? Does it happen
everywhere with your operator? Can you try another local operator with the same
service (borrow a friend's SIM card)?

This issue may even be a problem on the network side, so it will be helpful to
have information about that as well (from your information someone will be able
to determine who produced the network infrastructure and even its version.
Then, it can be compared to, for example O2 UK (my operator) where the problem
is not seen. It could be that N900 "rejects" such messages, and O2 network
realises and stops sending them, while your network is (erroneously?) ignoring
this signal. 

This is just a guess. Obviously needs investigation by the right people, and
I'm not one of them. But they do need detailed information from you if they are
to stand a chance of reproducing this (rather than giving up as they find
there's no problem on, say O2 UK).

If the problem is with the network, someone needs to tell them so they can fix
it. This, however, obviously can't be guaranteed, as it's outside the control
of the phone manufacturer.
Comment 2 Lassi Syrjälä nokia 2010-01-23 11:15:24 UTC
Could be a network or a modem configuration issue. The N900 does not
acknowledge the message but I am not sure if it's properly rejected either
(since the modem appears to have USSD support enabled, as noted in the mother
bug).

Whichever the reason, this should be working correctly on the next major update
where the rest of the SW stack supports USSD as well.
Comment 3 Sam (ABUSED BUGZILLA; ACCOUNT SUSPENDED) (reporter) 2010-01-23 23:04:53 UTC
(In reply to comment #2)
> Could be a network or a modem configuration issue. The N900 does not
> acknowledge the message but I am not sure if it's properly rejected either
> (since the modem appears to have USSD support enabled, as noted in the mother
> bug).
> Whichever the reason, this should be working correctly on the next major update
> where the rest of the SW stack supports USSD as well.

Hi Lassi. I am using N900 in Saudi Arabia where there are 3 cellular operators.
All of them are 2.5G / 3G which means you could choose either frequency.

Now adding to this whenever a user makes call, he automatically gets a balance
receipt after the call which can not be disabled. Since the current firmware
doesn't acknowledge the receipt message neither properly rejects it which later
consequents in keeping the phone busy and that can be easily heard by any
computer's speakers.
Today instead of putting phone offline to prevent lousy noise i decided to wait
till the USSD message is rejected. After 15 mins I received a text message from
unknown sender "My Nokia" stating the following.

(My Nokia: //PARU1fkgPhwEAAUbRIOdovQYEMzkyMQkAyACkpStoJ5LU1/G6Szu5)

I have no idea what this message is but gladly phone went back to normal and no
more sound was coming from my Computer's speakers.
Comment 4 Andre Klapper maemo.org 2010-03-15 20:52:25 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).