Bug 8396 - (int-154145) FM Transmitter displays gibberish text in Radio player
(int-154145)
: FM Transmitter displays gibberish text in Radio player
Status: RESOLVED FIXED
Product: Multimedia
FM Transmitter
: 5.0/(3.2010.02-8)
: N900 Maemo
: Medium normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: fmtx-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-22 13:56 UTC by Amilcar Santos
Modified: 2010-03-15 20:55 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Amilcar Santos (reporter) 2010-01-22 13:56:48 UTC
SOFTWARE VERSION:
Nokia N900
Maemo 5
Version: 2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Tap on N900 Media Player;
2. Tap on Music;
3. Tap on a music.
4. Tap on Play (music is playing).
5. Tap on Menu and tap on FM Transmitter.
6. Tap on FM Transmitter On.
7. Tap on Save.
8. Set the Radio player station (Radio player supports RDS station and info
text).
9. Music is playing the the Radio player.
10. Gibberish text is displayed in Radio player.

EXPECTED OUTCOME:
Expected "Nokia" to be displayed, in Radio player, has RDS station (e.g. other
text set by fmtx_client tool).

ACTUAL OUTCOME:
Gibberish text is displayed in Radio player.

REPRODUCIBILITY:
Sometimes no text is displayed.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
In the shell I executed the fmtx_client tool and the output was:
Usage:
------
-f<uint>        Set frequency (in kHz)
-s<string>      Set RDS station name
-t<string>      Set RDS info text
-p<uint>        Turn fmtx on (1) or off (0)

Current settings (Frequencies in kHz):
--------------------------------------
version=1
frequency=88100
freq_min=88100
freq_max=107900
freq_step=100
state=enabled
rds_ps=<ARTIST>/<ALBUM>/<TRACK NAME>
rds_text= 

note: "<ARTIST>/<ALBUM>/<TRACK NAME>" isn't the actual output...

Since the Media Player appears to be sending track metadata to the RDS text, an
expected resolution should be:
1. leave the rds_ps text unchanged and set the track metadata to the rds_text.


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.6)
Gecko/20070725 Firefox/2.0.0.6 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-22 14:08:15 UTC
Thanks for reporting this.
Comment 2 Andre Klapper maemo.org 2010-02-02 13:37:22 UTC
*** Bug 8665 has been marked as a duplicate of this bug. ***
Comment 3 Andre Klapper maemo.org 2010-02-22 19:16:04 UTC
This has been fixed in package
mediaplayer 1.2-13+0m5
which is part of the internal build version
10.2010.07-7
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-03-15 20:55:51 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).