Bug 8385 - (int-152372) New browser windows' contents are not updated when page loads in background
(int-152372)
: New browser windows' contents are not updated when page loads in background
Status: VERIFIED FIXED
Product: Browser
User interface
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: Oleg Romashin
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-22 00:43 UTC by Bartosz Taudul
Modified: 2010-05-25 22:54 UTC (History)
3 users (show)

See Also:


Attachments
Illustration of the issue (131.88 KB, image/png)
2010-01-22 00:44 UTC, Bartosz Taudul
Details
How it should be displayed (150.13 KB, image/png)
2010-01-22 00:45 UTC, Bartosz Taudul
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Bartosz Taudul (reporter) 2010-01-22 00:43:42 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Install camkeyd for fast window switching.
2. Open RSS reader.
3. Subscribe to any RSS feed.
4. Open any link from the feed.
5. Immediately after a new browser window shows up, press the camera button to
access window switcher and go back to RSS reader.
6. Repeat steps 4 and 5 a couple of times.
7. Open window switcher.

EXPECTED OUTCOME:
All browser windows have contents visible.

ACTUAL OUTCOME:
Some browser windows have no contents (all is white). Note that after bringing
such window to the foreground the valid content is displayed immediately (page
is already loaded).

REPRODUCIBILITY:
Rare, but frequent enough to be annoying.
Comment 1 Bartosz Taudul (reporter) 2010-01-22 00:44:20 UTC
Created an attachment (id=2084) [details]
Illustration of the issue
Comment 2 Bartosz Taudul (reporter) 2010-01-22 00:45:30 UTC
Created an attachment (id=2085) [details]
How it should be displayed

This screenshot is made after selecting the blank window (valid content is
displayed immediately) and going back to window switcher.
Comment 3 timeless 2010-01-22 12:30:06 UTC
i believe this is because we're trying not to starve your system for memory.
Rendering is a fairly expensive operation, iirc our buffer would be roughly 4mb
just for the picture, per window, not counting the memory required for the
page. So if we aren't active, we try to let other applications have more memory
when we aren't active (otherwise they'd starve and you'd complain...).

One thing you /might/ try changing is the last option in the browser (this is
based on an unofficial English, sorry) options>options>Stop other webapps =
"after 15 seconds" to "No".

I'm not sure if we have direct access to the preview windows (I think they're
calculated by the window manager), if we did, we could try to render a
pre-downsampled image which would require less memory bandwidth.
Comment 4 tuukka.tolvanen nokia 2010-01-23 04:03:59 UTC
fixed in int-152372 at 2010.03, five windows launched within 15s from browser
startup view updated in task switcher within one minute (when complete; that'll
vary), 3/3
Comment 5 Andre Klapper maemo.org 2010-02-16 14:07:47 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 3.2010.02-8 (also called "PR1.1.1"
sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.
Comment 6 tuukka.tolvanen nokia 2010-02-17 01:03:35 UTC
sorry, this is in 10.2010.03-12, not the 3.* series
Comment 7 Andre Klapper maemo.org 2010-03-15 20:51:53 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).