Bug 8378 - Tapping desktop then "more" quickly confuses application menu
: Tapping desktop then "more" quickly confuses application menu
Status: RESOLVED DUPLICATE of bug 6361
Product: Desktop platform
Application Menu
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: task-navigator-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-21 22:34 UTC by Josh Triplett
Modified: 2010-01-21 23:15 UTC (History)
0 users (show)

See Also:


Attachments
Screenshot of confused application menu (331.24 KB, image/png)
2010-01-21 22:34 UTC, Josh Triplett
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Josh Triplett (reporter) 2010-01-21 22:34:04 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Open the application menu.
2. Tap along the edge to close the menu, then *quickly* tap the "more" icon.

EXPECTED OUTCOME:

Either the menu closes, or the "more" menu opens.

ACTUAL OUTCOME:

The menu closes, leaving a desktop which still looks slightly zoomed out. 
Opening the application menu again immediately shows the "more" menu, drawn on
top of the non-"more" menu; I will attach a screenshot of this.  This behavior
persists until either a reboot or a change to the application menu (adding or
removing an application with an icon in the menu).

REPRODUCIBILITY:
Always, if you get the timing right.
Comment 1 Josh Triplett (reporter) 2010-01-21 22:34:44 UTC
Created an attachment (id=2081) [details]
Screenshot of confused application menu
Comment 2 Andre Klapper maemo.org 2010-01-21 23:07:42 UTC
Thanks for reporting this.
This particular problem has already been reported into our bug tracking system,
but please feel free to report any further bugs you find. Also feel encouraged
to vote for the original bug report if interested.

*** This bug has been marked as a duplicate of bug 6361 ***
Comment 3 Josh Triplett (reporter) 2010-01-21 23:15:55 UTC
(In reply to comment #2)
> Thanks for reporting this.
> This particular problem has already been reported into our bug tracking system,
> but please feel free to report any further bugs you find. Also feel encouraged
> to vote for the original bug report if interested.
> 
> *** This bug has been marked as a duplicate of bug 6361 ***

Thanks; it seems I didn't find that bug because it has status "RESOLVED FIXED",
though the latest released firmware doesn't have the fixed hildon-desktop.

(Ideally bugs need some status distinction between "fixed internally" and "fix
generally available", and searches should find the former by default.)