Bug 8376 - n900 refuses connection with cyrus pop3 server
: n900 refuses connection with cyrus pop3 server
Status: RESOLVED DUPLICATE of bug 5836
Product: Email
General
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-21 21:30 UTC by meamobz
Modified: 2010-01-29 15:05 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description meamobz (reporter) 2010-01-21 21:30:40 UTC
The N900 cannot connect to a cyrus pop3 server. 
(cyrus-pop3d-2.2 (2.2.13-16ubuntu1)).

The pop3 server is configured to use TLS.

The relevant camel debug output says:
POP3_STREAM_LINE(12): 'EXPIRE NEVER'
POP3_STREAM_LINE(14): 'LOGIN-DELAY 60'
POP3_STREAM_LINE(3): 'TOP'
POP3_STREAM_LINE(4): 'UIDL'
POP3_STREAM_LINE(10): 'PIPELINING'
POP3_STREAM_LINE(10): 'RESP-CODES'
POP3_STREAM_LINE(14): 'AUTH-RESP-CODE'
POP3_STREAM_LINE(4): 'USER'
POP3_STREAM_LINE(64): 'IMPLEMENTATION Cyrus POP3 server
v2.2.13-Debian-2.2.13-16ubuntu1'
POP3_STREAM_LINE(END)
POP3_STREAM_LINE(27): '+OK Name is a valid mailbox'
Got + response
POP3_STREAM_LINE(70): '-ERR [IN-USE] Unable to lock maildrop: Mailbox is locked
by POP server'


Verified was that there were not other clients connecting/connected to the pop3
server before the N900 attempted to connect. cyrus was restarted to ensure no
pending locks from previous tests.

The camel debug log shows that 2 connections are made during startup of the
email client.

the log was captured with:
export "CAMEL_DEBUG"="all"
/usr/bin/maemo-summoner /usr/bin/modest.launch -s > log 2>&1

Gr. Sim
Comment 1 meamobz (reporter) 2010-01-21 21:43:04 UTC
when modest is killed, immediately it is restarted, and a succesfull pop3
connection is made.

however, when the gui is used to check for email, a second pop3 connection is
made, and this one fails.

I've read about the comments made as to the servers behaviour, and it is clear
that only 1 connection should be made at a certain time to allow for rfc
compliant behaviour.

Gr. Sim
Comment 2 Lucas Maneos 2010-01-22 10:07:48 UTC
Thanks for the bug report. This particular bug has already been reported into
our bug tracking system, but please feel free to report any further bugs you
find.

*** This bug has been marked as a duplicate of bug 5836 ***