Bug 8367 - AVRCP: Skipping tracks (double key-press events?)
: AVRCP: Skipping tracks (double key-press events?)
Status: RESOLVED WONTFIX
Product: Media player
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low enhancement with 3 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-21 18:45 UTC by Michael
Modified: 2012-03-24 11:40 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Michael (reporter) 2010-01-21 18:45:11 UTC
SOFTWARE VERSION: 5.0/(1.2009.44-1)
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 

1. Connect A2DP/AVRCP headset (I was using the Sennheiser MM450)
2. Launch Media Player
3. Press previous/forward buttons on the headset.

EXPECTED OUTCOME:

The previous/next track is played back.

ACTUAL OUTCOME:

The previous/next track is played most of the times, but it also happens that
the playlist advances two positions for just one key press. This does not seem
to be related to bouncing contacts, I think it is a software problem.


REPRODUCIBILITY:

Tough, unfortunately. Please comment if you know a way to reproduce it more
easily.

(relevant) EXTRA SOFTWARE INSTALLED:

ogg-support, but seems to happen with MP3s as well as OGGs
Comment 1 Andre Klapper maemo.org 2010-01-22 17:07:42 UTC
Hi,
1.2009.44-1 is an old version released 2 weeks ago. Is this also an issue in
the latest version 2.2009.51-1?
Comment 2 Michael (reporter) 2010-02-08 14:07:26 UTC
Sorry about the late reply. But no, the new revision did not solve the problem.
Comment 3 Andre Klapper maemo.org 2010-02-09 01:28:41 UTC
Hi,
I don't think that this is currently supported at all for other headphones than
the official ones, which turns this into an enhancement request. See bug 1553,
and feel free to vote at
http://maemo.org/community/brainstorm/view/headset_button_input_reader/ 

*** This bug has been marked as a duplicate of bug 1553 ***
Comment 4 Michael (reporter) 2010-02-09 10:33:36 UTC
Andre: This has absoluteley nothing to do with bug #1553. This one is about
Bluetooth, the other one about headphones connected through the headphone
connector. AVRCP is a standard, so any AVRCP-capable Bluetooth headphone should
behave exactly the same way (and not the Mediaplayer should not skip tracks).

The link you mentioned is about an application *using* AVRCP to emulate that
functionality with headphones connected through the headphone connector.

I hereby request to re-open this bug.
Comment 5 Benjamin 2011-02-21 22:18:42 UTC
I can confirm this issue. I am using a Sennheiser MM-400 headset connected via
bluetooth and after skipping a few tracks, the media player randomly starts
skipping over two or more tracks per key-press, which is quite annoying. 

This bug unfortunately persisted through all PRs. Currently I am running
20.2010.36-2 with CSSU enabled.

On a sidenote: I noticed the exact same faulty behaviour when pairing my
headset with my laptop running Ubuntu 9.10. Sometime, either with the upgrade
to 10.4 or 10.10 it seems to have been fixed and now works as expected.
Comment 6 Damien 2011-10-16 12:15:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Damien 2011-10-16 12:19:13 UTC
Confirmed on a N900 running Maemo PR1.3 + CSSU enzbled and up to date, using
Sennheiser MM 450 BT Headset. I never had this behaviour with Nokia BH-504 BT
Headset.
Comment 8 Andre Klapper maemo.org 2012-03-24 11:40:03 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )