Bug 8343 - (int159579/int-173378) Skype throws "Incorrect address" error for phone numbers with p (pause tone) in Contacts
(int159579/int-173378)
: Skype throws "Incorrect address" error for phone numbers with p (pause tone) ...
Status: RESOLVED FIXED
Product: Telephony
General
: 5.0:(10.2010.19-1)
: N900 Maemo
: Unspecified normal with 6 votes (vote)
: Harmattan
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-21 00:53 UTC by Tim Watt
Modified: 2011-05-05 17:32 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Watt (reporter) 2010-01-21 00:53:18 UTC
SOFTWARE VERSION:
2.2009.51.1

EXACT STEPS LEADING TO PROBLEM: 

1. launch contacts 
2. a contact with a number with "x" or "p" or "'" in it can not be dialed from
using skype. 
3. eg. +1604 555 5555 p 333 ("p" denotes a pause before dialling the DTMF 333)
4. yellow bar displays incorrect address.  

EXPECTED OUTCOME:
+1604 555 5555 p 333 i expect the number to dial flowed by a pause followed by
the of 333. 

the number with a "p" in it should dial exactly the same way it dials on the
GSM network. 

ACTUAL OUTCOME:
number does not dial 
yellow bar displays incorrect address.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
no relevant 

OTHER COMMENTS:
similar problem as https://bugs.maemo.org/show_bug.cgi?id=7001 
but for Skype and I presume SIP

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Venomrush 2010-03-05 04:34:05 UTC
Confirming
Comment 2 Jason Byrne 2010-03-07 07:07:29 UTC
Just curious, is it possible to add the pause with a comma? That is/was
certainly the way to add pauses in dialing with modems and lots of dial-up
clients.
Comment 3 Tapani L. 2010-03-09 14:39:24 UTC
I have the same problem with SW Version: 3.2010.02-8 and using SIP.
Comment 4 Tim Watt (reporter) 2010-03-09 22:24:23 UTC
to dial a pause with a "," vote for this bug 
https://bugs.maemo.org/show_bug.cgi?id=8344
Comment 5 Andre Klapper maemo.org 2010-03-12 16:29:45 UTC
Nokia has no plans to support dialstrings in Maemo5.
Comment 6 Tim Watt (reporter) 2010-03-13 06:48:08 UTC
the problem is not related to dialstrings, but dialling numbers with a "p"
(pause) in them in skype or SIP.
Comment 7 Tim Watt (reporter) 2010-03-13 06:50:28 UTC
The problem is not related to dialstrings, but dialling numbers with a "p"
(pause) in them in skype or SIP. see opening comments.
https://bugs.maemo.org/show_bug.cgi?id=7001 = resolved for GSM dialling only,
not SIP or Skype.
Comment 8 Andre Klapper maemo.org 2010-03-13 18:16:52 UTC
Yes, that was meant by that WONTFIX comment.
Comment 9 Tim Watt (reporter) 2010-03-15 07:53:08 UTC
the problem is one can't use my address book to dial telephone numbers with
Skype.
At lease fix it to the point where it will dial the phone number. 

I would be happy if it just dialed the number up to "P" but it wont dial at
all. 
ie every number in the address book with an extension can't be dialled via the
contact list.   

Skype as employed by the n900 is a paradigm shifting feature, this is such a
great feature it should be made to work.
Comment 10 Andre Klapper maemo.org 2010-03-15 12:27:48 UTC
Please do not reopen WONTFIX as a sign of protest. Thank you.
Comment 11 Venomrush 2010-03-15 22:10:52 UTC
I believe we should reopen this bug.

Other SIP services support this feature, no reason why Skype (the major selling
point of the N900) shouldn't.

We have fix bugs related to this pause functionality previously.

(In reply to comment #9)
> the problem is one can't use my address book to dial telephone numbers with
> Skype.
> At lease fix it to the point where it will dial the phone number. 
> 
> I would be happy if it just dialed the number up to "P" but it wont dial at
> all. 

This is the main reason why I believe we should reopen as it does not dial a
contact's number stored in address book at all.
Comment 12 Venomrush 2010-03-15 22:58:44 UTC
Rewording summary and reopen.

Bug 5457 - "Skype: "Incorrect address" for phone numbers missing the country
code in Contacts" was fixed.

I strongly believe this bug should deserve the same treatment base on similar
behaviour. This is not a 'protest' :)
Comment 13 Andre Klapper maemo.org 2010-05-03 17:15:37 UTC
It is a WONTFIX for Nokia and reopening as a sign of protest will not change
this. It's not about what folks believe is good or not, it's about what project
management decides. Please understand. Thank you.
Comment 14 Tim Watt (reporter) 2010-05-05 00:48:32 UTC
Thanks for the update Andre,
As a consultant to Nokia you have a responsibility to promote there best
interests. It is understandable that you would advise this bug be wontfix in
the hope of getting things done. I believe your approach is hurting Nokia and
would advise you consider the best interests of all before reviewing issue with
Nokia staff.
Comment 15 Andre Klapper maemo.org 2010-05-05 01:10:34 UTC
Tim: I don't decide myself. I'm a messenger. I forward decisions.
(It's offtopic anyway here - feel free to contact Nokia Customer Care in case
of non-technical complaints or send me a private email, but here in Bugzilla is
simply the wrong place for this.)
Comment 16 Tim Watt (reporter) 2010-05-07 03:50:30 UTC
why is this WONTFIX? 

Does WONTFIX  mean its not broken?
or
The efort is not worth the reword?
Comment 17 Andre Klapper maemo.org 2010-05-07 12:29:34 UTC
Click the "Resolution" link and see:
https://bugs.maemo.org/page.cgi?id=fields.html#resolution
Comment 18 Andre Klapper maemo.org 2010-06-09 21:48:16 UTC
Reopening to hopefully get this fixed for Harmattan (the version after Maemo5).
Comment 19 Andre Klapper maemo.org 2011-05-05 17:32:06 UTC
This issue has been FIXED for Harmattan (the software version after Maemo5).

According to Nokia this unfortunately is a WONTFIX for Maemo5.