Bug 8319 - Loud beeps heard in Nokia BH-602 Bluetooth headset when answering call
: Loud beeps heard in Nokia BH-602 Bluetooth headset when answering call
Status: RESOLVED DUPLICATE of bug 7843
Product: Connectivity
Bluetooth
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-20 17:29 UTC by Tomas Walch
Modified: 2010-01-27 23:39 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tomas Walch (reporter) 2010-01-20 17:29:48 UTC
SOFTWARE VERSION:
2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Connect BT headset (mine is a Nokia BH-602), place it in your ear
2. Receive and answer incoming phone call

EXPECTED OUTCOME:
Call is active and I only hear the caller.

ACTUAL OUTCOME:
Initially I hear several (~3-6) loud quick beeps as well as the caller (or I
would hear the caller but the beeps are very loud)

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
When making a call there is just one beep which is annoying enough but
acceptable, and I guess by specification.
Used same headset with a N73 previously and didn't have this problem with
several beeps.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.33 Safari/532.0
Comment 1 Andre Klapper maemo.org 2010-01-20 21:03:33 UTC
Thanks for reporting this.

We'll need the bluetoothd debug logs and an hcidump to investigate this
further.

Some general info about the packages is available here:
http://wiki.maemo.org/Documentation/devtools/maemo5/syslog

The packages themselves are available from repository.maemo.org:
http://repository.maemo.org/pool/maemo5.0/free/

syslogd & klogd:
http://repository.maemo.org/pool/maemo5.0/free/s/sysklogd/

bluez-hcidump:
http://repository.maemo.org/pool/maemo5.0/free/b/bluez-hcidump/

You'll need to download and install (from the command line as root with dpkg -i
*.deb) the armel .deb files from those URL's.

In case you don't know how to get root privileges consult this page:
http://wiki.maemo.org/Root_access

Once you've installed the packages and rebooted your device, enable bluetoothd
debug logs with "killall -USR2 bluetoothd" (as root), perform the test and
gather any produced logs with "grep bluetoothd /var/log/syslog >
bluetothd-logs.txt". For HCI logs run "hcidump -XV" (also as root) while
performing the trace. If the HCI trace gets very long you can also create a
binary trace to a file with "hcidump -w hcidump.log -B"

(Note to myself only: int-139247)
Comment 2 Tomas Walch (reporter) 2010-01-22 09:29:02 UTC
This is a both very nice and a little annoying, but yesterday the headset
worked fine, and I have no clue as to why, I didn't do anything special other
than turning on and off. Before this I had this problem for almost two weeks,
since upgrading to 2009.51-1 (the problem didn't show because of this - I
wasn't using the headset before then, waiting for bug 6275 to be fixed). I
guess the mere knowledge of a bugreport being filed jinxed it back into proper
operation or something :-)

So I'm afraid I'm not able to assist with providing any debug logs if the
problem doesn't reappear. Just leave this as unconfirmed and I'll come back if
this happens.
Comment 3 Pekka Paunio 2010-01-27 16:30:52 UTC
Have the same problem. 

Also the callers complain about loud voices and/or hearing the ringtone of
answering N900 (2.2009.51-1).

My headset BH-602

Some times it works as it should but usually after some time with head phones
connected it starts working badly. After this a biref boot of BH-602 does not
change the situation.

It also seems that the head phones are active even when there is no call going
on (hear static).

Power consumption is also high, even though this situation seemed to improve
with the last firmware update.
Comment 4 Andre Klapper maemo.org 2010-01-27 23:39:39 UTC
This should be fixed internally now, see bug 7843 comment 4.

*** This bug has been marked as a duplicate of bug 7843 ***