Bug 8230 - cannot move message anywhere
: cannot move message anywhere
Status: RESOLVED FIXED
Product: Email
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-18 21:42 UTC by AB
Modified: 2010-03-15 20:56 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description AB (reporter) 2010-01-18 21:42:20 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. setup an IMAP account, send a message
2. navigate to local sent folder, tap to display sent message
3. tap "move"

EXPECTED OUTCOME:
Available folders show up as targets for the move operation immediately

ACTUAL OUTCOME:
Empty list, even after waiting about 1 minute

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
The only visible button is "New", however even a freshly-created folder will
not show up in the above list (though a second client on a desktop will see it
immediately). 

Also, I am pretty sure this was working fine in 1.2009.42-11, since I have used
this same functionality before on the same (own) IMAP server running Cyrus.

Might possibly be related to bug #7378


User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
Comment 1 AB (reporter) 2010-01-18 21:59:03 UTC
(In reply to comment #0)

> ACTUAL OUTCOME:
> Empty list, even after waiting about 1 minute

Interestingly, tapping "move" from the message list and selecting the same
message will show the available target folders, pronto
Comment 2 Andre Klapper maemo.org 2010-01-19 15:04:27 UTC
> 2. navigate to local sent folder, tap to display sent message
> 3. tap "move"

> Interestingly, tapping "move" from the message list

So what is what here, using the terms "long-tap context menu" and "title menu"
or something like that? :)
Comment 3 AB (reporter) 2010-01-19 15:35:33 UTC
(In reply to comment #2)

> So what is what here, using the terms "long-tap context menu" and "title menu"
> or something like that? :)

There is no long-tap action in the message list: I am talking about the title
menu in both cases, one in the message list and the other in the message view.
Comment 4 Sergio Villar Senin 2010-01-21 15:03:42 UTC
I can confirm that the bug existed and that we fixed it some time ago. Fix will
be delivered in PR1.2 update.
Comment 5 Andre Klapper maemo.org 2010-03-15 20:56:31 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).