Bug 8217 - Browser and Phone hangs in heavy flash based or picture based or browser downloading page
: Browser and Phone hangs in heavy flash based or picture based or browser down...
Status: RESOLVED WORKSFORME
Product: Browser
MicroB engine
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low major (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-18 17:18 UTC by First Knight
Modified: 2010-03-04 20:20 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description First Knight (reporter) 2010-01-18 17:18:34 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. go to facebook cafe world
2. cafe world loaded 100% but no respond after that
3. whole browser hangs which also caused the phone to hang

EXPECTED OUTCOME: to be able to access cafe world in n900

ACTUAL OUTCOME: browser and phone hangs.

REPRODUCIBILITY: always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS: Also, other website with heavy picture based and flash base
causes the phone to lag and hangs meaning no multiple task able to run. Even
when loading page it will cause it to lag and hangs.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-18 17:43:05 UTC
Thanks for reporting this.
This report isn't very useful because it doesn't describe the problem well. If
you have time and can still reproduce the problem, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add a more useful
description to this bug.
As written: Explain in detail what you do (e.g. tap on OK) and what you see
(e.g. message Connection Failed appears). Click by click.
Comment 2 First Knight (reporter) 2010-01-18 17:48:09 UTC
Dear Andre,

Well I dont have to click anything...

I just have to let it load until 100% and thats it, no more activity. Which
will then hang the browser and then lag the phone.
Comment 3 First Knight (reporter) 2010-01-18 17:49:48 UTC
In addition, to feel the phone hang I have click the top left corner to get
into the dashboard or multiple task window. It doesnt respond. When it does it
runs very slowly. When able to get onto the home screen. When scrolling left or
right it lags heavily...
Comment 4 Andre Klapper maemo.org 2010-01-18 17:53:38 UTC
> 1. go to facebook cafe world
> 2. cafe world loaded 100% but no respond after that

I have no idea what "Facebook cafe world" is. Hence the request to provide
exact steps...
Comment 5 First Knight (reporter) 2010-01-18 18:03:05 UTC
ok... thanks for the clarification.

Go to facebook.com
launch app/game cafe world by zynga
page loaded but the said game not loaded. I think it uses some script or java I
dont know.
So game will load till 100% as shown in the middle of the game screen.
During this you cant do anything much as the phone is lagging and the browser
is hanging too.
After reaching 100%, cant do anything at all. Browser hangs caused the phone to
hang too. Will need a long time before i can shut it down and a pop up stating
shut down browser as it is no longer responsive.
clicking yes also very lag.
after a long time it will eventually shut down.

hope this gives better picture...
Comment 6 First Knight (reporter) 2010-01-19 05:35:18 UTC
I would like to add further...

Running the browser seems to take alot of resources on the n900 if not
restarted at all.

For example. Connection used: 3G/wifi
Running facebook game castle wars.
Browser response laggy. 
I tried to click the bottom right to bring up the top header so I could click
the left top to view multiple app page, but it takes very long until it show
browser unresponsive ask me to close or not.
If i were lucky enough to get another new window up with gmail the whole
browser hangs and even the phone lags and would eventually hangs but it wont
come to a point i have to take out the batt. I just have to wait long before it
would respond again.

NOw i just recently found something interesting.
I have to restart the phone and everything seems to run smoothly.
Restart = off the phone. take out the battery. place back the batt. start the
phone.

Usual usage:
the Phone is on for 24/7 so basically no restart of the phone is made.
Comment 7 Andre Klapper maemo.org 2010-01-23 19:42:30 UTC
I simply don't play Facebook Games.
If you can provide complete exact steps to reproduce (click by click, in a
numbered list) somebody could try to reproduce, otherwise this will end up as
"cannot reproduce".
Comment 8 First Knight (reporter) 2010-01-24 10:24:37 UTC
(In reply to comment #7)
> I simply don't play Facebook Games.
> If you can provide complete exact steps to reproduce (click by click, in a
> numbered list) somebody could try to reproduce, otherwise this will end up as
> "cannot reproduce".
> 

ok give me few more hours let me try reproducing it put in numbered stepa.

thanks
Comment 9 First Knight (reporter) 2010-01-25 04:49:45 UTC
ok manage to reproduce.

maemo rss feed app running
start web app go to phonedog.com
page fully loaded
go to botom of page right side to subscribe feed
click new videos only
new page opens
new page loading cant do anything - phone hangs
continue to let it load phone goes to standby mode
use the unlock slide on the right - no response
take a long time to get my phone response 
screen shows up and show web site not responding ask to close or not.
click either yes or no -no response
when respond tht would be after some time...
manage to shut the web page down...
phone less responsive but will gain normal respond after some time
Comment 10 Andre Klapper maemo.org 2010-02-16 20:17:57 UTC
(In reply to comment #9)
> click new videos only
> new page opens
> new page loading cant do anything - phone hangs

"phone" means the N900? Writing "phone" is very confusing as it is an
application on the N900 too...
I cannot reproduce this here, neither with 3.2010.02-8 nor with internal
version 2010.06-13.

> EXTRA SOFTWARE INSTALLED:

Which other software do you have installed?
Comment 11 First Knight (reporter) 2010-02-17 04:06:54 UTC
thanks for your response.

the phone i refer here is n900 and no other application and software.

Software installed. Kindly advice abit more on this as i have installed quite a
few software. Is there anyway to give you a log of software that is running on
background and installed?
Comment 12 Andre Klapper maemo.org 2010-03-04 20:20:49 UTC
(In reply to comment #9)
> maemo rss feed app running
> start web app go to phonedog.com
> page fully loaded
> go to botom of page right side to subscribe feed
> click new videos only
> new page opens
> new page loading cant do anything - phone hangs

Tried this both with 3.2010.02-8 and internal version 10.2010.08 and cannot
reproduce. Could use taskswitcher all the time, for example.

> continue to let it load phone goes to standby mode
> use the unlock slide on the right - no response

Again, this both worked fine for me. I can only imagine that something else
running on your N900 slows done performance...