Bug 820 - tablet restarting randomly when using WLAN, maybe related to WPA?
: tablet restarting randomly when using WLAN, maybe related to WPA?
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 2.0
: All Maemo
: Medium critical (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2006-10-28 18:48 UTC by Klaasjan Brand
Modified: 2008-02-29 11:24 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Klaasjan Brand (reporter) 2006-10-28 18:48:19 UTC
I've recently replaces my network access point (11Mbit,WEP) with a new one
(54g,WPA). Since then, my 770 randomly reboots when (I think) it's transferring
big amounts of data (application installer, browsing a site with a lot of
images, buffering an audio stream). FI: pressing the full-screen button when
loading a web site with a lot of images often reboots the device.

The /proc/bootreason file states the 32wd_to watchdog resetted the device. Maybe
it's not fast enough to run some software, transfer data using encryption and
keep the watchdog satisfied?

Suggestions on how to track this problem are welcome.
Comment 1 Klaasjan Brand (reporter) 2006-11-03 23:17:25 UTC
Upgraded my 770 to 2006SE_2.2006.39-14 firmware. Still the same problem.
After reboot /proc/bootreason contains "32wd_to", /var/lib/dsme/stats/32wd_to
contains "2".
Every time the tablet restarts it's during heavy data transfers (had to try
multiple times before it could download the python runtime without crashing).
CPU load is 100% which could explain the watchdog reset.
Comment 2 mike 2006-11-08 18:19:42 UTC
Me too.  Happens about half of the time I download a specific 1MB package with
opera but never when I scp the file over.
Comment 3 Tero Saarni 2006-12-17 15:14:57 UTC
I seem to be experiencing this problem too.  
Software level 2.2006.39-14 and WPA encryption enabled (with 
Linksys WRT54G access point)
  
Browsing web sites with Opera triggers 32wd_tp watchdog initiated 
reboots randomly as often as once per ~10 minutes or so rendering
the device completely unusable.

Disabling WLAN encryption seems to work as a short term workaround
but an actual bugfix is needed asap!
Comment 4 Kalle Valo nokia 2007-01-12 17:46:04 UTC
(In reply to comment #2)
> Me too.  Happens about half of the time I download a specific 1MB package with
> opera but never when I scp the file over.

I usually use just iperf for stress testing, but I'll have to try with opera too.

Few remarks to all reporters of this bug:

o always report the OS version, eg. 2006SE_2.2006.39-14
o also try to report encryption algorithm used if possible (open, WEP, TKIP, AES)
o also some info about AP would be nice

That way I can try to narrow down where the bug exactly is. Thanks for your help.

I'll transfer this bug to Connectivity, so that it won't get lost.
Comment 5 mike 2007-01-12 18:25:59 UTC
It honestly feels more like the N770 fills up the memory based /tmp and linux's
oom killer shoots down the window manager.  When it "crashes" the N770 stops
accepting input for a few seconds, applications start closing, and then it
reboots.  It's happened on several N770 devices but not on one other.  IIRC the
ones I've seen it happen on have swap enabled and the fine one does not have swap.

If the N770 is doing soft WPA I wonder if it's passing multiple packets to the
stack at the same time leading to a larger socket read and then a larger file
descriptor write.

I'm using a linksys wrt54g too; IIRC it's set up with WPA2.
Comment 6 Kalle Valo nokia 2007-01-12 18:29:32 UTC
(In reply to comment #5)
> It honestly feels more like the N770 fills up the memory based /tmp and linux's
> oom killer shoots down the window manager.  When it "crashes" the N770 stops
> accepting input for a few seconds, applications start closing, and then it
> reboots.  It's happened on several N770 devices but not on one other.  IIRC the
> ones I've seen it happen on have swap enabled and the fine one does not have swap.

This sounds like different issue, not a kernel crash which was originally
reported here. Can you check the reboot reason after the crash. Instructions are
here:

http://maemo.org/maemowiki/ReportingRebootIssues
Comment 7 Siarhei Siamashka 2007-01-12 21:19:04 UTC
Hi Kalle, first I'm glad that this issue report finally reached the right
person, so we can hope for some resolution now.

Please take a look at my old post in the other bugreport which seems to be a
duplicate of this one: https://maemo.org/bugzilla/show_bug.cgi?id=677

[cut]
This bug may be probably related to the following issue.

Initially reported as:
http://maemo.org/pipermail/maemo-developers/2006-September/005527.html

Can be relatively easy reproduced with 'memtester' program (all three developers
including me who tried to test it, managed to reproduce it):
http://maemo.org/pipermail/maemo-developers/2006-September/005608.html
http://maemo.org/pipermail/maemo-developers/2006-September/005620.html

Final comment which contains information, that lets us make a conclusion that
there is a high probability that it is actually related to wifi (buggy wifi
driver?):
http://maemo.org/pipermail/maemo-developers/2006-September/005633.html
[/cut]

I noticed this random memory corruption problem when working in ssh session over
wifi connection when testing the application I was porting to Nokia 770
(mplayer). It resulted in occasional random crashes and reboots. Now I stopped
using wifi for any development or testing and switched to usbnet. As a long time
has passed already and these nasty problems don;t show up again, I'm almost
certain that they are wifi related (and not hardware fault, bad memory or
something else), 

I was using ASUS WL-520G wireless router, firmware version 1.9.5.4 (router
settings: 54G only, 54g Protection, WPA-PSK, TKIP, Hide SSID "yes", Enable Frame
Bursting "enabled"), 1.2006.26-8 OS version (and still using it as I can't find
time for upgrade), WPA pre-shared key, hidden network, WPA2-only mode box unchecked.

If you need any additional information or can't reproduce the same problem on
your setup, don't hesitate to ask. I may also upgrade OS and run the tests again
in it, but only if you are interested in getting these results.
Comment 8 Kalle Valo nokia 2007-02-01 09:37:37 UTC
A new firmware of OS 2006 was released last week:

http://maemo.org/pipermail/maemo-announce/2007-January/000034.html

It contains few WLAN fixes and especially one which I hope to fix the crashes.
But I cannot be sure because I haven't been able to reproduce the problem myself.

Klaasjan and others seeing the crashes: could you please test the new firmware
and send your feedback here? Thanks.
Comment 9 Tero Saarni 2007-02-01 11:49:08 UTC
(In reply to comment #8)
> Klaasjan and others seeing the crashes: could you please test the new firmware
> and send your feedback here? Thanks.

I have tested the new firmware in network with Linksys WRT54G + WPA where 
I previously had frequent crashes.  There hasn't been any crashes after 
upgrading, so I think you nailed the problem, thanks!
Comment 10 Klaasjan Brand (reporter) 2007-02-04 12:39:56 UTC
I've used the new firmware for a few hours now, including lots of network I/O
from re-downloading all my packages, and haven't seen the tablet reboot. I guess
the fix is working ;)
Thanks for making my tablet a lot more usable!
Comment 11 Tilman Vogel 2007-09-17 18:53:12 UTC
This bug may be related to bug 2006 for which I did some analysis and found a
workaround.
Comment 12 Siarhei Siamashka 2008-02-29 11:24:19 UTC
Marked it as FIXED as it is almost certainly a duplicate of bug 2006