Bug 8194 - General locale settings for new users does not set the correct locale for text input
: General locale settings for new users does not set the correct locale for tex...
Status: RESOLVED FIXED
Product: Settings and Maintenance
Startup wizard
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: startup-wizard-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-18 12:05 UTC by Otto Kekäläinen
Modified: 2010-03-15 20:56 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Otto Kekäläinen (reporter) 2010-01-18 12:05:48 UTC
EXACT STEPS LEADING TO PROBLEM: 
1. Take a brand new out-of-the-box N900 shipped in January 2010
2. Start it and then it asks for you language and locale fill in
Finnish/Finland.
3. In settings, go to text input and check what language is in use.

EXPECTED OUTCOME:
The vocabulary used by text input should be by default the same as the language
a new user chose, in this case Finnish.

ACTUAL OUTCOME:
The vocabulary was "English".

REPRODUCIBILITY:
I don't know, since I can't rerun the new user settings dialog that appears
when one opens a brand new N900. I guess somebody at Nokia could reproduce this
with ease..
Comment 1 Andre Klapper maemo.org 2010-03-09 16:58:20 UTC
Trying to reproduce here with the latest internal release:

I reflashed my loan N900 from Maemo Summit in Amsterdam with English/Dutch
hardware keyboard layout, hence it defaults to Dutch in the interface after
starting it.
By doing this, language proposal in the start screen is reset to "Nederlands
(Nederland)", but it somehow correctly remembers my Region setting "Ceska
Republika" here.
Anyway, in that dropdown I choose Language == "Suomi (Suomi)". Region (Alue)
also gets reset to "Suomi". I click "Apply" (Tallenna) and let the UI start.
Then I go to "Application Menu > Settings > Text Input" (Asetukset >
Tekstinsyöttö).
1st language (1. kieli) is set to "Suomi (Suomi)",
2nd language (2. kieli) is set to "English (United Kingdom)" (the latter is by
default a new setting in PR1.2 and hence not a bug).

Hence I'd say that this will be fixed in the next public release (PR1.2).
Comment 2 Andre Klapper maemo.org 2010-03-15 20:56:05 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).