Bug 8188 - (int-153454) Cannot delete a mobile internet connection
(int-153454)
: Cannot delete a mobile internet connection
Status: NEW
Product: Connectivity
Networking
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal with 7 votes (vote)
: ---
Assigned To: unassigned
: networking-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-18 09:17 UTC by Matt Giuca
Modified: 2011-04-19 16:55 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Matt Giuca (reporter) 2010-01-18 09:17:36 UTC
SOFTWARE VERSION: 5.0/2.2009.51-1.002

EXACT STEPS LEADING TO PROBLEM:
1. Open Settings -> Internet Connections
2. Tap "Connections"
3. Select a Mobile Internet connection

EXPECTED OUTCOME: I can press the Delete button to delete such a connection,
like I can with WLAN connections.

ACTUAL OUTCOME: The Delete button is greyed out.

REPRODUCIBILITY: Always

EXTRA SOFTWARE INSTALLED: N/A

OTHER COMMENTS: I'm not sure if there is a good reason for this. It's not like
the Mobile Internet connections come pre-loaded from the factory -- I installed
them myself, so I should be able to delete them myself.
Comment 1 Andre Klapper maemo.org 2010-01-18 13:38:36 UTC
Thanks for reporting this.
Confirming.
Comment 2 EC 2010-01-18 13:45:25 UTC
I think that the connection is permanent because it comes from your SIM, so you
can't delete it. It would be nice to delete, because I don't use it and it
happens to select it by mistake, but I think this will be resolved as INVALID
(hope it won't).
Comment 3 Matt Giuca (reporter) 2010-01-19 02:38:59 UTC
> I think that the connection is permanent because it comes from your SIM, so you
> can't delete it.

Do you mean it is *stored* on the SIM, or it was *copied* from the SIM?

If it's stored on the SIM, then it's fair enough, because it means my phone
company put it there, and I shouldn't delete it (it's not part of the phone's
business).

If it was copied from the SIM, then I should still be able to delete it, and if
necessary, copy it again. Otherwise, what if I change the SIM card? Am I stuck
with this mobile connection forever?

In any case, I didn't get mine off the SIM. I got my phone company (Virgin
Mobile Australia) to send it to my phone via SMS, and then I installed it. That
sort of thing should be deleteable.
Comment 4 EC 2010-01-19 10:32:16 UTC
I mean stored in the SIM, but after reading your experience I've changed my
mind. If you got that connection with an SMS, it should be definitely
deletable, and this is a proper bug. I'll vote for it
Comment 5 Venomrush 2010-03-09 18:06:55 UTC
*** Bug 9475 has been marked as a duplicate of this bug. ***
Comment 6 Venomrush 2010-03-09 18:07:56 UTC
I have added a new APN via fAPN (in Extras) but now unable to delete the
manually created APN. And because of bug 5791 I cannot set the default
carrier's APN so that I can set that APN under 'Connect automatically'

Under 'Connect automatically' it only shows my manually created APN
Comment 7 Mark 2010-05-20 21:42:10 UTC
Exact the same Probleme for me.

Firmware Version 3.2010.02-8- PR 1.1.1
Comment 8 Markus Silvan nokia 2010-05-31 13:58:08 UTC
As a workaround you can use the terminal.
You can list all the access points with
gconftool-2 -R /system/osso/connectivity/IAP

And remove one with
gconftool-2 --recursive-unset /system/osso/connectivity/IAP/<accesspointname>
Comment 9 Mark 2010-05-31 21:15:40 UTC
(In reply to comment #8)
> As a workaround you can use the terminal.
> You can list all the access points with
> gconftool-2 -R /system/osso/connectivity/IAP
> 
> And remove one with
> gconftool-2 --recursive-unset /system/osso/connectivity/IAP/<accesspointname>

Thx, Markus Silvan for this usefull easy workaround!
Comment 10 Andre Klapper maemo.org 2010-06-04 10:45:02 UTC
*** Bug 10545 has been marked as a duplicate of this bug. ***
Comment 11 discoveryellow 2011-04-19 03:36:16 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > As a workaround you can use the terminal.
> > You can list all the access points with
> > gconftool-2 -R /system/osso/connectivity/IAP
> > 
> > And remove one with
> > gconftool-2 --recursive-unset /system/osso/connectivity/IAP/<accesspointname>
> 
> Thx, Markus Silvan for this usefull easy workaround!

I just tried it for a similar issue (unable to delete user created GPRS AP,
from fMMS app). In my case here running the suggested command with AP name
(without "<>" - Right?) does not do anything.

Please share suggestions, thanks!
Comment 12 discoveryellow 2011-04-19 16:55:08 UTC
clearly I noob-ed, having just got my N900 a few days ago and with no skills at
programming.

The workaround works like a charm, once you know what to plug in for access
point name, which is not user created name (duh, which i tried), but the long
value string at the top of the access point. in my example it was
ef07f50f-f7c1-4ef8-b30f-fbfb056de734

Hopes this helps other noobs.