Bug 8165 - gst-video-thumbnailerd locks a media playback even for files from camera application
: gst-video-thumbnailerd locks a media playback even for files from camera appl...
Status: RESOLVED DUPLICATE of bug 6823
Product: Media player
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified major with 17 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-17 23:40 UTC by egoshin
Modified: 2010-05-26 23:07 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description egoshin (reporter) 2010-01-17 23:40:03 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. download a lot of video/movie files in different formats and in different
codecs
2. make some video shots via Maemo camera application
2. install Extra Codec Support and KMPlayer
3. start testing a video playback via Maemo media player in sequence - some
file, then camera video shot, then another file, another video shot etc

EXPECTED OUTCOME:

Video plays and unsupported video format and codecs doesn't play.

ACTUAL OUTCOME:

Video plays inconsistently - sometime it plays, sometime not in both - Maemo5
media player and KMPlayer. After reboot it usually plays but later it may start
showing "unsupported codec" in Maemo5 media player EVEN FOR BACKSIDE CAMERA
SHOTS MADE BY MAEMO5 CAMERA APPLICATION. And very often it stacks - no video
plays at all beyond .flv codec shots.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always, but unpredictable and codec files mix difficult to describe

EXTRA SOFTWARE INSTALLED:

KMPlayer, Extra Codec Support/Ogg support, mpeg2dec, gstreamer0.10-tools.
Packages gstreamer0.10-plugins-ugly and libxvidcore4 were installed on 42-11
and removed the same day yet long before upgrade to 44-1 and 51-1.

OTHER COMMENTS:

If I kill gst-video-thunbnailerd then the problem disappears - all video
playback start predictably in KMPlayer. Unfortunately, if I start an official
Maemo5 media player it automatically starts gst-video-thumbnailerd and problem
starts showing again.

This bug actually can be a source of multiple problems - fast battery drain,
slow response (gst-video-thumbnailerd consumes CPU resource) and different
intermittent video playback problems including video streaming freeze.

Also, if somebody advices me how to hide video files from
gst-video-thumbnailerd or switch ON debug/log in it I can find which codec/file
format is responsible. Unfortunately, it is very time-consuming to erase
file-by-file and transfer it from PC to N900.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8)
Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Comment 1 sierrafoxtrot 2010-01-18 13:00:27 UTC
Seems to be associated with gst-video-thunbnailerd locking up on unsupported
files. Can be side-stepped by ONLY having supported files on phone (or editing
tracker.cfg to not index certain folders where you store unsupported mp4s, mkvs
etc), and deleting tracker entries and restarting tracker.
Comment 2 Andre Klapper maemo.org 2010-01-18 19:47:39 UTC
Looks a lot like bug 6823 to me, also because of the thumbnail issue that I've
seen - do you agree it's a duplicate?
Comment 3 sierrafoxtrot 2010-01-18 19:58:07 UTC
(In reply to comment #2)
> Looks a lot like bug 6823 to me, also because of the thumbnail issue that I've
> seen - do you agree it's a duplicate?
> 

yes it looks like a duplicate but that bug report (6823) isn't particularly
specific.
Comment 4 egoshin (reporter) 2010-01-18 20:06:02 UTC
(In reply to comment #1)
> Seems to be associated with gst-video-thunbnailerd locking up on unsupported
> files. Can be side-stepped by ONLY having supported files on phone (or editing
> tracker.cfg to not index certain folders where you store unsupported mp4s, mkvs
> etc), and deleting tracker entries and restarting tracker. 
> 

It is impossible to delete - I have a lot of files on my mSDHC and I don't know
which one. I have suspicion ... some camcoder shots... but no knowledge exactly
which one - hundreds shots and from 4 different camcoders. Including some anime
too. 

BTW, how to prevent gst-video-thumbnailerd from searching some directories? I
tried to do it in tracker.cfg and it seems that it works for regular tracker
but not for video. I configured "EnableThumbnails=false" and restarted tracker
with DB removal. After I started media player it had no thumbnails but after
first or second playback the whole bunch of thumbnails pops up and I observed
gst-video-thumbnailerd running.
Comment 5 egoshin (reporter) 2010-01-18 20:12:10 UTC
(In reply to comment #2)
> Looks a lot like bug 6823 to me, also because of the thumbnail issue that I've
> seen - do you agree it's a duplicate?
> 

It depends from which kind of resolution would be for 6823. Because it seems in
my N900 divx / xvid are not a problem - all of them plays fine. It is something
else and actually it may be not a video file but some another file which is
taken as video by gst-video-thumbnailerd. I suspect so because in my media
player I see thumbnails for some video files which media player rejects to play
("unsupported codec").
Comment 6 egoshin (reporter) 2010-01-18 20:16:23 UTC
BTW, new additional info - I noted that gst-video-thumbnailerd grows in memory
size before anything stacks in media player - once it reached 160MB memory. And
typical size easily reaches 80MB.
Comment 7 sierrafoxtrot 2010-01-18 20:31:27 UTC
(In reply to comment #4)
> (In reply to comment #1)
> > Seems to be associated with gst-video-thunbnailerd locking up on unsupported
> > files. Can be side-stepped by ONLY having supported files on phone (or editing
> > tracker.cfg to not index certain folders where you store unsupported mp4s, mkvs
> > etc), and deleting tracker entries and restarting tracker. 
> > 
> 
> It is impossible to delete - I have a lot of files on my mSDHC and I don't know
> which one. I have suspicion ... some camcoder shots... but no knowledge exactly
> which one - hundreds shots and from 4 different camcoders. Including some anime
> too. 
> 
> BTW, how to prevent gst-video-thumbnailerd from searching some directories? I
> tried to do it in tracker.cfg and it seems that it works for regular tracker
> but not for video. I configured "EnableThumbnails=false" and restarted tracker
> with DB removal. After I started media player it had no thumbnails but after
> first or second playback the whole bunch of thumbnails pops up and I observed
> gst-video-thumbnailerd running.
> 

maybe you don't have to delete, you can just create a folder and drag all of
\MyDocs\.video in there except files that you are certain are supported, edit
tracker.cfg to not index this folder and move them back slowly to MyDocs and
see which one's are the cause of the problem. 

i tried editing EnableThumbnails=false as well but it looks like the
mediaplayer will always index the .video folder (unless you edited tracker.cfg
so that it doesn't). however, it does not index my no-watch folders so i am ok
there and i have no more problems with my media. i have encoded several movies
to mp4 x264 (x264.exe: --crf 19.0 --level 3.0 --no-cabac --no-mixed-refs
--bframes 0 --direct none --b-adapt 0 --no-weightb --weightp 0 --trellis 0
--partitions p8x8,b8x8,p4x4 --no-8x8dct --subme 5 --sar 1:1 --output
"C:\Temp\0032.264" "C:\Temp\0032.avs"), HE-AAC 96kbps, no chapters) and have
not had any more issues.
Comment 8 egoshin (reporter) 2010-01-18 20:34:00 UTC
BTW, I want to take your attention that gst-video-thumbnailerd consumes CPU at
this stage. Not very big (around 1%) but taken into account that "top" doesn't
record an activity of graphic accelerator that may be a reason of unexpected
battery drain by graphic logic in OMAP3 and device warming as a result. I refer
to bug 8004 (and - possibly - to bug 6615).
Comment 9 egoshin (reporter) 2010-01-18 20:39:17 UTC
(In reply to comment #7)

> i tried editing EnableThumbnails=false as well but it looks like the
> mediaplayer will always index the .video folder 

... and /media/mmc1/video (w/out dot) as well :)
Comment 10 Ali 2010-01-19 22:36:44 UTC
any one a solution??

please help me my media player on N900 doesnt work any more wht should i do now
i cant live without it!!

so please help me!!
Comment 11 Andre Klapper maemo.org 2010-01-20 12:57:34 UTC
(In reply to comment #10)
> any one a solution??
> please help me my media player on N900 doesnt work any more wht should i do now
> i cant live without it!!
> so please help me!!

Ali: Please note that maemo.org Bugzilla is not a support forum — it is a bug
tracking system for software errors. Such comments are unhelpful. Please ask
support questions in a forum like http://talk.maemo.org .
Comment 12 Ndi 2010-01-21 20:20:10 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Andre Klapper maemo.org 2010-03-05 12:36:29 UTC
I think this is the same issue as bug 6823 that will be fixed in the next
public update.

*** This bug has been marked as a duplicate of bug 6823 ***
Comment 14 egoshin (reporter) 2010-05-26 23:07:21 UTC
Bug fixed in PR1.2