Bug 8161 - Media player widget does not receive Bluetooth headset events
: Media player widget does not receive Bluetooth headset events
Status: RESOLVED DUPLICATE of bug 5331
Product: Desktop Widgets
Media player
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified major (vote)
: ---
Assigned To: unassigned
: mediaplayer-applet-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-17 22:36 UTC by Vladimir Oka
Modified: 2010-04-21 22:48 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vladimir Oka (reporter) 2010-01-17 22:36:19 UTC
SOFTWARE VERSION:
2.2009.51-1.203.2

EXACT STEPS LEADING TO PROBLEM: 
1. Put media player widget on desktop.
2. Connect Bluetooth headset (in my case Nokia BH-214).
3. Make sure Media Player is NOT running, but there are songs in current
playlist.
4. Make sure MP widget works (see:
https://bugs.maemo.org/show_bug.cgi?id=7909).
5. Try to use play/forward/back buttons on the headset.

EXPECTED OUTCOME:
Media Player start playing/advances/backtracks through playlist. Also being
able to use BT headset controls if the playback has been started manually.

ACTUAL OUTCOME:
Nothing happens. Control impossible even if playback is started manually via
the widget. One needs to start the whole Media Player and leave it in the
background if one is to use BT headset controls.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
A few non-Nokia supplied widgets; list similar to Radu's in #7909.

OTHER COMMENTS:
This issue affects the usability of stereo Bluetooth headsets a great deal. Use
case: have BT on all the time on N900, try using BT headset to listen to
music/answer calls without getting N900 out of the pocket --> impossible!

The only workaround currently is to start Media Player and leave it running in
the background.

This may be related to bug #7909 (link above) if the root cause is that events
in general (i.e. both screen tap and bluetooth events) are not passed to
widgets if non-Nokia provided widgets are used (I use a similar list of widgets
as Radu in #7909).
Comment 1 Andre Klapper maemo.org 2010-01-20 22:49:40 UTC
So does that mean if you do not use any other widgets then this issue does not
happen?
Comment 2 Vladimir Oka (reporter) 2010-01-20 22:58:56 UTC
(In reply to comment #1)
> So does that mean if you do not use any other widgets then this issue does not
> happen?
> 

Sorry, the last paragraph was a bit of musing, obviously uninformed. :(

I've just tried this:

- remove all widgets but MP
- reboot
- enable BT
- connect BH-214
- press play on headset
* nothing happens
- press next on headset
* nothing happens
- press previous on headset
* nothing happens
- double press call/answer on headset
*** nothing happens

This last thing is (possibly) a separate bug, as double press on the
call/answer button should dial the last dialled number? Let me know if this is
correct and I'll raise a new bug for it. ;)
Comment 3 Andre Klapper maemo.org 2010-03-01 19:10:16 UTC
Hmm, why are you sure that play/forward/back buttons on the headset are
supported at all? Is this described somewhere for the BH-214?
Comment 4 Vladimir Oka (reporter) 2010-03-01 20:06:28 UTC
(In reply to comment #3)
> Hmm, why are you sure that play/forward/back buttons on the headset are
> supported at all? Is this described somewhere for the BH-214?
> 

They seem to be supported by Media Player proper. If it is running, even in the
background, I have full control using my BH-214: play/forward/back/answer call.
So I expected MP widget to do the same. 

Obviously no idea how it is implemented, but I was imagining it is intercepting
the same events as MP proper (maybe even using the same engine/subsystem) and
passing them on to MP daemon and/or palyer. Anyway, this is just my musings...

As a side note, the usual double press on answer button does not re-dial last
dialled number, but that's something that I may at some point raise for the
Phone app.
Comment 5 Andre Klapper maemo.org 2010-04-19 16:38:29 UTC
Does this still happen in 3.2010.02-8 for you?

Which exact extra software is installed? Extra Decoders Support or Touchsearch?

Does this work correctly when you use the Media Player itself and have it in
the foreground, instead of using the desktop widget?
Comment 6 Vladimir Oka (reporter) 2010-04-19 17:21:10 UTC
(In reply to comment #5)
> Does this still happen in 3.2010.02-8 for you?

Yes.

> Which exact extra software is installed? Extra Decoders Support or Touchsearch?

Lots. Toomany to list but Extra Decoders yes, Touchsearch, no.
I'll happily reply to additional yes/no questions. ;)

> Does this work correctly when you use the Media Player itself and have it in
> the foreground, instead of using the desktop widget?

Yes. When Media Player is running, back- or foreground all commands from the
headset are acted upon correctly (see my previous comment). Problem occurs only
if MP is not running, and playback is started from MP widget. This apparently
just starts the MP deamon, as MP proper is not seen as being active.
Comment 7 Andre Klapper maemo.org 2010-04-21 19:52:45 UTC
I'm wondering if this is a duplicate of bug 5331.
Comment 8 Vladimir Oka (reporter) 2010-04-21 22:29:51 UTC
(In reply to comment #7)
> I'm wondering if this is a duplicate of bug 5331.
> 

It sure does... I also see it's fixed in PR 1.2
Now, just if we knew when that one's coming... ;)
Comment 9 Andre Klapper maemo.org 2010-04-21 22:48:55 UTC
Heh, your crystal ball is also broken? Darrn! :-P

*** This bug has been marked as a duplicate of bug 5331 ***