Bug 8159 - (int-146770) Missing direct shortcut to use SIP/Skype again in Recent Calls list
(int-146770)
: Missing direct shortcut to use SIP/Skype again in Recent Calls list
Status: RESOLVED FIXED
Product: Contacts
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 7 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-17 20:02 UTC by Sergey Vlasov
Modified: 2010-06-29 16:35 UTC (History)
13 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Sergey Vlasov (reporter) 2010-01-17 20:02:35 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Make a call using SIP
2. In recent calls select that call entry

EXPECTED OUTCOME:
Can call again using SIP.

ACTUAL OUTCOME:
Instead of SIP, Phone and SMS options are there.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
no

OTHER COMMENTS:
It's not a duplicate of bug 7380.
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7
Comment 1 wierdo 2010-01-18 02:19:44 UTC
I don't see this. If I have a SIP call from/to an address not in my contacts
listed in the recent calls list, I can tap on it and get the call/chat popup.
If I tap call, the device places a SIP call.

It says "Phone," but will really place the call over whatever transport the
call originally came in (or went out) on.
Comment 2 Sergey Vlasov (reporter) 2010-01-18 11:31:56 UTC
Not for me, it says "Phone" and it uses GSM when calling, not SIP. I might
record a screencast or something showing the bug.
Comment 3 Venomrush 2010-01-18 12:21:43 UTC
(In reply to comment #2)
> Not for me, it says "Phone" and it uses GSM when calling, not SIP. I might
> record a screencast or something showing the bug.
> 

Erm then you are probably mistakenly making a GSM call and not a SIP call. 
Because if you call using SIP, it'll show SIP icon and not a phone icon.
Comment 4 Venomrush 2010-01-18 12:23:29 UTC
Oh right, I get it now, you want to recall that contact using SIP

Well that's bug 8033 because Phone UI at the moment does not allow to make SIP
calls in recent call list.
Comment 5 Sergey Vlasov (reporter) 2010-01-18 12:31:45 UTC
(In reply to comment #3)
> Because if you call using SIP, it'll show SIP icon and not a phone icon.

That's true, the call entry has a SIP icon but it calls by GSM.


(In reply to comment #4)
> Oh right, I get it now, you want to recall that contact using SIP
> 
> Well that's bug 8033 because Phone UI at the moment does not allow to make SIP
> calls in recent call list.
> 

Yeah, that seems to be a similar issue.
Comment 6 Sergey Vlasov (reporter) 2010-01-18 12:36:42 UTC
(In reply to comment #4)
> Oh right, I get it now, you want to recall that contact using SIP

Just to clarify, not necessarily using SIP, I wan to recall the same way the
call was made at the first place. There is no problem with Google Talk or Skype
because it offers to use those protocols to recall, unfortunately for SIP call
it doesn't.
Comment 7 wierdo 2010-01-18 12:38:01 UTC
Let me state that again:

1. I receive or dial a call over SIP
2. Time passes, seasons change
3. I look at my call log and select the call that came in over sip (with a SIP
icon next to it)
4. Menu pops up with "Call," "Chat," "Merge with contact", and "New contact"
5. I tap Call
6. A SIP call is made to that number

What I am seeing now is that _one_ of the entries in my call log does that.
None of the others do. Odd.
Comment 8 Sergey Vlasov (reporter) 2010-01-18 12:43:30 UTC
(In reply to comment #7)
> Let me state that again:
> 
> 1. I receive or dial a call over SIP
> 2. Time passes, seasons change
> 3. I look at my call log and select the call that came in over sip (with a SIP
> icon next to it)
> 4. Menu pops up with "Call," "Chat," "Merge with contact", and "New contact"
> 5. I tap Call
> 6. A SIP call is made to that number
> 
> What I am seeing now is that _one_ of the entries in my call log does that.
> None of the others do. Odd.
> 

Please try to call or receive a SIP call from somebody who is in your contacts
already, that way there won't be "Call," "Chat," "Merge with contact", and "New
contact" popup menu.
Comment 9 Venomrush 2010-01-18 13:04:02 UTC
(In reply to comment #6)

> I wan to recall the same way the
> call was made at the first place. 

I don't think this is possible, it's a complete change to the current Phone UI.

At the moment, tapping the contact in recent contacts list brings up their
contact card. 

Recent call list is effectively Contact UI with 'Recent' mode set.
Comment 10 wierdo 2010-01-18 13:07:31 UTC
OK.

1. Tap the call log entry.
2. See popup with the avatar, Phone, and SMS
3. Tap avatar
4. Tap the newly appeared "SIP audio" button

If the contact has a SIP address listed and the call log was generated by the
SIP client, that will appear instead of phone and SMS (and sip audio), for what
it's worth.

In any event, tapping the avatar gives you access to all the contact's
available contact methods.
Comment 11 Sergey Vlasov (reporter) 2010-01-18 13:15:45 UTC
(In reply to comment #9)
> (In reply to comment #6)
> 
> > I wan to recall the same way the
> > call was made at the first place. 
> 
> I don't think this is possible, it's a complete change to the current Phone UI.

It is already implemented. You tap a call entry, a popup menu appears with
options to recall the same way. If you want to see the whole contact card you
just tap it's picture on the left, from here you can choose other options to
communicate.


(In reply to comment #10)
> OK.
> 
> 1. Tap the call log entry.
> 2. See popup with the avatar, Phone, and SMS

You just reproduced it, congrats!

> 3. Tap avatar
> 4. Tap the newly appeared "SIP audio" button

Also GTalk, Skype, AIM, Jabber, Home address and whatsoever was filled for that
contact. Not my bug report related.
Comment 12 Sergey Vlasov (reporter) 2010-01-18 13:17:20 UTC
(In reply to comment #11)
> Also GTalk, Skype, AIM, Jabber, Home address and whatsoever was filled for that
> contact. Not my bug report related.
> 

Ok, not Home address, but you got the point :)
Comment 13 wierdo 2010-01-18 13:21:10 UTC
Well, if you had a SIP address for them, that's what would show up in the
popup. If you don't you just get the regular cellular details.
Comment 14 Sergey Vlasov (reporter) 2010-01-18 13:33:29 UTC
(In reply to comment #13)
> Well, if you had a SIP address for them, that's what would show up in the
> popup. If you don't you just get the regular cellular details.
> 

Hm, I guess it would. Can somebody check if SkypeOut is also replaced with GSM?
Comment 15 wierdo 2010-01-19 02:45:01 UTC
Having gone through all of my call log entries, I have to say the most
confusing part is that it does different things for the same contact, even when
the transport of the original call is the same.

This one particular contact I have five times or so in my call log, 3 of them
are SIP calls. One pops up the contact's sip addresses when I tap it. The
others just give me the Cell and SMS options, despite having the SIP icon next
to the log entry.

The one where the contact called me from their landline at work correctly pops
up the work numbers.

It's completely erratic.
Comment 16 Andre Klapper maemo.org 2010-01-21 16:32:28 UTC
*** Bug 8209 has been marked as a duplicate of this bug. ***
Comment 17 Andre Klapper maemo.org 2010-01-21 16:32:57 UTC
*** Bug 8348 has been marked as a duplicate of this bug. ***
Comment 18 Andre Klapper maemo.org 2010-01-21 16:48:14 UTC
*** Bug 8033 has been marked as a duplicate of this bug. ***
Comment 19 Lassi Syrjälä nokia 2010-01-21 17:29:22 UTC
Confirmed, this is a known bug.

SIP and SkypeOut are supposed to be the default options, but unfortunately
there's a limitation in the current Contacts UI that breaks this use case and
hides the options behind an avatar tap.

I'll move this to Contacts, so it gets the attention of the right people.
Comment 20 tuukka.tolvanen nokia 2010-02-07 23:40:19 UTC
*** Bug 8888 has been marked as a duplicate of this bug. ***
Comment 21 Andre Klapper maemo.org 2010-02-09 20:02:47 UTC
This has been fixed in the internal build version
10.2010.06-0
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 22 Andre Klapper maemo.org 2010-02-12 13:29:07 UTC
Correction: Version 10.2010.06-8.

1. when we tap on the entry in call log it will display only [ Skype call] / [
SIP call ] buttons.
2. After taping on Avatar,the buttons for 
[ Cellular call ]
[ SMS ]
[ Skype call ]
[ SIP call ] available.
Comment 23 Sergey Vlasov (reporter) 2010-02-12 13:30:41 UTC
Great news! Can't wait to try it out :)
Comment 24 Andre Klapper maemo.org 2010-02-16 15:20:16 UTC
*** Bug 9077 has been marked as a duplicate of this bug. ***
Comment 25 Andre Klapper maemo.org 2010-03-01 13:22:00 UTC
*** Bug 9330 has been marked as a duplicate of this bug. ***
Comment 26 Andre Klapper maemo.org 2010-03-15 20:53:20 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 27 Andre Klapper maemo.org 2010-03-23 17:41:22 UTC
*** Bug 9652 has been marked as a duplicate of this bug. ***
Comment 28 Wille 2010-06-07 09:40:40 UTC
I have pr1.2 installed but still have the same problem with sip calls from
recent callog list. Can someone else confirm this?
Comment 29 nivw2008 2010-06-07 17:52:38 UTC
same here
Comment 30 Wille 2010-06-08 14:56:10 UTC
(In reply to comment #29)
> same here
> 

I have now reflashed my phone and the problem is solved. So Andre you may
forward the problem to the tech guys that over the air updates missed this and
possibly more stuff..
Comment 31 Andre Klapper maemo.org 2010-06-29 16:35:01 UTC
*** Bug 10740 has been marked as a duplicate of this bug. ***
Comment 32 Andre Klapper maemo.org 2010-06-29 16:35:25 UTC
(In reply to comment #30)
> I have now reflashed my phone and the problem is solved. So Andre you may
> forward the problem to the tech guys that over the air updates missed this and
> possibly more stuff..

Please file a new bug report about this.