Bug 8150 - Small images not scaled up to max width/height
: Small images not scaled up to max width/height
Status: RESOLVED WONTFIX
Product: Images and Camera
Image viewer
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified enhancement (vote)
: ---
Assigned To: unassigned
: image-viewer-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-17 14:34 UTC by Oskar
Modified: 2010-03-08 16:10 UTC (History)
2 users (show)

See Also:


Attachments
example image (66.43 KB, image/jpeg)
2010-01-17 14:36 UTC, Oskar
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Oskar (reporter) 2010-01-17 14:34:57 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Add attached image to your images-folder
2. Open image viewer and select this image to be displayed full screen
3. View image both in landscape and portrait mode

EXPECTED OUTCOME:
Image is scaled up to max. height in landscape mode, the same way it is scaled
down to fit max. width in portrait mode.

ACTUAL OUTCOME:
Image isn't re-sized in landscape mode. Black borders on all 4 sides. It is, of
course, scaled down when viewed in portrait.

REPRODUCIBILITY:
always


OTHER COMMENTS:
This is an irritating behavior especially when showing photos of different
sizes to friends. The screen is already just a tad too small for comfortable
viewing; having images appear even smaller than the screen is unnecessary.

It could even be considered a UX bug instead of an enhancement: When you browse
through various images (or start a slide show), you don't know about their
technical specifications. As a user, you can't tell why some photos are full
screen while others have black borders on all 4 sides and appear to by "zoomed
out". 


User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.9.1.6)
Gecko/20091229 Gentoo Shiretoko/3.5.6
Comment 1 Oskar (reporter) 2010-01-17 14:36:58 UTC
Created an attachment (id=2022) [details]
example image
Comment 2 Andre Klapper maemo.org 2010-01-18 15:26:42 UTC
This is most probably expected behaviour because if you have small icons etc,
looking at them by default with high zoom will just look ugly.
Comment 3 Daniil Ivanov nokia 2010-02-05 11:00:16 UTC
Image is displayed to fit the screen or 100% scale otherwise. All other imaging
software does the same.
Comment 4 Oskar (reporter) 2010-02-05 11:26:20 UTC
(In reply to comment #3)
> Image is displayed to fit the screen or 100% scale otherwise. 

Right. This is exactly what I descibed.
Comment 5 Daniil Ivanov nokia 2010-02-05 11:28:21 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Image is displayed to fit the screen or 100% scale otherwise. 
> 
> Right. This is exactly what I descibed.
> 

Then expected outcome is invalid, isn't it?
Comment 6 Oskar (reporter) 2010-02-05 12:10:34 UTC
(In reply to comment #5)
> Then expected outcome is invalid, isn't it?

Maybe we're getting "lost in translation" here. :)
Why would it be 'invalid'? 

I'll ty again in other words:

What I would expect is any image - no matter of its size in pixels - to be
displayed in a way that makes best use of the available physical screen
dimensions (which means inches, not pixels). 
An image with an aspect ratio of 15:9 should always fill the whole screen (and
never leave black borders), no matter if its dimension in pixels is 800x480,
1600x960 or 400x240. Images with an aspect ratio other than 15:9 should have
black borders only verticalls *or* horizontally, but never on all 4 sides.

This is a reasonable expectation. The media player does the very same to video
files: It stretches them to the full display size. You wouldn't want to watch a
15:9 video with black borders on all 4 sides only because it's encoded with a
resolution<800x480, would you? 

My assumption behind this enhancement request is that a user would expect the
device to display a photo as good as possible, "good" meaning big and visible. 

Andre mentioned above that displaying very small graphics this way (like icons)
would distort them and make them look ugly, which is correct. I'm not sure,
though, if displaying icons is the intended use case of an application that
does tagging, geotagging, slide-shows,... I believe it was meant to display
photos. And when viewing photos, you want them big, especially on such a small
screen. - If you're still unsure about what it means to icons: There are 2
views already in the image viewer. One that's (supposed to be) full screen and
one that shows the controls for tagging/deleting/sharing the file. Make the
latter display images in their original size if they're smaller than the screen
(the way it is now), and use the stretched view proposed here for both the full
screen view and the slideshow.
Comment 7 Daniil Ivanov nokia 2010-02-05 12:40:50 UTC
Then it's a duplicate of bug #6838.
Comment 8 Oskar (reporter) 2010-02-05 13:00:25 UTC
(In reply to comment #7)
> Then it's a duplicate of bug #6838.

No. 

Bug #6838 was fixed in PR1.1., this bug is reported against PR1.1.

Bug #6838 is about how images are treated when device is rotated from landscape
to portrait. It does not deal with the upscaling of images smaller than
800x480, which is what this enhancement request is about.
Comment 9 Daniil Ivanov nokia 2010-02-05 15:03:24 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Then it's a duplicate of bug #6838.
> 
> No. 
> 
> Bug #6838 was fixed in PR1.1., this bug is reported against PR1.1.
> 
> Bug #6838 is about how images are treated when device is rotated from landscape
> to portrait. It does not deal with the upscaling of images smaller than
> 800x480, which is what this enhancement request is about.
> 

Please, demonstrate any imaging application, which up-scales images smaller
than window size. It's highly uncommon and the reason is mentioned in comment
#2.
Comment 10 Oskar (reporter) 2010-02-05 16:27:18 UTC
(In reply to comment #9)
> Please, demonstrate any imaging application, which up-scales images smaller
> than window size. 

Would this enhance my viewing experience on the N900?

Would this make the N900 any more joyful to use?

Did you design the Maemo 5 UI so that it exactly replicates the UX you find on
other computers?

Was "never be better than others" a target during development?


When my standard image viewer I find on my Windows XP desktop doesn't upscale
the attached example image, I still see an image that's 14.5cm wide and 10.5cm
high. That's plenty.

When the N900 image viewer doesn't upscale the attached image, I see a photo
thats 4.8cm wide and 3.6cm high. That's inadequate and, as I explained above,
incomprehensible to people who don't care about technical details like image
resolutions and just don't understand why some photos "are scaled down". (Which
is the impression you get, esp. compared to viewing the same image on a low-res
phone of approx. the same screen size.)

Presenting it in 6x4.6cm, which the device is capable of, would be an obvious
enhancement and would make a perfect, seemless UX in slide shows.


BTW, I understand you're not interested in implementing this. It would be
easier to simply close it as WONTFIX then. WONTFIX is useful and friendly
because it is a needed starting point for further action (brainstorm,
application request,...)
Comment 11 Daniil Ivanov nokia 2010-02-05 16:51:56 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Please, demonstrate any imaging application, which up-scales images smaller
> > than window size. 
> 
> Would this enhance my viewing experience on the N900?
> 
> Would this make the N900 any more joyful to use?
> 
> Did you design the Maemo 5 UI so that it exactly replicates the UX you find on
> other computers?
> 
> Was "never be better than others" a target during development?
> 
> 
> When my standard image viewer I find on my Windows XP desktop doesn't upscale
> the attached example image, I still see an image that's 14.5cm wide and 10.5cm
> high. That's plenty.
> 
> When the N900 image viewer doesn't upscale the attached image, I see a photo
> thats 4.8cm wide and 3.6cm high. That's inadequate and, as I explained above,
> incomprehensible to people who don't care about technical details like image
> resolutions and just don't understand why some photos "are scaled down". (Which
> is the impression you get, esp. compared to viewing the same image on a low-res
> phone of approx. the same screen size.)
> 
> Presenting it in 6x4.6cm, which the device is capable of, would be an obvious
> enhancement and would make a perfect, seemless UX in slide shows.
> 
> 
> BTW, I understand you're not interested in implementing this. It would be
> easier to simply close it as WONTFIX then. WONTFIX is useful and friendly
> because it is a needed starting point for further action (brainstorm,
> application request,...)
> 

It was implemented like that in Maemo 4. Then it was a lot of negative feedback
about the feature and it was changed it to match needs of the most of people.
Comment 12 Andre Klapper maemo.org 2010-03-08 16:10:51 UTC
WONTFIX as per last comments.