Bug 8135 - dnsmasq segfaults when connecting to a certain WLAN AP
: dnsmasq segfaults when connecting to a certain WLAN AP
Status: RESOLVED DUPLICATE of bug 8133
Product: Connectivity
Networking
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: networking-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-17 00:16 UTC by Philipp Zabel
Modified: 2010-01-20 14:15 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Philipp Zabel (reporter) 2010-01-17 00:16:38 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Set up a new connection to the WLAN AP (setting SSID and WPA-PSK)
2. Connect to the WLAN AP, either by getting into range when automatic
   WLAN connecting is enabled, or by selecting it from the connection
   dialog when in range.

EXPECTED OUTCOME:
dnsmasq forwards DNS queries to the name server, which is correctly entered in
the wlan0 resolv.conf.

ACTUAL OUTCOME:
dnsmasq segfaults in reply_query at line 219 of forward.c

REPRODUCIBILITY:
So far always - the WLAN AP in question is not mine, I only tried several times
on three occasions.

EXTRA SOFTWARE INSTALLED:
Conboy (unstable)
Extra Decoders Support
Harmony
Last.fm scrobbler
Ogg Support
OpenSSH Client
OpenSSH Server
pymaemo-optify
rootsh
vagalume
XChat

OTHER COMMENTS:

Here is a partial syslog of the connection attempt:

Jan 16 13:55:02 Nokia-N900-51-1 kernel: [13105.937225] wlan0: associated
Jan 16 13:55:02 Nokia-N900-51-1 icd2 0.87+fremantle4+0m5[1165]: connecting iap
0x39a10 in state ICD_IAP_STATE_LINK_POST_UP: interface is 'wlan0'
Jan 16 13:55:02 Nokia-N900-51-1 icd2 0.87+fremantle4+0m5[1165]: connecting iap
0x39a10 in state ICD_IAP_STATE_IP_UP: interface is 'wlan0'
Jan 16 13:55:03 Nokia-N900-51-1 udhcpc[1631]: udhcpc (v0.9.9-pre) started
Jan 16 13:55:03 Nokia-N900-51-1 udhcpc[1631]: Sending discover...
Jan 16 13:55:07 Nokia-N900-51-1 udhcpc[1631]: Sending discover...
Jan 16 13:55:08 Nokia-N900-51-1 udhcpc[1631]: Sending select for
192.168.2.101...
Jan 16 13:55:08 Nokia-N900-51-1 udhcpc[1631]: Lease of 192.168.2.101 obtained,
lease time 172800
Jan 16 13:55:08 Nokia-N900-51-1 dnsmasq[1132]: failed to access
/var/run/resolv.conf.wlan0: No such file or directory
Jan 16 13:55:08 Nokia-N900-51-1 dnsmasq[1132]: read /etc/hosts - 1 addresses
Jan 16 13:55:08 Nokia-N900-51-1 icd2 0.87+fremantle4+0m5[1165]: connecting iap
0x39a10 in state ICD_IAP_STATE_IP_UP: interface is 'wlan0'
Jan 16 13:55:08 Nokia-N900-51-1 icd2 0.87+fremantle4+0m5[1165]: srv type ''
unknown
Jan 16 13:55:08 Nokia-N900-51-1 [1074]: Unknown state 15 received from ICd2
Jan 16 13:55:09 Nokia-N900-51-1 mce[741]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x30020, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 location-proxy[1117]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x27c18, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 mission-control[1032]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x3e410, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 alarmd[967]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x33018, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 [1411]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xf9980, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 browserd[1457]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0x42d80, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:09 Nokia-N900-51-1 browserd[1457]: GLIB DEBUG default -
connection_cb(0x42d80, 6e668de8-9891-4d0b-ae47-d30d8537eb2e, WLAN_INFRA, 0, 0)
count 0
Jan 16 13:55:09 Nokia-N900-51-1 browserd[1457]: GLIB DEBUG default -
connection_cb(0x42d80, 6e668de8-9891-4d0b-ae47-d30d8537eb2e, WLAN_INFRA, 0, 0)
connected
Jan 16 13:55:09 Nokia-N900-51-1 [1074]: GLIB DEBUG ConIc -
con_ic_connection_send_event(0xa49e0, 6e668de8-9891-4d0b-ae47-d30d8537eb2e,
WLAN_INFRA, 0)
Jan 16 13:55:14 Nokia-N900-51-1 dnsmasq[1132]: reading
/var/run/resolv.conf.wlan0
Jan 16 13:55:14 Nokia-N900-51-1 dnsmasq[1132]: using nameserver 192.168.2.1#53
Jan 16 13:55:15 Nokia-N900-51-1 init: dnsmasq main process (1132) killed by
SEGV signal
Jan 16 13:55:15 Nokia-N900-51-1 init: dnsmasq main process ended, respawning
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: started, version 2.35 cachesize
150
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: compile time options: IPv6
GNU-getopt no-RTC no-ISC-leasefile DBus no-I18N 
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: failed to access
/var/run/resolv.conf.gprs: No such file or directory
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: failed to access
/var/run/resolv.conf.lo: No such file or directory
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: failed to access
/var/run/resolv.conf.ppp0: No such file or directory
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: failed to access
/var/run/resolv.conf: No such file or directory
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: reading
/var/run/resolv.conf.wlan0
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: using nameserver 192.168.2.1#53
Jan 16 13:55:15 Nokia-N900-51-1 dnsmasq[1699]: read /etc/hosts - 1 addresses
Jan 16 13:55:20 Nokia-N900-51-1 init: dnsmasq main process (1699) killed by
SEGV signal
...

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6)
Gecko/20091216 Iceweasel/3.5.6 (like Firefox/3.5.6; Debian-3.5.6-1)
Comment 1 Philipp Zabel (reporter) 2010-01-17 00:18:42 UTC

*** This bug has been marked as a duplicate of bug 8133 ***