Bug 8087 - (int-144401) Photo autorotation issue
(int-144401)
: Photo autorotation issue
Status: RESOLVED FIXED
Product: Images and Camera
Image viewer
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 9 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: image-viewer-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 23:02 UTC by f_scarrone
Modified: 2010-03-15 20:54 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description f_scarrone (reporter) 2010-01-15 23:02:39 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
Open file browser
open n900 folder
open camera folder
select a photo (fullscreen)
rotate the device 

EXPECTED OUTCOME:
the photo rotates

ACTUAL OUTCOME:
the photo does not rotate
REPRODUCIBILITY:
(always)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
activate camera
enter photo collection from camera interface
select a photo (full screen)
rotate the device --> the photo rotates 

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Henri 2010-01-17 14:10:22 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 donjoe 2010-01-26 15:06:12 UTC
open Email prog.
open email with picture in attachment.
select a picture
view picture (fullscreen)
rotate device(n900), picture dosent rotate
Comment 3 Andre Klapper maemo.org 2010-01-28 13:45:30 UTC
Hi, I can reproduce this with 2.2009.51-1.
I cannot reproduce this anymore with the internal version 2010.04-8 anymore, so
this has been fixed in the meantime.

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 4 Andre Klapper maemo.org 2010-03-15 20:54:34 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).