Bug 8081 - "Unknown number" when someone calls from number with 6 digits
: "Unknown number" when someone calls from number with 6 digits
Status: RESOLVED DUPLICATE of bug 6769
Product: Chat & Call & SMS
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium major with 2 votes (vote)
: ---
Assigned To: rtcomm@maemo.org
: communication-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 22:19 UTC by ohiivatukka
Modified: 2010-01-21 14:00 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description ohiivatukka (reporter) 2010-01-15 22:19:00 UTC
SOFTWARE VERSION:2.2009.51-1


EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Someone from our company calls me
2. Only text "unknown number" is shown and no actual number
3. 

EXPECTED OUTCOME:With my previous Nokia phones E90 and E71 number was shown
either in short form e.g. 801234 or 044-7771234 dependig if the caller is using
long or short form of my phone number. (Our company uses mobile phone exhange).

ACTUAL OUTCOME: "unknown number"

REPRODUCIBILITY:always


EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:This is pretty annoying because I can't return calls :)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 ohiivatukka (reporter) 2010-01-19 09:07:02 UTC
The problem seems to be with the short phone number format (801234). When we
tested internal calls the long number is automatically regogniced by the mobile
exchange and changed to short.
So when a call arrives from 801234 type of phonenumber the N900 displays
"unknown number".
Comment 2 Andre Klapper maemo.org 2010-01-21 00:01:42 UTC
Also see bug 6769
Comment 3 Mikhail Zabaluev nokia 2010-01-21 14:00:33 UTC

*** This bug has been marked as a duplicate of bug 6769 ***