Bug 8076 - New messages do not change to "read" after being read
: New messages do not change to "read" after being read
Status: RESOLVED DUPLICATE of bug 8441
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 1 vote (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 21:45 UTC by Ben Smith
Modified: 2010-01-28 19:05 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ben Smith (reporter) 2010-01-15 21:45:08 UTC
SOFTWARE VERSION: 2.2009.51-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
1. Receive new message after having updated the N900 Firmware to the new
2.2009.51-1
2. Read the message (either from tapping on it on the dashboard or going
directly to the "Conversations" menu)
3. Close message and return to "Conversations"

EXPECTED OUTCOME: the message I've just read should be in the Conversations but
not in bold anymore; hence, its status should automatically be as "Read".

ACTUAL OUTCOME: the message I've just read is in bold in the "Conversations"
menu, as if I had not already read it. The same thing happens even after a few
reboots, the read message is still set as "unread"

REPRODUCIBILITY: always with the new firmware installed

EXTRA SOFTWARE INSTALLED: no other software.

OTHER COMMENTS: I've flashed it 3 times: at first I thought something wrong
went with the 2.2009.51-1 OTA update, so I flashed it once and the fault was
still there; then I flashed it a second time, and it was still there; now I've
flashed the device with the new firmware but the bug is still there. 

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Comment 1 Andre Klapper maemo.org 2010-01-27 19:54:09 UTC
Thanks for reporting.

What exact messages is this about? SMS, IM (if so, which service)? Does this
happen with all of them? If it's about SMS, what is your provider?

Bug 8441 might be a duplicate...
Comment 2 stephendoak 2010-01-28 18:51:19 UTC
Yes I happens with all of them .. its sms ... and my network is vodafone.
Comment 3 Andre Klapper maemo.org 2010-01-28 19:05:02 UTC
Ah, thanks, then it's the same issue as bug 8441

*** This bug has been marked as a duplicate of bug 8441 ***