Bug 8071 - Problems typing cyrillic characters into the search field
: Problems typing cyrillic characters into the search field
Status: RESOLVED DUPLICATE of bug 8390
Product: Map
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: map-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 20:08 UTC by zmey_jr
Modified: 2010-01-25 18:06 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description zmey_jr (reporter) 2010-01-15 20:08:45 UTC
SOFTWARE VERSION:
2.2009.51-1

It is impossible to change keyboard layout when typing in the search field.
It is possible to switch layout in an other application and return to maps/
When trying to type in the search field with Russian keyboard layout turned on,
the first typed character is English, while the rest are Cyrillic. 

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; InfoPath.3)
Comment 1 Andre Klapper maemo.org 2010-01-18 15:30:51 UTC
Thanks for reporting this.
This report isn't very useful because it doesn't describe the problem well. If
you have time and can still reproduce the problem, please read
https://bugs.maemo.org/page.cgi?id=bug-writing.html and add exact, step by
step, click by click "Steps to reproduce" to this bug.
Please also provide your Hardware keyboard layout, 1st language and 2nd
language settings under Settings > Text input.
Comment 2 zmey_jr (reporter) 2010-01-18 16:37:19 UTC
Hardware keyboard layout is Russian. 1st language is Russian, 2nd is English.

STEPS TO REPRODUCE THE PROBLEM:
1. Open Maps application
2. Tap "places" (not sure exact English label for this)
3. Type anything - get English input
4. press Ctrl+space to switch layout
5. Switch to any other application and switch layout there, then switch back to
Maps
6. try to type anything in the search field again

EXPECTED OUTCOME
4. layout switching expected
6. Russian input expected

ACTUAL OUTCOME
4. Nothing happens
6. The first character is English, the rest are Russian
Comment 3 Andre Klapper maemo.org 2010-01-23 19:38:10 UTC
Ah, thanks a lot! This is the same issue as bug 8390 that is currently being
worked on.

*** This bug has been marked as a duplicate of bug 8390 ***
Comment 4 zmey_jr (reporter) 2010-01-24 14:23:08 UTC
Thanks a lot for your response, but there is an issue not mentioned in bug
8390. It is impossible to switch keyboard layout in "Maps" (step 4 in comment
2).
Comment 5 Andre Klapper maemo.org 2010-01-25 18:06:17 UTC
(In reply to comment #4)
> Thanks a lot for your response, but there is an issue not mentioned in bug
> 8390. It is impossible to switch keyboard layout in "Maps" (step 4 in comment
> 2).

Ah, I see. Can you please file a separate bug report against Maps?