Bug 8062 - the text field of the media player widget always scrolls no matter the length
: the text field of the media player widget always scrolls no matter the length
Status: RESOLVED WONTFIX
Product: Desktop Widgets
Media player
: 5.0:(10.2010.19-1)
: N900 Maemo
: Low enhancement with 2 votes (vote)
: ---
Assigned To: unassigned
: mediaplayer-applet-bugs
:
: use-time
:
:
  Show dependency tree
 
Reported: 2010-01-15 17:51 UTC by Kieron
Modified: 2012-03-24 11:43 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Kieron (reporter) 2010-01-15 17:51:01 UTC
SOFTWARE VERSION: 
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. play a song whist media player widget is visible on desktop
2. wait, and you'll see that the text no matter the length is always scrolling.

EXPECTED OUTCOME:
the text should only scroll when it is too long to fit in the space provided.
both the artist and track title should also scroll seperately. e.g. if the
title is too long yet the artist fits fine only the title should scroll.
ACTUAL OUTCOME:
instead, the text scrolls no matter what the length of the artist or track is.
REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always.
EXTRA SOFTWARE INSTALLED:
n/a
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv7l; en-GB; rv:1.9.2a1pre)
Gecko/20091127 Firefox/3.5 Maemo Browser 1.5.6 RX-51 N900
Comment 1 Andre Klapper maemo.org 2010-01-15 18:03:15 UTC
Thanks for reporting.
I assume that this has been a design decision and not a bug.
Comment 2 Kieron (reporter) 2010-01-15 18:54:21 UTC
Andre,

I only though this as a bug because of the issues when trying to read the
actual title etc.

I come in to problems, because at the speed of the scrolling and the shortness
of the text, I have to wait a while before the text scrolls back to the start
to actually see the track name/artist. Do you see my point?

Although if you truly think its an enhancement rather than a bug, each to their
own, as long as it gets fixed eventually I'm happy! :)

PS. Very impressed, you seem to be everywhere at once, keep up the good work
mate!!
Comment 3 Venomrush 2010-04-02 13:03:44 UTC
(In reply to comment #2)
> Andre,
> 
> I only though this as a bug because of the issues when trying to read the
> actual title etc.
> 
> I come in to problems, because at the speed of the scrolling and the shortness
> of the text, I have to wait a while before the text scrolls back to the start
> to actually see the track name/artist. Do you see my point?
> 

This is valid. However, stopping the scrolling all together will make long
tracks name unviewable.

The scope of Maemo Bugzilla are bugs, only very specific and no-brainer
enhancement requests. This bug report contains a feature request that is too
generic for Maemo Bugzilla and is therefore treated as an invalid bug report.

There will be more success for this enhancement to be implemented by filing a
report explaining the problem you have and provide solutions that people can
vote for at Maemo Brainstorm. Please post this problem and propose your
solution at http://maemo.org/community/brainstorm

Information regarding Maemo Brainstorm can be found at
http://wiki.maemo.org/Maemo_brainstorm
Comment 4 Andre Klapper maemo.org 2010-04-02 13:12:09 UTC
Venomrush: Please don't close as INVALID.
Comment 5 Jonathan Mikhail 2010-07-13 17:33:33 UTC
I have encountered this same issue on my device. I, too, find it visually
unappealing, even though it is almost certainly by design. That said, there may
be another interesting point to consider: whenever the widget is scrolling,
there is a marked increase in CPU activity.

I haven't been able to get exact numbers using Top, as I do not know which
thread relates directly to the media widget; however, using load applet, I can
consistently observe the CPU usage going up a "notch" when scrolling begins and
going back down when scrolling ceases.

As this constantly prevents the CPU from switching to its power-saving idle
mode, this behavior almost certainly leads to a drain of the battery. For this
reason alone, would it not make sense to try and eliminate needless scrolling?
Comment 6 Andre Klapper maemo.org 2012-03-24 11:43:07 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )