Bug 8058 - (Croc) Flickr photo sharing doesn't work over WLAN
(Croc)
: Flickr photo sharing doesn't work over WLAN
Status: RESOLVED WORKSFORME
Product: Sharing
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal (vote)
: ---
Assigned To: unassigned
: sharing-general-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-01-15 16:52 UTC by Tom
Modified: 2010-04-02 12:20 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tom (reporter) 2010-01-15 16:52:38 UTC
SOFTWARE VERSION:
2.2009.51.1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))

1. connect to internet via WLAN 
2. open any photo in n900 photo viewer
3. click on share icon at the bottom of the screen
4. select "share via service"
5. hit "share" button

EXPECTED OUTCOME:
1. green "share" icon in top status bar
2. photo uploaded
3. after upload green "share" icon should be gone

ACTUAL OUTCOME:
1. green "share" icon in top status bar
2. no upload 
3. green "share icon stuck in status bar

REPRODUCIBILITY:

ALWAYS

EXTRA SOFTWARE INSTALLED:
NON

OTHER COMMENTS:
switching to 3G internet and upload goes ahead.
also when using WLAN connection adding flickr sharing account in
Settings>>>Sharing accounts crashes to desktop with this message: "internal
error. application 'settings' closed"
and same as with photo upload adding flickr account while on 3G connection
works without any errors.

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64;
Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
Media Center PC 6.0; InfoPath.2; OfficeLiveConnector.1.4; OfficeLivePatch.1.3;
FDM)
Comment 1 Tom (reporter) 2010-01-15 16:57:25 UTC
SOFTWARE VERSION:
2.2009.51.1

EXACT STEPS LEADING TO PROBLEM: 

1. connect to internet via WLAN 
2. open any photo in n900 photo viewer
3. click on share icon at the bottom of the screen
4. select "share via service"
5. hit "share" button

EXPECTED OUTCOME:
1. green "share" icon in top status bar
2. photo uploaded
3. after upload green "share" icon should be gone

ACTUAL OUTCOME:
1. green "share" icon in top status bar
2. no upload 
3. green "share icon stuck in status bar

REPRODUCIBILITY:

ALWAYS

EXTRA SOFTWARE INSTALLED:

NON

OTHER COMMENTS:
switching to 3G internet and upload goes ahead.
also when using WLAN connection adding flickr sharing account in
Settings>>>Sharing accounts crashes to desktop with this message: "internal
error. application 'settings' closed"
and same as with photo upload adding flickr account while on 3G connection
works without any errors.
Comment 2 Andre Klapper maemo.org 2010-01-15 17:59:54 UTC
Thanks for reporting this.

So, more information about your WLAN is highly welcome, e.g. what type and if
certain ports maybe are blocked...
Comment 3 Tom (reporter) 2010-01-15 18:13:10 UTC
Billion 7402NX (Firmware 5.53.s5) (it is adsl modem/router/ap in one box)
everything else on n900 via WLAN works without any issues with my setup.

no blocked ports but i'm forwarding few ports to one of my workstations:

TCP only:
21

TCP and UDP:
8686
27500
27900
7776-7780

any ports out of this bunch is used by flickr?
Comment 4 Tom (reporter) 2010-01-15 18:29:22 UTC
To make things simple i just backed up my modem settings and removed all
forwarded ports plus i put n900 ip in to DMZ mode on my modem so there would be
nothing getting blocked.
hope removing this extra variables helps
Comment 5 Kasper Souren 2010-01-17 03:47:01 UTC
Might be related to https://bugs.maemo.org/show_bug.cgi?id=6274
Comment 6 Tom (reporter) 2010-01-18 08:13:51 UTC
over last couple of days i managed to test this at 3 other locations, different
wireless routers and different internet providers, it always fails to work over
WLAN
Comment 7 Andre Klapper maemo.org 2010-02-02 23:03:39 UTC
Any chance to provide a tcpdump / package capture?
tcpdump can be used on the Nokia device (Wireshark/Ethereal could be used from
other hosts). Please take a look at
http://maemo.org/development/documentation/man_pages/tcpdump.html for more
information.
Comment 8 Tom (reporter) 2010-02-09 13:18:14 UTC
can you tell me what switches should i use for tcpdump to capture what you
need?
Comment 9 Andre Klapper maemo.org 2010-02-11 13:36:08 UTC
Uhm, sorry, I don't know
Comment 10 Venomrush 2010-04-02 12:20:46 UTC
(In reply to comment #1)

> EXACT STEPS LEADING TO PROBLEM: 
> 
> 1. connect to internet via WLAN 
> 2. open any photo in n900 photo viewer
> 3. click on share icon at the bottom of the screen
> 4. select "share via service"
> 5. hit "share" button
> 
> EXPECTED OUTCOME:
> 1. green "share" icon in top status bar
> 2. photo uploaded
> 3. after upload green "share" icon should be gone
> 

Closing as WORSKFORME for the time being, as I cannot reproduce the issue with
the latest firmware PR1.1.1 (3.2010.02-8), but please feel free reopen if this
happens again and if possible please provide exact steps leading to the issue.