Bug 8050 - Media Player displays stop button during the playback of an AAC stream. It should display pause button.
: Media Player displays stop button during the playback of an AAC stream. It sh...
Status: RESOLVED FIXED
Product: Media player
General
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 15:11 UTC by Harish Koka
Modified: 2010-04-07 17:24 UTC (History)
3 users (show)

See Also:


Attachments
AAC clip to be streamed from HTTP server. (1.74 MB, audio/aac)
2010-01-15 15:16 UTC, Harish Koka
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Harish Koka (reporter) 2010-01-15 15:11:27 UTC
SOFTWARE VERSION:
2.2009.51-1.002

Device connected to WLAN with Internet connection.

EXACT STEPS LEADING TO PROBLEM: 
1. Launch browser and open page http AAC audio streaming link.
2. Select Open with Media Player in File Download window.

EXPECTED OUTCOME:
The media player should launched and the media file should be streamed
successfully. The pause button should be displayed during stream playback.

ACTUAL OUTCOME:
Media Player displays stop button during the stream playback.
Tapping twice on Media Player volume icon(or switching to library view and back
to now playing view), the Stop button changes the Pause button. 
Looks to be an UI issue.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.20)
Gecko/20081217 Firefox/2.0.0.20 (.NET CLR 3.5.30729)
Comment 1 Harish Koka (reporter) 2010-01-15 15:16:23 UTC
Created an attachment (id=1991) [details]
AAC clip to be streamed from HTTP server.
Comment 2 Andre Klapper maemo.org 2010-01-22 14:58:12 UTC
(In reply to comment #1)
> Created an attachment (id=1991) [details] [details]
> AAC clip to be streamed from HTTP server.

Clicking this only offers "Save to Device" here, but no "Open in Media Player".
Comment 3 Venomrush 2010-03-16 23:35:18 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=1991) [details] [details] [details]
> > AAC clip to be streamed from HTTP server.
> 
> Clicking this only offers "Save to Device" here, but no "Open in Media Player".
> 

Same here

EXTRA SOFTWARE INSTALLED: ??
Comment 4 Mohammad Abu-Garbeyyeh 2010-03-17 14:44:45 UTC
File attached has to be put on an HTTP Server with the correct MIME type
defined.
Tested it on my home server (HFS on Windows, Apache should also work), defined
the MIME type as audio/aac and open in Media Player appears.
Stop button appears when streaming starts, if the volume button is pressed
twice, a pause button is shown.
This might be due to the server not being detected as supporting streaming (or
resume downloads - essentially the same in this case) but when it detects that
it supports streaming it fails to update the GUI button.
Changing to CONFIRMED.
Comment 5 Mohammad Abu-Garbeyyeh 2010-03-17 14:48:21 UTC
If anyone wants to test it use this link instead of the attachment above:
http://mohammadag.ucoz.com/van.aac
Comment 6 Andre Klapper maemo.org 2010-04-07 17:24:00 UTC
(In reply to comment #5)
> If anyone wants to test it use this link instead of the attachment above:
> http://mohammadag.ucoz.com/van.aac

Running the internal newer version 2010.12-9 here:
Entered this link in the browser, chose "Open with Media Player", music started
playing. Track length is 03:49 and the three usual buttons are shown:
  |<   ||   >|

So this seems to be fixed in the upcoming PR1.2.