Bug 8038 - (int-147359) Unlocking screen using power button/touch slide tops last application when on the desktop
(int-147359)
: Unlocking screen using power button/touch slide tops last application when on...
Status: VERIFIED FIXED
Product: Desktop platform
Home
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified minor with 9 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: home-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 10:23 UTC by Janne Kolehmainen
Modified: 2010-05-26 00:44 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Janne Kolehmainen (reporter) 2010-01-15 10:23:03 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Start some programs
2. Go to desktop
3. Lock the screen
4. Click power button ones
5. Use slider to open the lock

EXPECTED OUTCOME:
Desktop is shown as was when locked.

ACTUAL OUTCOME:
Last opened software is show in the screen

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7)
Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Ryan Abel maemo.org 2010-01-15 12:24:00 UTC
Lock with screen + unlock with power button/screen -> bug
Lock with screen + unlock with switch -> no bug
Lock with switch + unlock with power button/screen -> bug
Lock with switch + unlock with switch -> no bug
Comment 2 Dawid Lorenz 2010-01-15 17:56:48 UTC
Yes, I confirm this bug. It has been introduced with 51-1, as there was no such
issue before.

Basically speaking, using lock/unlock slider on the side of device work OK, but
whenever unlock occurs via power button and lock swipe gesture - last opened
application appears on the screen, instead of desktop (even when that
application *didn't* have a focus while locking device).
Comment 3 Neil MacLeod maemo.org 2010-01-19 19:57:08 UTC
Ah good, glad someone has reported this - bl00dy confusing it is.

Unlocking should always put you back to exactly where you were in the UI before
the lock took place.
Comment 4 Neil MacLeod maemo.org 2010-01-19 20:06:01 UTC
This doesn't seem to have anything to do with the swipe to unlock - just
pressing the power button prior to unlocking with the side switch results in
the most recently accessed application getting focus, ie.

1. Open several apps
2. Go to desktop
3. Lock with side switch
4. Press power button once (but don't swipe to unlock)
5. Unlock with side switch

EXPECTED OUTCOME:

6. Desktop is displayed

ACTUAL OUTCOME:

6. Most recent app has focus
Comment 5 Joachim Malmlund 2010-01-21 21:35:11 UTC
I can add yet an other scenario that relates.

SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM:
1. Start at least one application
2. Go to desktop 
3. Lock screen (doesn't matter in what way)
4. Press power button once (but don't swipe to unlock)
5. Slide out screen to reveal keyboard => unlock

EXPECTED OUTCOME:

6. Desktop is displayed

ACTUAL OUTCOME:

6. Most recent app has focus

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
None, happens even after complete re-flash from computer.

OTHER:
When following the steps to reproduce the problem hold after step 4 and let the
screensaver kick back on (go to blank screen) and wait a few more seconds and
then unlock by slider or sliding out the screen and the expected outcome will
be the actual and correct outcome.
Comment 6 Andre Klapper maemo.org 2010-02-02 13:40:04 UTC
This has been fixed in package
hildon-desktop 1:2.2.129-1+0m5
which is part of the internal build version
2010.04-11
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 7 Andre Klapper maemo.org 2010-02-05 12:46:33 UTC
*** Bug 8841 has been marked as a duplicate of this bug. ***
Comment 8 Andre Klapper maemo.org 2010-03-15 20:54:20 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 9 Neil MacLeod maemo.org 2010-05-26 00:44:31 UTC
Fixed in PR1.2 (10.2010.19-1, full reflash) - thanks. Verifying.