Bug 8033 - SIP call not available in Phone UI when calling a recent contact
: SIP call not available in Phone UI when calling a recent contact
Status: RESOLVED DUPLICATE of bug 8159
Product: Chat & Call & SMS
Call Application UI
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 1 vote (vote)
: ---
Assigned To: rtcomm@maemo.org
: call-ui-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-15 07:51 UTC by Venomrush
Modified: 2010-01-21 16:48 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2010-01-15 07:51:22 UTC
SOFTWARE VERSION:
PR1.1

EXACT STEPS LEADING TO PROBLEM: 
1. Open Phone UI
2. Select a contact from recent call list

EXPECTED OUTCOME:
'SIP audio' available 

ACTUAL OUTCOME:
'SIP audio' not available

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Fixing issue to let users SMS to recent call contacts had left out the SIP
calling feature.

This should be an easy fix in my opinion.
Comment 1 Andre Klapper maemo.org 2010-01-15 18:57:02 UTC
This is definitely missing steps to reproduce.
For example IM and SIP accounts available. Please always provide exact steps as
this makes it way easier to reproduce issues...! Thanks!

> ACTUAL OUTCOME:
> 'SIP audio' not available

So what exactly is available?
Comment 2 Venomrush (reporter) 2010-01-16 03:03:36 UTC
(In reply to comment #1)
> 
> So what exactly is available?
> 

Going to Phone UI, tap any contact in the recent call list, only the cellular
phone number and text message are available.

In 44-11, there is another option for making SIP call along with cellular +
text message
Comment 3 wierdo 2010-01-18 12:28:34 UTC
If it is a contact, tap on the contact's avatar, and all the methods of
contacting that particular person will appear.

If the number isn't in your contacts, you're out of luck if the call didn't
come in over SIP.
Comment 4 Venomrush (reporter) 2010-01-18 12:52:49 UTC
(In reply to comment #3)
> If it is a contact, tap on the contact's avatar, and all the methods of
> contacting that particular person will appear.
> 
> If the number isn't in your contacts, you're out of luck if the call didn't
> come in over SIP.
> 

Your comments made me confused.

I'm talking about those contacts with a phone number, no SIP option is
available to call them in recent call list.
Comment 5 wierdo 2010-01-18 13:00:22 UTC
Yes, if the cellular call didn't come from someone already in your contacts,
there doesn't appear to be a way to call the number back over SIP.
Comment 6 Andre Klapper maemo.org 2010-01-21 16:48:14 UTC
Collecting all duplicates of bug 8159 in that bug, even if this one is older
(sorry, spotted it too late).

*** This bug has been marked as a duplicate of bug 8159 ***