Bug 8012 - Using volume/zoom hardware buttons: Volume changed slowly, must wait 8 seconds
: Using volume/zoom hardware buttons: Volume changed slowly, must wait 8 seconds
Status: CLOSED WONTFIX
Product: Multimedia
Multimedia framework
: 5.0/(2.2009.51-1)
: All Maemo
: Unspecified normal with 13 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: multimedia-framework-bugs
:
:
: int-151641
:
  Show dependency tree
 
Reported: 2010-01-15 00:03 UTC by Andrej Krutak
Modified: 2010-07-01 04:05 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrej Krutak (reporter) 2010-01-15 00:03:03 UTC
SOFTWARE VERSION:
51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Using volume hardware control

EXPECTED OUTCOME:
Volume is controlled smoothly, and in locked mode (on the screen where one can
use slider to unlock) it is possible to change volume by pressing the volume
keys.

ACTUAL OUTCOME:
The volume takes about 8 seconds to go from zero volume to full volume. By
pressing the button quickly (in either direction), the volume changes even
slower. I think in 41-10, the movement was much smoother and faster, nicer to
use...

In the unlock screen, it volume buttons can't be used at all. This is very
unpleasant when controling volume without taking mobile off pocket. This worked
in previous version(s).

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
nothing important

OTHER COMMENTS:
if this is intended behaviour, a switch (using gconf or something similar)
would be very appreciated to override this behavior...
Comment 1 Tim Watt 2010-01-15 00:44:31 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Andre Klapper maemo.org 2010-01-21 20:05:26 UTC
Hi, please don't mix up two issues in one bug report. Unlock screen is covered
by bug 8011 already, hence convering the other issue only:


> EXACT STEPS LEADING TO PROBLEM: 
> 1. Using volume hardware control
> 
> EXPECTED OUTCOME:
> Volume is controlled smoothly
> 
> ACTUAL OUTCOME:
> The volume takes about 8 seconds to go from zero volume to full volume. By
> pressing the button quickly (in either direction), the volume changes even
> slower. I think in 41-10, the movement was much smoother and faster, nicer to
> use...

How was it in 42-11? I must admit that I don't really remember it...
Comment 3 Andrej Krutak (reporter) 2010-01-21 20:15:29 UTC
AFAIRemember, the volume control was smoother and faster... like, when I press
volume button twice, the volume often doesn't change  (well, at least the
indicator doesn't move)...

And if it was the same in 41/42 releases (I doubt that - it didn't bother me
back then, so...), it still deserves some programmer's love, I'd say...
Comment 4 Andrej Krutak (reporter) 2010-01-27 13:41:08 UTC
now that I spent some time with "new" volume control, it seems like it's
behaving correctly - the volume is changed continuously, only

a) the volume indicator seems to use some "rounding", so the visual appearance
is confusing (it looks like the volume changing speed was changed randomly,
when a volume key is pressed - when in reality, volume changes continuously,
but indicator "moves" with different speeds)

b) the continuous speed is too slow.. I'd suggest some speed increase, when
volume button is held pressed for more than, say, 0.2 s ...
Comment 5 Uwe Kaminski 2010-04-16 11:26:37 UTC
*** Bug 8205 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper maemo.org 2010-06-30 22:25:58 UTC
Nokia currently has no plans to change the "speed" of the volume change.
Comment 7 Uwe Kaminski 2010-06-30 23:30:35 UTC
This has been improved in PR 1.2: Now it takes less than 4 Seconds from zero to
max. Hence this can should be closed as fixed. Please feel free to change the
state if you disagree. :)
Comment 8 Ndi 2010-07-01 04:05:51 UTC
Agreed, the pain is gone now. Also vote on fixed.