Bug 8002 - (int-148215) Being offline, RSS Reader tries to connect for refresh unconditionally
(int-148215)
: Being offline, RSS Reader tries to connect for refresh unconditionally
Status: RESOLVED FIXED
Product: Desktop Widgets
RSS feed reader
: 5.0/(2.2009.51-1)
: All Maemo
: High major with 10 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: rss-feed-reader-applet-bugs
:
: use-time
:
: int-153616 8484
  Show dependency tree
 
Reported: 2010-01-14 22:02 UTC by Yves-Alexis
Modified: 2010-03-24 11:23 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Yves-Alexis (reporter) 2010-01-14 22:02:22 UTC
SOFTWARE VERSION:
(Settings > General > About product)
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. open RSS reader
2. tap the menu bar, then settings
3. choose to update automagically:
   - when on WLAN;
   - every 15 minutes

EXPECTED OUTCOME:
When on wlan, RSS feeds are updated every 15 minutes. When not connected or on
cell, no update at all.

ACTUAL OUTCOME:
When not connected at all, a “connection popup window” (asking which connection
to chose) appears. I guess that means it tries to find a connection to update
the feeds.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
I have the RSS applet shown on the desktop area. I don't know what happens if
I'm connected to GPRS (wether it updates or not).

This behavior appeared in the 2.2009.51-1 upgrade.

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531+
(KHTML, like Gecko) Safari/531.2+ Midori/0.2.2
Comment 1 Yves-Alexis (reporter) 2010-01-14 22:04:01 UTC
*** Bug 8003 has been marked as a duplicate of this bug. ***
Comment 2 Yves-Alexis (reporter) 2010-01-14 22:36:15 UTC
It seems that even when on GPRS connection it tries to update, even if I
specifically asked to only refresh while on wlan.
Comment 3 Yves-Alexis (reporter) 2010-01-15 12:06:23 UTC
Ho and it happens wether the RSS Reader is running or not, because of the RSS
widget. If I disable the RSS widget, the problem's gone too.
Comment 4 Andre Klapper maemo.org 2010-01-19 15:20:40 UTC
*** Bug 8147 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-19 15:36:54 UTC
Good catch! Confirming.
This most likely triggers bug 8115.
Comment 6 massimo.bilvi 2010-01-19 22:52:45 UTC
I confirm the bug.
Comment 7 Vincent Lefevre 2010-01-21 18:13:39 UTC
I got this problem too yesterday, while I was using the camera, and this was
even worse: for several dozens of seconds, I couldn't control the device: the
popup window was reappearing just after I clicked in an empty area (since I
didn't want to connect).
Comment 8 Aranel Surion 2010-02-03 11:13:27 UTC
Confirmed here.
Comment 9 Andre Klapper maemo.org 2010-02-09 20:03:14 UTC
This has been fixed in package
osso-rss-feed-reader 1.8.03-3+0m5
which is part of the internal build version
10.2010.05-6
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 10 Andre Klapper maemo.org 2010-02-12 18:04:05 UTC
(Correcting Product/component)
Comment 11 Andre Klapper maemo.org 2010-02-12 18:04:25 UTC
*** Bug 8090 has been marked as a duplicate of this bug. ***
Comment 12 Vincent Lefevre 2010-02-12 19:56:53 UTC
(In reply to comment #7)
> I got this problem too yesterday, while I was using the camera, and this was
> even worse: for several dozens of seconds, I couldn't control the device: the
> popup window was reappearing just after I clicked in an empty area (since I
> didn't want to connect).

What I was seeing here could be bug 9029.
Comment 13 Jon Hedemann 2010-02-23 21:37:38 UTC
*** Bug 8381 has been marked as a duplicate of this bug. ***
Comment 14 Andre Klapper maemo.org 2010-03-07 17:24:43 UTC
*** Bug 9432 has been marked as a duplicate of this bug. ***
Comment 15 Andre Klapper maemo.org 2010-03-15 20:54:06 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 16 Lucas Maneos 2010-03-24 11:23:23 UTC
*** Bug 9687 has been marked as a duplicate of this bug. ***