Bug 8000 - UPnP streaming movies: sound plays fine, video is stuck on first frame
: UPnP streaming movies: sound plays fine, video is stuck on first frame
Status: RESOLVED DUPLICATE of bug 8043
Product: Multimedia
Media streamer
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal with 49 votes (vote)
: ---
Assigned To: internet-tablet-addons@nokia.com
: media-streamer-addon-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-14 21:30 UTC by Floriano Scioscia
Modified: 2010-03-01 21:49 UTC (History)
19 users (show)

See Also:


Attachments
First video test case affected by the bug (1.02 MB, video/avi)
2010-01-14 22:40 UTC, Floriano Scioscia
Details
Second video test case affected by the bug (1.81 MB, video/mp4)
2010-01-14 22:47 UTC, Floriano Scioscia
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Floriano Scioscia (reporter) 2010-01-14 21:30:47 UTC
SOFTWARE VERSION:
5.0(2.2009.51-1)

EXACT STEPS LEADING TO PROBLEM: 
1. Share movies via UPnP from a PC. I use TVersity Media Server, but others are
reporting the same issue today in talk.maemo.org
(http://talk.maemo.org/showthread.php?p=471484#post471484) using Windows
Vista's "Media sharing" function in the Windows Network and Sharing Centre.
2. Open either Media Player or File manager on N900.
3. Select your PC as media server.
4. Browse folders, go to a movie and select it.

EXPECTED OUTCOME:
Media Player connects and starts playing. Both audio and video are played
correctly.

ACTUAL OUTCOME:
Media Player connects and starts playing. Audio is played correctly. Video is
stuck on the first frame.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
TVersity Media Server on a PC with Windows XP; none related to multimedia
framework and codecs on N900.

OTHER COMMENTS:
In particular, I tested that the problem occurs with movie files with the
following characteristics:
1) AVI container; DivX video codec, 700 to 1000 kbps; MP3 audio codec, 64 to
128 kbps; resolution 320x240 or 640x480, 25 frames/s
2) MP4 container; MPEG4 video codec, 700 to 1000 kbps; AAC audio codec, 96
kbps; resolution lower or equal to 640x360, 25 frames/s

The same movie files (with no change on the PC media server) were played
correctly with Maemo 5 1.2009.42.11 firmware version.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.1.7)
Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7 (.NET CLR 3.5.30729)
Comment 1 Floriano Scioscia (reporter) 2010-01-14 22:40:48 UTC
Created an attachment (id=1980) [details]
First video test case affected by the bug
Comment 2 Floriano Scioscia (reporter) 2010-01-14 22:47:33 UTC
Created an attachment (id=1981) [details]
Second video test case affected by the bug

Both this attachment and the one in Comment #1 are affected by the bug when
played in streaming. If they are copied to N900 (e.g. via Bluetooth) and played
locally, instead, both audio and video are OK.
Comment 3 javiermon 2010-01-15 00:18:55 UTC
This happens to me. Just upgraded to 5.0(2.2009.51-1)

My media server is a ubuntu 9.10 machine with mediatomb which used to work fine
in the PR1.0 firmware.
Comment 4 John Perez 2010-01-15 14:12:55 UTC
For me, this problem appeared only after update to 2.2009.51-1.002

Video files were verified as playing correctly with previous version of N900
software as well as a separate Windows XP based upnp client.

Now they get stuck on the first frame when played on the N900 via wifi, but
play correctly if copied to the N900 itself.
Comment 5 John Perez 2010-01-15 15:15:24 UTC
After more testing, many of the previously functional videos seem to be
identified as 1 second in duration (if that is what is indicated by the number
on right of timeline which reads 00:01), a small number of others are
identified with correct length but still fail to play video.  Also, when a
single frame is shown, the accompanying audio stops after anywhere from 5-30
seconds and does not continue for the duration of the file in my case.
Comment 6 Calum Lind 2010-01-16 04:38:32 UTC
(In reply to comment #3)
> This happens to me. Just upgraded to 5.0(2.2009.51-1)
> 
> My media server is a ubuntu 9.10 machine with mediatomb which used to work fine
> in the PR1.0 firmware.
> 

Exactly the same with me
Comment 7 mike choy 2010-01-16 11:39:27 UTC
I believe that this may be the same problem as local videos also not playing as
discussed in this thread.

http://talk.maemo.org/showthread.php?t=40675&highlight=pr1.1

Videos play in KM Player,but not in the in built media player
Comment 8 janne.koivukoski 2010-01-16 12:14:34 UTC
Streaming begins, but stops intermediately and the connection to the server
breaks and the login page comes to screen. In previous version this worked
well.
Comment 9 Bill 2010-01-16 12:26:17 UTC
I get the same using western digital network drive and twonky. Audio playing,
still stuck on first frame for video. This is on all types of video.
Comment 10 wierdo 2010-01-16 12:38:04 UTC
This also happens for me using both Orb and XBMC as upnp servers. Audio plays
for 15-20 seconds without video, then displays a buffering message for an
instant, then stops. Audio streaming works perfectly.

I have no problem playing videos stored on the device.
Comment 11 egoshin 2010-01-16 23:21:59 UTC
(In reply to comment #7)
> I believe that this may be the same problem as local videos also not playing as
> discussed in this thread.
> 
> http://talk.maemo.org/showthread.php?t=40675&highlight=pr1.1
> 
> Videos play in KM Player,but not in the in built media player
> 

Local video started playing well after re-installation of Extra Decoder Support
and passing a couple of hours. See

http://talk.maemo.org/showthread.php?p=476597#post476597
Comment 12 Philip Langdale 2010-01-18 04:33:56 UTC
Note that this problem only happens with xvid/mpeg4-part-2/h.263 files. h.264
files play correct, assuming that bug 8172 is avoided.
Comment 13 Felix 2010-01-18 14:40:09 UTC
Also image browsing appear to be broken. With Twonkymedia server on Vista 64
I've the same problem reported here with videos, fully working audio streaming
and any image available from n900 (except the local images). Other upnp clients
are working ok
Comment 14 massimo.bilvi 2010-01-18 18:10:24 UTC
This happens also to me. 

My media server is a debian machine running ushare.
Streaming xvid was fine in the previous firmware.
Comment 15 massimo.bilvi 2010-01-18 20:53:22 UTC
This bug is the same as 8043 which is already fixed?
Comment 16 Matt 2010-01-20 01:55:37 UTC
Agreed I have the exact same problems described streaming any video codec.

Incidentally my friend has an n900 and streaming with my TVersity 1.7.2.1
server on Win 7 x64 it worked fine (before the recent Maemo pushed update).

However, I since have bought the n900 and cannot stream it to my device. (this
is after the Maemo update).

Picture freezes on frame one, audio plays, scroll bar moves correctly and
jogging through the video does not update the video.

Thanks
Comment 17 John Perez 2010-01-20 04:43:24 UTC
Bug 8043 deals with HTTP streaming, rather than this bug which is regarding
UPnP streaming and is not yet fixed.
Comment 18 Philip Langdale 2010-01-20 04:56:47 UTC
upnp is http based and when you ultimately decided to play a file, it looks the
same, underneath, as what was shown in bug 8043 - so I strongly suspect this is
fixed (internally) as well - someone on the inside will need to verify to
close.
Comment 19 martin 2010-01-21 00:10:34 UTC
Happening with TVersity for me;

Initialise stream through either File Manager or Media Player and I get sound
for a while but no running video.

BUT - if I copy the same file through TVersity to Local storage on the N900,
they play back fine
Comment 20 janne.vakkilainen 2010-01-21 10:33:34 UTC
Happens with Elgato Eyeconnect 1.53 too. 
Worked fine before PR1.1.
Definitely needs a fix.
Comment 21 Andre Klapper maemo.org 2010-01-22 14:34:46 UTC
I'm wondering if this is related to /same root issue as bug 8254 comment 20.
Comment 22 zaheer merali 2010-01-22 14:47:54 UTC
Thanks for the 2 files, I will try to debug why they don't play well over http.
Comment 23 zaheer merali 2010-01-22 15:09:17 UTC
Ok I can reproduce with the avi file (first test case) but not the mp4.

With the avi both these pipelines fail with just first frame shown but rest of
sound plays:

gst-launch -v playbin2 uri=http://<my_webserver>/test1.avi
gst-launch -v http://<my_webserver>/test1.avi ! avidemux ! dspvdec !
xvimagesink
Comment 24 zaheer merali 2010-01-22 15:30:45 UTC
What is interesting is that if I do:

gst-launch -v http://<my_webserver>/test1.avi ! avidemux ! dspvdec ! gdppay !
filesink location=<location>

and play that back with: gst-launch -v filesrc location=<location> ! gdpdepay !
xvimagesink on either n900 or my desktop, i get that single frame.
Comment 25 Zvonimir 2010-01-25 07:32:07 UTC
(In reply to comment #24)
> What is interesting is that if I do:
> 
> gst-launch -v http://<my_webserver>/test1.avi ! avidemux ! dspvdec ! gdppay !
> filesink location=<location>
> 
> and play that back with: gst-launch -v filesrc location=<location> ! gdpdepay !
> xvimagesink on either n900 or my desktop, i get that single frame.
> 

I know realize that the bug I have been commenting on 8254 rather belongs here.
I confirm the following:

1) MPEG encoded video files play fine locally and over uPnP (using DLink
NDS-323
NAS box as a server).

2) AVI contained files with MPEG compressed video play fine locally or over
uPnP

3) AVI contained files with xvid/divx encoding play fine locally, but over uPnP
play only audio (which is mpeg layer 3) and show the first frame only.

I apologize for making several posting not realizing the importance of what
plays locally vs. what is streamed.
Comment 26 cocayden+maemo 2010-01-25 10:31:25 UTC
I also have this issue. I have tested on twonky and mythtv upnp server. This
did not happen before PR1.1
Comment 27 zaheer merali 2010-01-25 14:12:35 UTC
This is exactly the same as #8043

*** This bug has been marked as a duplicate of bug 8043 ***
Comment 28 simonliang86 2010-01-25 14:36:40 UTC
(In reply to comment #27)
> This is exactly the same as #8043
> 
> *** This bug has been marked as a duplicate of bug 8043 ***
> 

This may or may not be a duplicate of bug #8043. But the fact of the matter is,
there is STILL a problem with the video streaming and it was working prior to
the PR1.1 upgrade.

There is clearly a problem, so I do not understand why both bug #8043 is marked
as resolved.
Comment 29 zaheer merali 2010-01-25 14:42:37 UTC
bug 8043 is marked as resolved because it is fixed in an internal nokia build
so it will be fixed in PR1.2

UPnP streaming is exactly the same as HTTP streaming, just with added
convenience such as discovery etc.
Comment 30 simonliang86 2010-01-25 14:45:07 UTC
(In reply to comment #29)
> bug 8043 is marked as resolved because it is fixed in an internal nokia build
> so it will be fixed in PR1.2
> 
> UPnP streaming is exactly the same as HTTP streaming, just with added
> convenience such as discovery etc.
> 

When will we be seeing the release of PR1.2? I'm REALLY keen on getting HTTP
streaming back.
Comment 31 Andre Klapper maemo.org 2010-01-25 14:50:53 UTC
(In reply to comment #28)
> so I do not understand why both bug #8043 is marked as resolved.

See https://bugs.maemo.org/page.cgi?id=fields.html#resolution

(In reply to comment #30)
> When will we be seeing the release of PR1.2?

Nokia does not announce release dates of public updates in advance. For
followup questions to this please use a forum like talk.maemo.org as these
generic topics have nothing to do with this specific bug report. Thanks!
Comment 32 John Perez 2010-02-17 04:01:05 UTC
This bug is not fixed as of update 3.2010.02-8
Comment 33 janne.koivukoski 2010-02-17 21:10:45 UTC
After update to 3.2010.02-8 when I tried to free up memory as much I could I
succeeded to play streaming video once, but after reboot there was no lucky at
all. Could this be somehow memory related bug?
Comment 34 Andre Klapper maemo.org 2010-03-01 21:49:22 UTC
No, as bug 8043 is not fixed in 3.2010.02-8, but the version after that has not
been published yet...