Bug 7993 - (int-153264) User-facing camera displays many dead pixels and low/no noise reduction
(int-153264)
: User-facing camera displays many dead pixels and low/no noise reduction
Status: RESOLVED INVALID
Product: Images and Camera
Camera
: 5.0/(2.2009.51-1)
: N900 Maemo
: Unspecified normal with 12 votes (vote)
: ---
Assigned To: unassigned
: camera-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-14 19:03 UTC by Tim Samoff
Modified: 2010-10-03 00:43 UTC (History)
10 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Tim Samoff (reporter) maemo.org 2010-01-14 19:03:36 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Use the Mirror app (Extras) to access user-facing camera display

EXPECTED OUTCOME:
1MP, but clean(ish) output.

ACTUAL OUTCOME:
There are several dead pixels on the screen and little to no noise reduction of
image.

REPRODUCIBILITY:
always

OTHER COMMENTS:
This bug is an outcome of Bug #5663.
Comment 1 Attila Csipa nokia 2010-01-14 19:11:53 UTC
A solution would be maybe to hook into the noise reduction functions originally
intended for the main cam (harnessing functionality like the one in the ipp
gstreamer element).
Comment 2 dudi.cohen 2010-02-09 11:12:38 UTC
Just encountered this bug, while trying to port my application that uses front
cameras to maemo.
This pretty much makes the front camera utterly unusable for pretty much
anything.
Comment 3 atikin 2010-02-21 01:03:33 UTC
Some people reported a better camera output using GTalk video conversation.
Sorry, I lost the link to the thread, it is googlable though. Having a google
account I had no chance to check it with somebody for some reason. But I'm
ready to become a 'counterpart' for the videocheck: I'm living GMT+3 time; drop
me a line with your gmail if interested
Comment 4 Andre Klapper maemo.org 2010-03-05 12:30:23 UTC
Internal comment: "This cannot be fixed in the software due to hardware
limitations."
Comment 5 Tim Samoff (reporter) maemo.org 2010-03-05 15:12:59 UTC
(In reply to comment #4)
> Internal comment: "This cannot be fixed in the software due to hardware
> limitations."
> 

Interesting, because the camera used to yield better results (aside from the
dark band on the side). Once the dark band was "fixed," the quality of the
output became worse. Sure seems like a software issue to me.
Comment 6 Alan Bruce maemo.org 2010-03-10 21:15:17 UTC
So does this mean no official use of the front-facing camera on the N900 due to
"hardware limitations"? No video conferencing? That's pretty heartbreaking. I
assumed we'd get front-facing video apps eventually. This bug's resolution
sounds like the developers have completely given up on the front-facing cam.
Comment 7 Attila Csipa nokia 2010-03-11 00:14:32 UTC
Okay, how about making this at least into a 'generic gstreamer noise/hot pixel
removal element' enhancement ? Can we have Nokia support for that ?
Comment 8 bugzilla 2010-03-13 09:50:43 UTC
I am really disappointed and feel this is a marketing scam now.  The
prototype's front camera worked well.  The retail one's don't.
I think a class action suit for a recall may be necessary here.
Comment 9 Andre Klapper maemo.org 2010-05-12 15:50:44 UTC
"We cannot reproduce this unless in very dark (<50 lx) conditions.
Our latest releases were with acceptable quality.
Could you please share any  videos or frames in order to observe the reported
problem."
Comment 10 Tim Samoff (reporter) maemo.org 2010-05-12 16:01:34 UTC
(In reply to comment #9)
> "We cannot reproduce this unless in very dark (<50 lx) conditions.
> Our latest releases were with acceptable quality.
> Could you please share any  videos or frames in order to observe the reported
> problem."
> 

What would be the preferred method of capturing a frame from the front-facing
camera (i.e., to provide something that's "official" in regards to producing
the best possible quality)?
Comment 11 Attila Csipa nokia 2010-05-12 16:41:41 UTC
Can we take the 50lx figure as an official limit or reference light level ? A
quick check gives me 300-400lx when pointed to the window (sunlit street at
15h) and can easily get below 50lx when pointed away from the window or a
bright light source (which is generally how it's used). I dare not measure the
values when it's not broad daylight :)
Comment 12 Andre Klapper maemo.org 2010-06-17 13:11:51 UTC
(In reply to comment #10)
> What would be the preferred method of capturing a frame from the front-facing
> camera (i.e., to provide something that's "official" in regards to producing
> the best possible quality)?

I've asked this twice now internally and am still waiting for an answer from
Nokia.
Comment 13 Andre Klapper maemo.org 2010-10-03 00:43:07 UTC
So.....:

"Apologies for the late answer.

You can use the /dev/video1 device which conforms to V4L2 API. Yavta is
available here:

<URL:http://git.ideasonboard.org/>

AEWB won't be available this way, though.

AEWB is works with gst-launch though, something like this, untested:

gst-launch-0.10 v4l2camsrc device=/dev/video1 num-buffers=10 !
"video/x-raw-yuv, width=640, height=480, framerate=(fraction)3003/100" !
jpegenc ! filesink location=image.jpg