Bug 7987 - first click on wakeup always interpreted as application menu click
: first click on wakeup always interpreted as application menu click
Status: RESOLVED DUPLICATE of bug 7886
Product: Desktop platform
Home
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: home-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-01-14 18:17 UTC by Frank Banul
Modified: 2010-04-13 00:53 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Frank Banul (reporter) 2010-01-14 18:17:46 UTC
SOFTWARE VERSION: 2.2009.51-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. put screen to sleep
2. wake up screen
3. click any where besides application menu area

EXPECTED OUTCOME: location appropriate click registered

ACTUAL OUTCOME: desktop behaves as if application menu area was clicked

REPRODUCIBILITY: always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED: quite a bit

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us)
AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Comment 1 Frank Banul (reporter) 2010-01-14 23:32:36 UTC
I'm stupid. Sorry for filing this.
Comment 2 Frank Banul (reporter) 2010-01-15 02:24:49 UTC
I'm sorry, my initial report was wrong but this bug seems to still exist. Let's
try again.

SOFTWARE VERSION: 2.2009.51-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. screen is asleep
2. fbreader is topmost application
3. new email notification comes in
4. unlock screen and press top left application switcher button

EXPECTED OUTCOME: location appropriate click registered, take user to task
switcher

ACTUAL OUTCOME: button behaves as if application menu area was clicked

REPRODUCIBILITY: 1/1 at the moment, I'll comment back with more info

EXTRA SOFTWARE INSTALLED: quite a bit

OTHER COMMENTS:
Comment 3 Frank Banul (reporter) 2010-01-15 02:28:57 UTC
REPRODUCIBILITY: always

I also tried with the web browser topmost with the same result.
Comment 4 Frank Banul (reporter) 2010-01-15 02:29:45 UTC
And it appears to be any notification, IM or email, to trigger the event.
Comment 5 Andre Klapper maemo.org 2010-01-15 17:55:21 UTC
Thanks for reporting.

I'd love to see a second person confirming this, because so far I had no
problems with it...
Comment 6 John Veness 2010-03-20 00:21:58 UTC
I think I have since this a few times. I wake the device and immediately press
the top-left on-screen button, but instead the application menu appears, as if
I had pressed on the title bar. I haven't yet found a pattern to it.
Comment 7 John Veness 2010-03-25 12:32:10 UTC
I have seen this a few more times. The last time this happened, I did *not*
have any notifications waiting to be shown. I had X Terminal, File Manager, and
Notes running, with Notes as the topmost application when I woke the device. I
pressed the top-left button but the Notes application menu appeared instead.

I have grsync, leafpad, openssh client and server, rootsh installed, using
5.0/(3.2010.02-8) firmware.
Comment 8 John Veness 2010-03-25 12:48:40 UTC
I wonder if this bug is the same as Bug 7886, which will apparently be resolved
in PR 1.2?
Comment 9 Frank Banul (reporter) 2010-03-25 16:51:36 UTC
Bug 7886 looks suspiciously similar so I've installed the attachement and it
appears to solve the problem.
Comment 10 John Veness 2010-04-13 00:43:40 UTC
(In reply to comment #9)
> Bug 7886 looks suspiciously similar so I've installed the attachement and it
> appears to solve the problem.

Do you want to mark this bug as a duplicate of 7886?
Comment 11 Frank Banul (reporter) 2010-04-13 00:53:17 UTC
I haven't seen the reported problem since updating as described in 7886.
Marking as duplicate.

*** This bug has been marked as a duplicate of bug 7886 ***