Bug 7983 - After upgrading from 2009.42.203.2, product version appears as (null)
: After upgrading from 2009.42.203.2, product version appears as (null)
Status: RESOLVED INVALID
Product: Development platform
general
: 5.0-final
: N900 Maemo
: Unspecified normal with 3 votes (vote)
: ---
Assigned To: unassigned
: control-panel-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2010-01-14 17:10 UTC by Chris Pitchford
Modified: 2010-10-25 16:25 UTC (History)
9 users (show)

See Also:


Attachments
*#0000# in the phone application (176.06 KB, image/png)
2010-01-14 17:15 UTC, Chris Pitchford
Details
Settings, about product (97.17 KB, image/png)
2010-01-14 17:16 UTC, Chris Pitchford
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Chris Pitchford (reporter) 2010-01-14 17:10:41 UTC
SOFTWARE VERSION:
(Settings > General > About product)
That is the problem.. Settings -> General -> About product does not reveal
versions, only (null)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Upgrade from PR1.0 (2009-42.11.203.2) to PR1.0.1
2. Settings -> about

EXPECTED OUTCOME:
1.2009.44-203 or 
1.2009.51-203 or similar
ACTUAL OUTCOME:
(null)
REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
pc connectivity, telepathy plugins, 
OTHER COMMENTS:
Not sure if this is UK (203) specific
This device was updated via app.manager from PR1.0 to PR1.0.1 to PR1.1.. Since
PR1.0.1, only (null) has been visible
Using *#0000# in the phone application produces <n/a> <n/a>, <n/a> © Nokia

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Comment 1 Chris Pitchford (reporter) 2010-01-14 17:15:11 UTC
Created an attachment (id=1970) [details]
*#0000# in the phone application
Comment 2 Chris Pitchford (reporter) 2010-01-14 17:16:05 UTC
Created an attachment (id=1972) [details]
Settings, about product
Comment 3 Andre Klapper maemo.org 2010-01-14 18:11:43 UTC
*** Bug 7982 has been marked as a duplicate of this bug. ***
Comment 4 Andre Klapper maemo.org 2010-01-14 18:11:47 UTC
*** Bug 7981 has been marked as a duplicate of this bug. ***
Comment 5 Andre Klapper maemo.org 2010-01-14 18:55:54 UTC
Hi Chris, if you're familiar with the X Terminal, can you please post the
output of the commands
    ps aux | grep controlp
and
    set | grep OSSO

(Note to myself: According to int-114630 this issue might go as low as
maemo-launcher and dbus.)
Comment 6 Paul 2010-01-15 15:30:07 UTC
(In reply to comment #5)
> Hi Chris, if you're familiar with the X Terminal, can you please post the
> output of the commands
>     ps aux | grep controlp
> and
>     set | grep OSSO
> 
> (Note to myself: According to int-114630 this issue might go as low as
> maemo-launcher and dbus.)
> 
I have this issue. Arrived after 1.0.1, still there with 1.1. 

My output of the above commands is 

ps aux | grep controlp
 2789 user      3936 S    /usr/bin/controlpanel
 2790 user     25788 S    /usr/bin/controlpanel

Interestingly from the local machine I get 

set | grep OSSO
OSSO_SWAP='/media/mmc1'

from a remote SSH session 
set | grep OSSO
OSSO_PRODUCT_FULL_NAME='Nokia N900'
OSSO_PRODUCT_HARDWARE='RX-51'
OSSO_PRODUCT_KEYBOARD='English, Dutch'
OSSO_PRODUCT_NAME='N900'
OSSO_PRODUCT_REGION='Britain'
OSSO_PRODUCT_RELEASE_FULL_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_VERSION='2.2009.51-1.203.2'
OSSO_PRODUCT_SHORT_NAME='Nokia N900'
OSSO_PRODUCT_WLAN_CHANNEL='etsi/eu'
OSSO_SWAP='/home/user/MyDocs'
OSSO_VERSION='RX-51_2009SE_2.2009.51-1.203.2_PR_203'


HTH
Comment 7 Paul 2010-01-15 15:31:15 UTC
(In reply to comment #5)
> Hi Chris, if you're familiar with the X Terminal, can you please post the
> output of the commands
>     ps aux | grep controlp
> and
>     set | grep OSSO
> 
> (Note to myself: According to int-114630 this issue might go as low as
> maemo-launcher and dbus.)
> 
I have this issue. Arrived after 1.0.1, still there with 1.1. 

My output of the above commands is 

ps aux | grep controlp
 2789 user      3936 S    /usr/bin/controlpanel
 2790 user     25788 S    /usr/bin/controlpanel

Interestingly from the local machine I get 

set | grep OSSO
OSSO_SWAP='/media/mmc1'

from a remote SSH session 
set | grep OSSO
OSSO_PRODUCT_FULL_NAME='Nokia N900'
OSSO_PRODUCT_HARDWARE='RX-51'
OSSO_PRODUCT_KEYBOARD='English, Dutch'
OSSO_PRODUCT_NAME='N900'
OSSO_PRODUCT_REGION='Britain'
OSSO_PRODUCT_RELEASE_FULL_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_NAME='Maemo 5'
OSSO_PRODUCT_RELEASE_VERSION='2.2009.51-1.203.2'
OSSO_PRODUCT_SHORT_NAME='Nokia N900'
OSSO_PRODUCT_WLAN_CHANNEL='etsi/eu'
OSSO_SWAP='/home/user/MyDocs'
OSSO_VERSION='RX-51_2009SE_2.2009.51-1.203.2_PR_203'


HTH
Comment 8 Chris Pitchford (reporter) 2010-01-17 14:04:41 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > Hi Chris, if you're familiar with the X Terminal, can you please post the
> > output of the commands
> >     ps aux | grep controlp
> > and
> >     set | grep OSSO
> > 
> > (Note to myself: According to int-114630 this issue might go as low as
> > maemo-launcher and dbus.)
> > 

My apologies for delay, I missed the new posts.. 

from the ps auxw|grep controlp shows that controlpanel isn't running

set |grep OSSO reports only one line:
OSSO_SWAP='/media/mmc1'

This is the same if I ssh in as both user and root

~ $ ps auwx|grep controlp
 4866 user      2088 S    grep controlp 
~ $ set |grep OSSO
OSSO_SWAP='/media/mmc1'
Comment 9 Chris Pitchford (reporter) 2010-01-17 14:16:48 UTC
Ok, having a look through:
    osso-af-init/af-defines.sh

contains the section:
  if [ ! -d /scratchbox ]; then
    if [ ! -e /tmp/.opi.tmp -a -x /usr/bin/osso-product-info ]; then
      if [ "x$USER" = "xroot" ]; then
        _SUDO=''
      else
        _SUDO='sudo'
      fi
      $_SUDO /usr/bin/osso-product-info 1> /tmp/.opi.tmp.tmp 2> /dev/null
      $_SUDO /bin/mv -f /tmp/.opi.tmp.tmp /tmp/.opi.tmp 2> /dev/null
      unset _SUDO
    fi
    if [ -r /tmp/.opi.tmp ]; then
      VNAMES=`awk -F '=' '{print $1}' < /tmp/.opi.tmp`
      source /tmp/.opi.tmp
      export $VNAMES
      unset VNAMES
    fi
  fi


It seems I have a /scratchbox directory as a result of playing around with
pcconnectivity and the SDK and SBRSH.. 

If I move the directory aside

  sudogain root
  mv /scratchbox /scratchbox.keep

and reboot, the problem has gone.. 

Seems this is related to SDK usage.. and perhaps this had stopped working just
before I upgraded to -44 and then -51.. it might be older than I suggested..


In any case, I suspect that file might be where the problem lies, for me at
least
Comment 10 Andre Klapper maemo.org 2010-01-18 13:31:06 UTC
Thanks for investigations.
Looks like INVALID as per last comments?
Comment 11 Andre Klapper maemo.org 2010-01-18 16:19:51 UTC
Paul, can you check what Chris has written and if that aplies for your case
too?
Comment 12 Eero Tamminen nokia 2010-01-18 18:33:46 UTC
(In reply to comment #9)
> Ok, having a look through:
>     osso-af-init/af-defines.sh
> 
> contains the section:
>   if [ ! -d /scratchbox ]; then
...

This is not a valid way to check for being run inside Scratchbox (as that dir
exists also outside of Sbox).  The check should be for:
  /targets/links/scratchbox.config


(In reply to comment #9)
> It seems I have a /scratchbox directory as a result of playing around with
> pcconnectivity and the SDK and SBRSH.. 

(In reply to comment #10)
> Thanks for investigations.
> Looks like INVALID as per last comments?

AFAIK pcconnectivity is provided by SDK team and it's _intended_ to be
installed to the device.  If the other users have the same issue of having
/scratchbox dir on the device, I think this is SDK bug with major severity. 
Lots of things work differently when they think they're in Sbox.
Comment 13 Jarmo Tikka nokia 2010-01-20 09:55:26 UTC
It was not clear to me from this bug report how that /scratchbox directory was
created to the device. Waas it Maemo PC Connectivity instalaltion that created
it or was it some component/script installed by Maemo PC Connectivity taht
created it. Or maybe it was just user using Maemo PC Connectivity (with SSH and
disk mounts :) who created it :)
Comment 14 Jarmo Tikka nokia 2010-01-20 09:57:36 UTC
Just testing bugzilla by adding this comment as it failed to send notifications
for previous comment.
Comment 15 Paul 2010-01-20 11:44:40 UTC
I have pc-connectivity-manager, but I don't have a /scratchbox directory.

I do have a custom .profile, to manage an ssh agent, I moved that out of the
way and rebooted, and the problem is still there.
Comment 16 Chris Pitchford (reporter) 2010-01-25 00:39:05 UTC
(In reply to comment #15)
> I have pc-connectivity-manager, but I don't have a /scratchbox directory.
> 
> I do have a custom .profile, to manage an ssh agent, I moved that out of the
> way and rebooted, and the problem is still there.
> 
I didn't manually create the /scratchbox directory.. but I'll try to reproduce
the steps that did create it
Comment 17 Oran 2010-02-17 01:45:56 UTC
*** This bug has been confirmed by popular vote. ***
Comment 18 Oran 2010-02-17 01:56:42 UTC
i had this bug too. removed the /scratchbox folder, rebooted and it was solved.
(i have the pc-connectivity package installed and whole lot of other crap)

some more information which i'm not sure is related:
i had an update this morning and i was occupied so i installed it (thought it
was the currency conversion application). later discovered my battery lasts for
16 hours instead of just 6 (as it used to be). and checking maemo.org i
discovered it might have been PR 1.1.1.
went into the about screen in the control panel and saw the 'null' not sure if
it was there before the update or not.
anyway, now the about screen shows 2.2009.51-1 which is PR 1.1 and not 1.1.1.
when i check for updates it i don't get anything new, and also the free space
in the root file system seems a lot less than it was before (which together
with the longer battery life, hints that 1.1.1 was installed).
could it be that the /scratchbox folder (or anything related to the
pc-connectivity prevents the update from updating the version number? is there
any other way that i can check what version i have installed? (*#0000# gives me
2.2009.51-1 too).
Comment 19 Oran 2010-02-22 09:56:55 UTC
regarding the above comment:
it turns out my firmware was not updated (i had the UK version), so the bottom
part of my comment is irrelevant.
Comment 20 Tomi Ollila 2010-02-24 14:53:20 UTC
We did some extensive reading of sbrsh source and testing of sbrsh binary.

IIRC scratchbox source code has no reference to /scratchbox directory so by
default it doesn't do such.

it is possible to edit sbrsh config file such a way that it creates
/scratchbox directory on N900

If this is what happened with the reporters we'd like to get more detailed
information of what they did in order to think how to prevent such thing
happeneing in the future (by documenting the *feature* in a way users do not
make errors here).
Comment 21 spam 2010-02-24 17:43:06 UTC
Does this bug also apply to an issue where the phone will report <unkown>
instead of null?
My Phone is a German N900 and I DON'T have a /scratchbox dir.

When I do *#0000# I see
   V <unkown>
   <unkown>, <unkown>
   c Nokia

If this is related then here is the Software I have installed:
- Currency Converter
- OpenSSH Client
- rdesktop
- rootsh
- vncviewer
- python-tk (via apt-get to get IDLE to work)

I also installed these but have uninstalled them via the package manager:
- PyQt4 Demo (removed because some documentation was missing)
- PyQt4 Full Install
- Mclock
Comment 22 Eero Tamminen nokia 2010-02-24 18:00:11 UTC
what these report:
  dpkg -S scratchbox
  grep /scratchbox /var/lib/dpkg/info/*.p*inst
?
Comment 23 spam 2010-02-24 23:20:33 UTC
(In reply to comment #22)
> what these report:
>   dpkg -S scratchbox
>   grep /scratchbox /var/lib/dpkg/info/*.p*inst
> ?

Here is the output, I installed the OpenSSH server and logged in remotely. Hope
that is ok.
BTW, whoever wrote the installation script for the OpenSSH server did a nice
job. Worked too easy :)


7of9:~# dpkg -S scratchbox
dpkg: *scratchbox* not found.
7of9:~# grep /scratchbox /var/lib/dpkg/info/*.p*inst
/var/lib/dpkg/info/base-files.postinst:if [ -e /targets/links/scratchbox.config
]
/var/lib/dpkg/info/base-files.postinst: . /targets/links/scratchbox.config
/var/lib/dpkg/info/calendar.postinst:if [ -e /targets/links/scratchbox.config ]
; then
/var/lib/dpkg/info/calendar.postinst:   . /targets/links/scratchbox.config
/var/lib/dpkg/info/cmt-firmware-rx51.postinst:[ -e
/targets/links/scratchbox.config ] && exit 0
/var/lib/dpkg/info/hildon-application-manager-settings-standard.postinst:if [
-e /targets/links/scratchbox.config ] ; then
/var/lib/dpkg/info/hildon-application-manager-settings-standard.postinst:      
 . /targets/links/scratchbox.config
/var/lib/dpkg/info/kernel-flasher.postinst:if [ -L
/targets/links/scratchbox.config ]; then
/var/lib/dpkg/info/maesync-backend.postinst:if [ -e
/targets/links/scratchbox.config ] ; then
/var/lib/dpkg/info/maesync-backend.postinst:  .
/targets/links/scratchbox.config
/var/lib/dpkg/info/makedev.postinst:if [ -e /targets/links/scratchbox.config ]
/var/lib/dpkg/info/makedev.postinst:    . /targets/links/scratchbox.config
/var/lib/dpkg/info/nolo.postinst:if [ -L /targets/links/scratchbox.config ];
then
/var/lib/dpkg/info/osso-af-startup.preinst:# if [ -e
/targets/links/scratchbox.config ] ; then
/var/lib/dpkg/info/osso-af-startup.preinst:#   .
/targets/links/scratchbox.config
/var/lib/dpkg/info/osso-applet-device.postinst:if [ -e
/targets/links/scratchbox.config ]; then
/var/lib/dpkg/info/osso-applet-device.postinst:        .
/targets/links/scratchbox.config
/var/lib/dpkg/info/osso-core-config.postinst:if [ -e
/targets/links/scratchbox.config ] ; then
/var/lib/dpkg/info/osso-core-config.postinst:   .
/targets/links/scratchbox.config
/var/lib/dpkg/info/pymaemo-optify.postinst:if [ -e
/targets/links/scratchbox.config ]; then
/var/lib/dpkg/info/pymaemo-optify.preinst:if [ -e
/targets/links/scratchbox.config ]; then
Comment 24 Kristiina 2010-03-04 09:57:11 UTC
The error report is closed as invalid because we could not reproduce the
problem by just using PC-connectivity, SDK and SBRSH without explicitly
mounting or creating /scratchbox directory. And so far the reporter of the
error has not provided more precise information.
User has the possibility to configure SBRSH so that it mounts /scratchbox
directory to N900, but SBRSH does not do it implicitly.