Bug 798 - 401 Unauthorized
: 401 Unauthorized
Status: VERIFIED FIXED
Product: maemo.org Website
Repositories
: 2.0
: All Maemo
: Low normal (vote)
: 4.1+
Assigned To: Marcell Lengyel
: repositories@maemo.bugs
: http://repository.maemo.org/stable/
:
:
:
  Show dependency tree
 
Reported: 2006-10-08 09:26 UTC by giuliano torrente
Modified: 2011-04-27 14:26 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description giuliano torrente (reporter) 2006-10-08 09:26:38 UTC
This bug recalls what has been already told you with bug 445
Comment 1 giuliano torrente (reporter) 2006-10-08 09:49:59 UTC
This is what the browser's window shows while I attempt to fetch any content of 
the repository
Authorization Required
 This server could not verify that you are authorized to access the document 
requested. Either you supplied the wrong credentials (e.g., bad password), or 
your browser doesn't understand how to supply the credentials required.

Same results if I try to fetch a file of the repository using wget
giuliano@linux-hl2e:~>  wget 
http://repository.maemo.org/pool/mistral/free/n/ncurses/ncurses-base_5.4-3_all.deb
--08:18:39--  
http://repository.maemo.org/pool/mistral/free/n/ncurses/ncurses-base_5.4-3_all.deb
           => `ncurses-base_5.4-3_all.deb'
Risoluzione di repository.maemo.org in corso... 213.156.44.154, 213.156.44.152
Connessione a repository.maemo.org|213.156.44.154:80... connesso.
HTTP richiesta inviata, aspetto la risposta... 401 Unauthorized

the traceroute from my machine to the repository is:
1  192.168.1.1 (192.168.1.1)  0.768 ms   0.469 ms   0.428 ms
 2  23.250.168.1 (23.250.168.1)  10.705 ms   11.156 ms   8.802 ms
 3  10.1.223.34 (10.1.223.34)  8.142 ms   7.270 ms   7.211 ms
 4  10.251.179.209 (10.251.179.209)  9.331 ms   7.685 ms   7.750 ms
 5  10.251.174.24 (10.251.174.24)  8.036 ms   10.125 ms   7.478 ms
 6  10.251.175.1 (10.251.175.1)  8.346 ms   9.686 ms   7.536 ms
 7  10.251.179.194 (10.251.179.194)  7.717 ms   9.439 ms   8.221 ms
 8  10.1.152.14 (10.1.152.14)  8.499 ms   9.257 ms   8.371 ms
 9  10.128.0.6 (10.128.0.6)  9.021 ms   10.691 ms   8.004 ms
10  10.254.1.53 (10.254.1.53)  8.897 ms   10.537 ms *
11  83-103-100-174.ip.fastwebnet.it (83.103.100.174)  17.847 ms   19.435 ms   
17.829 ms
12  83-103-100-174.ip.fastwebnet.it (83.103.100.174)  17.653 ms   17.635 ms   
17.549 ms
13  62-101-93-6.ip.fastwebnet.it (62.101.93.6)  18.763 ms   19.315 ms   17.809 
ms
14  a213.140.4.113.deploy.akamaitechnologies.com (213.140.4.113)  18.107 ms   
18.003 ms   18.204 ms

P.S the first two loops are related to my domestic router, and to the DHCP 
server of my ISP, fastweb. By the way, if you make a ripe/whois query related 
to a213.140.4.113.deploy.akamaitechnologies.com (213.140.4.113), you would find 
out that quite certainly it's a machine assigned also to some network services 
for fastweb

I tried to fetch files from the repository using a remote shell account I have 
with another ISP, located of course in Italy (like me)

The fetch action was successful
This is the result:
folic@linux:~> wget 
http://repository.maemo.org/pool/mistral/free/n/ncurses/ncurses-base_5.4-3_all.deb
--06:52:13--  
http://repository.maemo.org/pool/mistral/free/n/ncurses/ncurses-base_5.4-3_all.deb
           => `ncurses-base_5.4-3_all.deb'
Risoluzione di repository.maemo.org in corso... 195.22.198.30, 195.22.198.37
Connessione a repository.maemo.org|195.22.198.30:80... connesso.
HTTP richiesta inviata, aspetto la risposta... 200 OK
Lunghezza: 11,066 (11K) [application/x-debian-package]

This time, the ripe/whois query, related to repository.maemo.org|195.22.198.30 
is:
% Information related to '195.22.198.0 - 195.22.198.127'

inetnum:      195.22.198.0 - 195.22.198.127
netname:      AKAMAI-OVER-SEABONE
descr:        Akamai Servers in Telecom Italia International Backbone
country:      IT
admin-c:      NARA1-RIPE
tech-c:       NARA1-RIPE
rev-srv:      dns.seabone.net
rev-srv:      trider-g7.seabone.net
status:       ASSIGNED PA
remarks:      ***************************************************************

Of course it's technically easy for me to download from the repository all the 
files I need, using my remote shell account, and then copy those files to my 
Tablet using sftp, (or copying them to the MMC card), but the main problem, of 
course, is the "weird reaction" of the maemo repository, when accessed through 
the Fastweb network. By the way Fastweb is one of the leading ISPs' in Italy

Thanks for your support

Giuliano Torrente
Comment 2 Ferenc Szekely maemo.org 2006-11-07 16:25:42 UTC
Request was sent to the network admins to check this bug.
Comment 3 Ferenc Szekely maemo.org 2006-12-13 11:16:50 UTC
The network admins are investigating this problem right now. Could you please
try accessing the repository and download this file:
http://repository.maemo.org/pool/scirocco/free/a/adduser/adduser_3.51_all.deb

Thanks!
Comment 4 giuliano torrente (reporter) 2006-12-20 13:16:07 UTC
Everything works smoothly now
I made the test, and downloaded the file without problems
Ciao
Giuliano Torrente
Comment 5 Ferenc Szekely maemo.org 2007-01-29 23:21:51 UTC
Simply marking as FIXED.
Comment 6 Mike Lococo 2007-02-04 19:24:49 UTC
Comments show this bug has been fixed, marking it as such.
Comment 7 andrea trentini 2007-02-23 18:48:34 UTC
same as bug #445

I also have the same problem, see my comment on #445 and posting in the
maemo-users ml
Comment 8 andrea trentini 2007-02-23 18:54:39 UTC
this is the result of an 'apt-get update' form inside fastweb (big NATted
network in Italy)


Failed to fetch
http://repository.maemo.org/dists/bora/free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/dists/bora/non-free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/dists/gregale/free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/dists/gregale/non-free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/dists/mistral/free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/dists/mistral/non-free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/extras/dists/bora/free/binary-armel/Packages.gz  401
Unauthorized [IP: 213.156.44.152 80]
Failed to fetch
http://repository.maemo.org/extras/dists/bora/non-free/binary-armel/Packages.gz
 401 Unauthorized [IP: 213.156.44.152 80]
Comment 9 andrea trentini 2007-02-27 12:32:47 UTC
still having intermittent "unauthorized" errors... it really seems a problem of
"maximum load" reached from a single IP (remember that all traffic coming from
fastweb in Italy arrives from ONE SINGLE IP)
Comment 10 andrea trentini 2007-02-27 13:02:00 UTC
... this traffic may be confused for a DOS attack...
Comment 11 Henri Bergius 2007-08-24 11:33:21 UTC
Changing component to Repositories.
Comment 12 Quim Gil nokia 2007-10-23 07:44:57 UTC
Can this have a relation with https://bugs.maemo.org/show_bug.cgi?id=1896 ?
Comment 13 Riccardo Setti 2008-01-13 19:51:03 UTC
i can confirm it, i can still reproduce it. I'm also using Fastweb as ISP. :(
Comment 14 Juha Kallioinen nokia 2008-02-05 11:49:33 UTC
Riccardo, do you get the 401 every time or occasionally?
Comment 15 Marat Radchenko 2008-04-09 21:18:11 UTC
Same error here (100% reproducible):

user@n800 ~ $ traceroute repository.maemo.org
traceroute: Warning: repository.maemo.org has multiple addresses; using
217.212.246.59
traceroute to a515.g.akamai.net (217.212.246.59), 30 hops max, 40 byte packets
 1  192.168.0.1 (192.168.0.1)  4.882 ms  4.455 ms  4.577 ms
 2  10.11.163.1 (10.11.163.1)  7.630 ms 41-111-st.zelcom.ru (80.92.111.41)
5.982 ms  10.467 ms
 3  gw30.eth.zelcom.ru (80.92.96.30)  31.708 ms  9.613 ms  12.604 ms
 4  * * *
 5  * 212.45.2.25 (212.45.2.25)  4917.359 ms  1805.329 ms
 6  Ulyan-SR-69.comcor.ru (62.117.100.69)  167.816 ms  141.571 ms  116.119 ms 7
 sl-gw10-sto-12-1.sprintlink.net (80.77.97.241)  40.863 ms  38.574 ms *
 8  sl-bb20-sto-8-0-0.sprintlink.net (80.77.96.37)  43.854 ms  40.191 ms 29.999
ms
 9  s-b3-link.telia.net (213.248.67.93)  110.199 ms  88.379 ms  78.522 ms
10  s-hdn-i3-link.telia.net (80.91.249.69)  52.765 ms  52.918 ms  61.889 ms
11  217-212-246-59.customer.teliacarrier.com (217.212.246.59)  61.127 ms 
51.910 ms  72.021 ms


P.S. link in comment  #3 by Ferenc Szekely returns 401 also.
Comment 16 Marat Radchenko 2008-04-09 22:16:34 UTC
Please see my comment to bug #1896:
https://bugs.maemo.org/show_bug.cgi?id=1896#c13
Comment 17 Andre Klapper maemo.org 2008-06-16 18:11:05 UTC
Juha: Any news? (High priority bug, so nagging here)
Comment 18 Juha Kallioinen nokia 2008-06-18 12:42:41 UTC
(In reply to comment #17)
> Juha: Any news? (High priority bug, so nagging here)

Hello, see discussion in bug 1896. There's not enough info in this bug to see
if the cause is any different from the (non-Iran) related cases there.
Comment 19 Andre Klapper maemo.org 2008-06-18 12:58:51 UTC
Juha: Well... what info do you need, then? Just ask, that's what bugtrackers
are for. :-)
Comment 20 Juha Kallioinen nokia 2008-06-18 13:02:27 UTC
(In reply to comment #19)
> Juha: Well... what info do you need, then? Just ask, that's what bugtrackers
> are for. :-)

First of all is there still an issue for others than Marat (he's active on the
other bug too)?

If this is still an issue for Riccardo, please provide logs of the outgoing
HTTP request similar to what's in bug 1896.
Comment 21 Andre Klapper maemo.org 2008-06-18 13:12:08 UTC
Thanks. :-)
Comment 22 Niels Breet maemo.org 2009-01-05 16:12:21 UTC
*** Bug 3959 has been marked as a duplicate of this bug. ***
Comment 23 Niels Breet maemo.org 2009-01-05 16:13:38 UTC
See Bug 3959 for more recent and detailed logs.
Comment 24 Michael T Farnworth 2009-01-08 13:30:42 UTC
This is still a bug, please fix it, why has it been going on for over 2 years? 
Is there anybody competent at Nokia looking into the problem.  It isn't low
priority if you bought a device and it has been crippled by the inability to
download any software.

Perhaps I should take the device with me to the Annual General Meeting of Nokia
on the 23 April and ask the chairman of the board if he will please explain to
all the shareholders why I can't use the device properly when the problem has
been known to exist for over 2 years.  It might not be a major issue to the
corporation as a whole, but I think we can be pretty confident he is going to
find it rather embarrassing.

Your call.
Comment 25 Marcell Lengyel maemo.org 2009-01-14 09:51:01 UTC
Michael, could you try to use stage.maemo.org instead of repository.maemo.org
and see if that makes any difference? r.m.o is using a caching network and
s.m.o is bypassing the cache. That would help to eliminate some variables in
the debugging process. Thanks.
Comment 26 Michael T Farnworth 2009-01-14 11:58:03 UTC
I tried changing it to stage.maemo.org for maemo Extras and the error message
changed slightly from '401 Unauthorized' to '401 Authorization Required', other
than that no change.

Here is the output of wget from my laptop when doing the same thing:

latitude:/tmp> cd /tmp/ ; wget -S
http://stage.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
--2009-01-14 09:46:53-- 
http://stage.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
Resolving stage.maemo.org... 62.61.85.32
Connecting to stage.maemo.org|62.61.85.32|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.1 401 Authorization Required
  Date: Wed, 14 Jan 2009 09:47:06 GMT
  Server: Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-18 mod_perl/1.29
  Connection: close
  Content-Type: text/html; charset=iso-8859-1
Authorization failed.

latitude:/tmp> cd /tmp/ ; wget -S
http://repository.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
--2009-01-14 09:47:20-- 
http://repository.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
Resolving repository.maemo.org... 92.122.126.234, 92.122.126.248
Connecting to repository.maemo.org|92.122.126.234|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.0 401 Unauthorized
  Server: Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-18 mod_perl/1.29
  Content-Type: text/html; charset=iso-8859-1
  Date: Wed, 14 Jan 2009 09:47:33 GMT
  Connection: close
Authorization failed.

Using the exact same query on a computer based in the UK rather than Isle of
Man I see the following:

[root@wjf tmp]# cd /tmp/ ; wget -S
http://stage.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
--09:52:25-- 
http://stage.maemo.org/extras/dists/diablo/free/binary-armel/Packages.gz
Resolving stage.maemo.org... 62.61.85.32
Connecting to stage.maemo.org|62.61.85.32|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Date: Wed, 14 Jan 2009 09:52:25 GMT
  Server: Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-18 mod_perl/1.29
  Content-Length: 575961
  Last-Modified: Tue, 13 Jan 2009 12:50:24 GMT
  Cache-Control: no-cache, no-store
  Connection: close
  Content-Type: text/plain; charset=iso-8859-1
Length: 575961 (562K) [text/plain]
Saving to: `Packages.gz'

100%[=========================================================================================================================================================================>]
575,961     54.0K/s   in 10s

09:52:36 (54.7 KB/s) - `Packages.gz' saved [575961/575961]

I think it is incredibly obvious that for some obscure unknown reason you are
blocking any ISP based in the Isle of Man.  It is also interesting to note that
I can get directory listings from your web servers, just not the contents of
files.

For example returning to the Isle of Man computer again this works:

latitude:/tmp> cd /tmp/ ; wget -S
http://repository.maemo.org/extras/dists/diablo/free/binary-armel/
--2009-01-14 09:55:39-- 
http://repository.maemo.org/extras/dists/diablo/free/binary-armel/
Resolving repository.maemo.org... 92.122.127.8, 92.122.126.234
Connecting to repository.maemo.org|92.122.127.8|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.0 200 OK
  Server: Apache/1.3.33 (Debian GNU/Linux) PHP/4.3.10-18 mod_perl/1.29
  Content-Type: text/html; charset=iso-8859-1
  Content-Length: 1233
  Expires: Wed, 14 Jan 2009 09:55:52 GMT
  Cache-Control: max-age=0, no-cache, no-store
  Pragma: no-cache
  Date: Wed, 14 Jan 2009 09:55:52 GMT
  Connection: keep-alive
Length: 1233 (1.2K) [text/html]
Saving to: `index.html'

100%[========================================================================================================================================================================>]
1,233       --.-K/s   in 0s

2009-01-14 09:55:40 (46.5 MB/s) - `index.html' saved [1233/1233]

The fact that  UK computer can retrieve the files doesn't help me as I live in
the Isle of Man and my handheld device is here not there!
Comment 27 Marcell Lengyel maemo.org 2009-01-14 12:06:49 UTC
We made some changes in the configuration, could you please try again with
repository.maemo.org?
Comment 28 Marcell Lengyel maemo.org 2009-01-20 10:19:27 UTC
A fix was applied to the file delivery service and we are hoping that this
fixes the download issues for Isle of Man, Italy, UK and Russia. If the problem
still exists please reopen the bug and tell the public IP address in the
comments so we could investigate.
Comment 29 Michael T Farnworth 2009-01-20 17:02:46 UTC
I was delighted to switch on my N810 this morning and to discover that I could
see the repositories.

Many thanks for all your efforts.

Michael
Comment 30 Andre Klapper maemo.org 2009-01-20 17:37:55 UTC
Cool. I take the last comment as "VERIFIED". :)
Comment 31 maemobug 2011-04-27 10:50:13 UTC
Hi!

This bug repeated again.
Trying from 2 different places to get page
http://repository.maemo.org/extras/dists/fremantle/free/binary-i386/Packages

and got error 

Authorization Required
This server could not verify that you are authorized to access the document
requested. Either you supplied the wrong credentials (e.g., bad password), or
your browser doesn't understand how to supply the credentials required.
Apache/2.2.9 (Debian) DAV/2 PHP/5.2.6-1+lenny4 with Suhosin-Patch
mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.9 OpenSSL/0.9.8g mod_perl/2.0.4
Perl/v5.10.0 Server at stage.maemo.org Port 80


I am from Russia,Saint-Pitersburg
Comment 32 maemobug 2011-04-27 14:26:55 UTC
(In reply to comment #31)
> Hi!
> 
> This bug repeated again.
> Trying from 2 different places to get page
> http://repository.maemo.org/extras/dists/fremantle/free/binary-i386/Packages
> 
> and got error 
> 
> Authorization Required
> This server could not verify that you are authorized to access the document
> requested. Either you supplied the wrong credentials (e.g., bad password), or
> your browser doesn't understand how to supply the credentials required.
> Apache/2.2.9 (Debian) DAV/2 PHP/5.2.6-1+lenny4 with Suhosin-Patch
> mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.9 OpenSSL/0.9.8g mod_perl/2.0.4
> Perl/v5.10.0 Server at stage.maemo.org Port 80
> 
> 
> I am from Russia,Saint-Pitersburg

Heh no answer,but problem fixed for now. I'll wait for evening for testing.
tnx