Bug 7971 - (int-153680) mail for exchange freezes when trying to sync calendar and tasks
(int-153680)
: mail for exchange freezes when trying to sync calendar and tasks
Status: RESOLVED FIXED
Product: Synchronization
Mail for Exchange
: 5.0/(3.2010.02-8)
: N900 Maemo
: High major with 18 votes (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: activesync-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-14 15:01 UTC by Eddie
Modified: 2010-08-02 21:11 UTC (History)
21 users (show)

See Also:


Attachments
a grep on activesync from the syslog (414.36 KB, application/octet-stream)
2010-01-15 00:28 UTC, Eddie
Details
Syslog including calendar log of failed sync (179.39 KB, application/octet-stream)
2010-01-20 12:39 UTC, Eddie
Details
requested detail-log (7.75 KB, application/x-zip)
2010-03-26 13:52 UTC, Michael Markstaller
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Eddie (reporter) 2010-01-14 15:01:24 UTC
SOFTWARE VERSION:
2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
I set up a mail for exchange profile to sync with a exchange 2003 server. After
setup the first synchronisation will start.

EXPECTED OUTCOME:
synchronisation of mail and of calendar and tasks


ACTUAL OUTCOME:
synchronisation of mail works fine.
If synchronisation of calendar and tasks is checked the synchronisation freezes
when calendar and tasks progress bar is at about 99%.
It's not possible to stop synchronisation. Both synchronisation and settings do
not respond. In TOP the as-daemon shows to run at 90% or more and will continue
even after killing it. Only way to stop as-daemon is a reboot.

On my exchange server i can see that my n900 calendar items are uploaded. The
details tab of MfE sais 80 items are downloaded but they do not show in my n900
calendar.

REPRODUCIBILITY:
Always
Comment 1 Vitaly Repin 2010-01-14 23:27:05 UTC
Could you take the logs as described here:
http://wiki.maemo.org/Mail_for_Exchange#How_can_I_turn_the_logging_ON_or_OFF.3F

It would be beneficial to understand the root cause.

Pls, make sure that the logs do not contain any data which you treat as a
personal.
Comment 2 Eddie (reporter) 2010-01-15 00:28:30 UTC
Created an attachment (id=1983) [details]
a grep on activesync from the syslog
Comment 3 RoG 2010-01-15 09:51:18 UTC
Hi,

I can also report having exacty the same condition. Syncronizing without
"calendar and tasks" works just fine (but a bit slow), but when I add these,
the sync stops at around 99% with the as-daemon eating about all processor
resourses. I've seen more people in the talk area experiencing this with
Exchange 2003/PR1.1. When upgrading, I did a clean install by running Maemo
flasher 3.5 tool. I've made no changes to the phone config, besides installing
some officially released apps from OVI store and Maemo. The old calendar was
deleted and I also removed all tasks in my Outlook/Exchange since I suspected
that the sync stoped there, but no luck.

Does the sync log from eddielukkien@hotmail.com say anything about the cause?
Do you want me to send mine?

Thanks,



(In reply to comment #1)
> Could you take the logs as described here:
> http://wiki.maemo.org/Mail_for_Exchange#How_can_I_turn_the_logging_ON_or_OFF.3F
> It would be beneficial to understand the root cause.
> Pls, make sure that the logs do not contain any data which you treat as a
> personal.

(In reply to comment #1)
> Could you take the logs as described here:
> http://wiki.maemo.org/Mail_for_Exchange#How_can_I_turn_the_logging_ON_or_OFF.3F
> It would be beneficial to understand the root cause.
> Pls, make sure that the logs do not contain any data which you treat as a
> personal.
Comment 4 Eddie (reporter) 2010-01-15 15:41:24 UTC
(In reply to comment #3)
> Does the sync log from eddielukkien@hotmail.com say anything about the cause?
> Do you want me to send mine?

Maybe it's a good idea to send in your logs as well. I looked at mine but could
not see anything that looked like error messages. Maybe because activesync was
still busy or stuck in a loop.

The problem could also be server side but still then activesync should not keep
on running, it should time-out and display an error message.

Even if i press 'stop synchronisation' and the gui disappears, activesync
continues to run in the background.
Comment 5 Eddie (reporter) 2010-01-16 15:15:26 UTC
I did some testing last night and found that activesync got stuck every time
after downloading the same amount of calendar items (i saw that when pressed
details). Looking through my items on the server I found that the item that was
last downloaded was a 'repeated event' (like a birthday or holliday). After
deleting some items AS still stuck at the same item. After deleting that item
it got stuck at another 'repeated event'. 
My guess is that importing repeated events cause the problem.
Comment 6 RoG 2010-01-16 17:58:48 UTC
Interresting and sounds like a valid theory! I experienced some strange things
in the earlier firmware versions for re-occuring events when syncronizing using
Nokia PC suite. Both that set reminders got off-sync and that changes in a
re-occurring event didn't get syncronized, so this might point at that the
existing firmwares have problems handlig re-occuring events.

I'll produce a log from my phone a.s.a.p. but it's not likely to give much
clues.
Comment 7 bob 2010-01-18 21:32:04 UTC
Exactly the same problem as reported - the calendar hangs on 194 uploads but
then stalls - no error reports.  I also deleted all tasks but no success.
Comment 8 Eddie (reporter) 2010-01-19 16:46:48 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Eddie (reporter) 2010-01-19 16:47:55 UTC
Is anybody from Maemo developers actually working on this Bug?
Comment 10 Andre Klapper maemo.org 2010-01-19 19:00:03 UTC
Yes.
Comment 11 Vitaly Repin 2010-01-19 23:09:58 UTC
What we (MfE team) can say right now - it hangs somewhere in calendar backend. 
There is a way to collect detailed calendar logs (what is happening in the
calendar backend while MfE inserts the entry into the calendar database). 

Unfortunately, I don't remember the instructions by heart.  Have requested this
data from our colleagues in calendar.  Pls, stay tuned.
Comment 12 Vitaly Repin 2010-01-20 10:46:51 UTC
(In reply to comment #7)
> Exactly the same problem as reported - the calendar hangs on 194 uploads but
> then stalls - no error reports.  I also deleted all tasks but no success. 

Could you or anybody who experiences the same problem take the calendar logs
during the failed sync?

The procedure:

1) Open xterm
2) Issue the command: 
touch /home/user/.calendar/log
3) Reboot the device

Calendar log will be located in /var/log/syslog (together with activesync logs)

Before publishing any logs, pls, make sure that they do not contain any data
which you treat as private or confidential.

Thank you for your help.
Comment 14 Eddie (reporter) 2010-01-20 13:34:03 UTC
(In reply to comment #13)
> I'll remove the birthday and will try
> to resync. But it will probably have to wait till this evening.

I tried it already, but it didn't solve the problem.
Comment 15 yvette 2010-01-21 12:51:57 UTC
I  have the same problem - mine always freezes at 316 so for now i have left
the calendar unsynced but I do need the function.  I am not techie enough nor
have i played enough with the n900 to understand the log instructions so cannot
proiduce one but I do have a lot of recurring things in my calendar.  i have
exactly the same setps and problem as Eddie and each time the calendar freezes
i have to completely turn on and off the phone and then put the phone offline
on rebooting in order to change the settings and turn off the synchronisation. 
I also find the mail and contacts sync slower than on the e71.  I am using
exchange 2007.  I have calendar set for the minimum of 2 weeks previous
entries. If you need more info I'm happy to follow very simple instructions to
produce it (I didn't understand how to install syslog to do that for you -
sorry..)
Thank you
Yve
Comment 16 bob 2010-01-21 14:06:09 UTC
I reported the problem a few days ago (report #7).  I have since removed all of
my recurring entries and cleared all of my reminders etc... It worked !! I am
now able to fully use the Calendar and tasks.  The phone links to an exchange
2003 server.  I haven't added any recurring entries since the deletion and I
won't until there is a fix.. I can live with that.

Hope this works for you...
Comment 17 Eddie (reporter) 2010-01-21 14:26:53 UTC
(In reply to comment #16)

I have found another workaround:
- In Outlook export your calendar to a comma separated file (.csv).
- The export wizard will ask you for a timeframe since it cannot export
recurring events (they would go on indefinitely). I used here 31-12-2012 as
latest date.
- Delete all your calendar items from Outlook
- Import the .cvs file
- Sync your N900

Works for me, only 2 problems:
- outlook won't let you delete all items at the same time. You have to delete
them one by one :(
- recurring events will now stop at the date limit you have set.

Bob's solution and mine are more evidence to the theory that recurring events
are the cause of this problem.
Comment 18 jason r. totten 2010-01-28 16:46:49 UTC
Let me know if you need logs - I'm currently in this state any time I try to
turn on Calendar sync...

Thanks,
Jason
Comment 19 Eddie (reporter) 2010-02-03 17:50:38 UTC
Are there any updates on this bug?
Comment 20 Andre Klapper maemo.org 2010-02-03 17:55:12 UTC
Patience please (in general). When there's updates, they are announced.
(And for potential followup rants on Nokia's partially non-transparent
processes please use the forum at talk.maemo.org ;-)
Comment 21 Cesare 2010-02-05 14:55:25 UTC
Hello guys !

I 'm having also this big problem and I cannot use complete MFE for this
reason.
I understand that there is no fix yet. PLEASE fix it as soon as possible and
give us the single update (I can'0t wait for other 3 months for a PR 1.2
complete update).
I bought the N900 but all these problem with MFE and Exchange 2003 has
prevented me to real use this device.
I can't delete all the outlook recurring event one by one; I have years of
events in my Exchange calendar. If there is no a other solution on the windows
side we need to have this fiexed as soon as possible !
Or any Guru of Linux/maemo can do something else ?

Anyway it's really strande that noone is working on a better calendar/PIM apps
for N900...


Thanks for the help,
Cesare
Comment 22 Cesare 2010-02-05 14:58:10 UTC
Hello guys !

I 'm having also this big problem and I cannot use complete MFE for this
reason.
I understand that there is no fix yet. PLEASE fix it as soon as possible and
give us the single update (I can'0t wait for other 3 months for a PR 1.2
complete update).
I bought the N900 but all these problem with MFE and Exchange 2003 has
prevented me to real use this device.
I can't delete all the outlook recurring event one by one; I have years of
events in my Exchange calendar. If there is no a other solution on the windows
side we need to have this fixed as soon as possible !
Or any Guru of Linux/maemo can do something else ?

Anyway it's really strange that noone is working on a better calendar/PIM apps
for N900...


Thanks for the help,
Cesare
Comment 23 Vitaly Repin 2010-02-08 15:36:18 UTC
Andre, what is the internal bug id for this issue?
Comment 24 Andre Klapper maemo.org 2010-02-08 16:31:39 UTC
Vitaly: See the Alias field.

Cesare: This is not a forum, please go to talk.maemo.org instead with your
issue.
Comment 25 Andrew Baumann 2010-02-16 21:52:12 UTC
I've just run into this bug and can confirm that it is still present on
3.2010.02-8. Please let me know if another set of logs would be helpful.
Comment 26 Leon 2010-03-04 13:33:25 UTC
Same here!

(In reply to comment #25)
> I've just run into this bug and can confirm that it is still present on
> 3.2010.02-8.
Comment 27 sam 2010-03-09 01:42:10 UTC
*** Bug 9382 has been marked as a duplicate of this bug. ***
Comment 28 technoswiss 2010-03-10 18:16:02 UTC
I had read about a work around for this bug, exporting your calendar with a
time frame to get rid of reoccurring appointments. I'm posting here as well
since it might help with solving the bug.

If you put an end date on all your reoccurring appointment (I picked
12/31/2012) then you can sync the calendar. So it appears the issue isn't just
reoccurring appointments, but reoccurring appointments with no end date.
Comment 29 Eddie (reporter) 2010-03-10 18:42:12 UTC
(In reply to comment #28)
> If you put an end date on all your reoccurring appointment (I picked
> 12/31/2012) then you can sync the calendar. So it appears the issue isn't just
> reoccurring appointments, but reoccurring appointments with no end date.

I agree that it's only recurring events with no end date. Sorry that I didn't
specify this in previous messages.
Your solution will work but in 2013 you will be forgetting birthdays and
annyversaries.

Will this bug be fixed in the next firmware update?
Comment 30 Michael Markstaller 2010-03-10 19:42:01 UTC
I probably have the same issue: syncing my calendar (E2003) let's as-daemon
hang at 100% CPU and never finishes. And there are many recurring items here..
Please let me know when you need another log of this.
Comment 31 redonj 2010-03-12 04:11:55 UTC
Same problem to me. For a month it Works perfectly. But now I can’t sync my
calendar and contacts.
Only works with mail. Sometimes woks when I do a complete resync.
Comment 32 Andre Klapper maemo.org 2010-03-15 14:45:43 UTC
Is it possible to get full logs for Calendar, MfE, alarmd?
For this:
#touch ~/.calendar/log
#touch ~/.calendar/logui
#touch ~/mfelogon
#touch /root/alarmd.verbose
#reboot
Comment 33 blackthor 2010-03-24 10:01:18 UTC
we were having the same problem (exchange 2003 synch over wlan)
everything synched fine except for calendar

deleting a certain birthday calendar event fixed this

hope this helps
Comment 34 Michael Markstaller 2010-03-26 13:52:36 UTC
Created an attachment (id=2532) [details]
requested detail-log

syslog with 
touch /home/user/.calendar/log
touch /home/user/.calendar/logui
touch /home/user/mfelogon
touch /root/alarmd.verbose

rebooted, enabled calendar-sync, as-daemon hangs at 80% cpu
Comment 35 Andre Klapper maemo.org 2010-04-07 13:13:31 UTC
Thanks!
"Incorrect INTERVAL value is provided by activesync. INTERVAL can't be "-1"."
Comment 36 Vitaly Repin 2010-04-07 15:03:18 UTC
(In reply to comment #35)
> Thanks!
> "Incorrect INTERVAL value is provided by activesync. INTERVAL can't be "-1"."

Another comment:

Fortunately, this issue can be easily reproduced with using KMail Organizer and
uploading to Exchange a yearly recurring event with specifying interval=1. It
looks like it doesn't provide the interval value if it is the default one.

Before the fix, calendar backend hangs with ~100% CPU usage when adding such an
event to calendar.
After the fix, it works well.
Comment 37 Chris Samuel 2010-04-11 17:15:44 UTC
My N900 stopped syncing with the Universities Exchange 2003 server recently,
and I suspect it was triggered by an invitation to a recurring event sent from
Lotus Notes by an IBMer (repeat invitiations from Uni staff have not caused any
issues previously).

Will try and confirm tomorrow that it is the same issue and whether this is
indeed the problem appointment.
Comment 38 Andre Klapper maemo.org 2010-04-22 14:30:19 UTC
This has been fixed in package
as-daemon 0.0.3-34+0m5
which is part of the internal build version
10.2010.14-16
(Note: 2009/2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
update.)
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.


To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 39 Eddie (reporter) 2010-08-02 21:06:21 UTC
Is it possible to delete comment #13? My girlfriend doesn't like that this page
shows up when googling her name...
Comment 40 Andre Klapper maemo.org 2010-08-02 21:11:43 UTC
(In reply to comment #39)
> Is it possible to delete comment #13?

Done (Hidden).