Bug 7964 - Provide x86_64 linux flasher
: Provide x86_64 linux flasher
Status: RESOLVED WONTFIX
Product: Flasher
Linux
: 5.0/(2.2009.51-1)
: other Linux
: Low enhancement with 3 votes (vote)
: ---
Assigned To: unassigned
: flasher-linux-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-14 13:54 UTC by Mikko Ruohola
Modified: 2012-03-24 11:47 UTC (History)
7 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mikko Ruohola (reporter) 2010-01-14 13:54:46 UTC
SOFTWARE VERSION:
Flasher 3.5

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Try to find 64-bit flasher to flash N900.
2. Fail to find it
3. 

EXPECTED OUTCOME:

Finding flasher 3.5 for 64-bit linux

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

This would be essential for power users and testers, who don't use 32bit linux.
It creates a bit of a problem to be a tester for N900 software, if there is no
verified way to flash N900 back if I brick my phone by accident. :)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2pre)
Gecko/20100109 Ubuntu/9.10 (karmic) Epiphany/2.22 Namoroka/3.6pre
Comment 1 Andre Klapper maemo.org 2010-01-14 18:22:44 UTC
Thanks for reporting.
For future reference, exact URL are welcome, like
http://tablets-dev.nokia.com/maemo-dev-env-downloads.php
Comment 2 Lucas Maneos 2010-01-15 04:56:28 UTC
Adjusting summary a bit (I assume x86_64 is what is requested and not, say,
PPC64).  For version 3.0 such a binary was provided.

Note that the i386 binary runs fine on x86_64 boxes if i386 libc & libusb are
available.
Comment 3 Yves-Alexis 2010-01-15 11:38:18 UTC
(In reply to comment #2)
> Adjusting summary a bit (I assume x86_64 is what is requested and not, say,
> PPC64).  For version 3.0 such a binary was provided.

In fact, the perfect way would be to provide sources so binaries could be built
for all architectures :)
> 
> Note that the i386 binary runs fine on x86_64 boxes if i386 libc & libusb are
> available.

Which is still a bit painful until everybody has multi-arch fully working.
Sure, redhat/fedora has bi-arch and Debian/Ubuntu the awful ia32-libs, but it's
not really maintainable atm.

Cheers,
--
Yves-Alexis
Comment 4 Andre Klapper maemo.org 2010-01-15 13:55:53 UTC
(In reply to comment #3)
> In fact, the perfect way would be to provide sources

Nokia has offered this 13 months ago (check the mailing lists) but there was
basically no interest.
Comment 5 Yves-Alexis 2010-01-15 14:42:21 UTC
S(In reply to comment #4)
> (In reply to comment #3)
> > In fact, the perfect way would be to provide sources
> 
> Nokia has offered this 13 months ago (check the mailing lists) but there was
> basically no interest.
> 
Sorry, I didn't know about that. I searched the maemo-developers list archives
from dec. 2008 and found
http://lists.maemo.org/pipermail/maemo-community/2008-December/001396.html and
https://bugs.maemo.org/show_bug.cgi?id=1100#c5.

#1100 looks exactly that this current bug, basically providing binary version
for new architectures.

In the maemo-community thread, it looks like 0xFFFF developer, pancake, was
really interested by the opening of flasher (see
http://lists.maemo.org/pipermail/maemo-community/2008-December/001406.html).
I'm not sure what is the situation now (wrt. flasher and 0xFFFF) so I'm adding
him to CC: (hope he doesn't mind).

Cheers,
--
Yves-Alexis
Comment 6 Tomasz Rybak 2010-01-18 20:45:14 UTC
(In reply to comment #2)
> Adjusting summary a bit (I assume x86_64 is what is requested and not, say,
> PPC64).  For version 3.0 such a binary was provided.
> 
> Note that the i386 binary runs fine on x86_64 boxes if i386 libc & libusb are
> available.
> 

For those trying to run it I did it in the following fashion on 64-bit Debian:
1. Downloaded flasher.tar.gz file (Debian package was useless as dpkg refused
to install it claiming wrong architecture - i386 vs. amd64).
2. Downloaded libusb for i386 package from Debian:
http://packages.debian.org/sid/i386/libusb-0.1-4/download
3. Unpacked flasher
4. Unpacked libusb in the current directory (dpkg -x libusb.deb .)
5. Moved libusb*.so* files to flasher directory
6. Run flasher with current directory added to library search path:
"LD_LIBRARY_PATH=. ./flasher-3.5"
Comment 7 Pali Rohár 2011-01-24 00:34:22 UTC
Any news about linux 64bit version of flasher?
Comment 8 Andre Klapper maemo.org 2012-03-24 11:47:01 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )