Bug 7958 - date of birth in contacts appears incorrectly in smart calender birthdays
: date of birth in contacts appears incorrectly in smart calender birthdays
Status: RESOLVED DUPLICATE of bug 6876
Product: Calendar
General
: 5.0/(1.2009.44-1)
: N900 Maemo
: High major with 1 vote (vote)
: ---
Assigned To: unassigned
: calendar-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-14 12:56 UTC by Andrew Franklin
Modified: 2010-03-28 01:52 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Franklin (reporter) 2010-01-14 12:56:52 UTC
SOFTWARE VERSION:
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1.go to all contacts
2.click new contacts from options 
3. insert a name (anything)
4.insert a phone number (anything)
5. click add field
6. select birthday
7. select d.o.b as 14th november 1969
8. press done
9.press save
10. go to calender
11. from options select month view
12 scroll down to november
13. look at box for 14th november there will be no birthday icon in there for
the new contact you just added
14. look at box for 13th november there WILL be a birthday icon there for the
contyact you just added.


EXPECTED OUTCOME:the contacts birthday to be displayed in the correct date in
the calender

ACTUAL OUTCOME:contact is displayed in the incorrect date in the calender

REPRODUCIBILITY:ALWAYS
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
I did a little more testing and assertained the following
Set contacts DOB to 14th November 1970 (or a lesser year) and birthday appears
in calender on the 13th November (INCORRECT)

Set contacts DOB to 14th November 1971 (or a higher year) and birthday appears
in calender on the 14th November(CORRECT) 

I have also tried setting a contacts date of birth as a different date with the
year as less than 1970 but it appears correctly in the calender so it appears
to be an issue only with the date 14th November (but i did not try with all 365
days so maybe there are other dates out there that have the same issue). 

i created a post which goes into a lot more detail on the bug which can be
viewed here http://talk.maemo.org/showthread.php?p=470273#post470273

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0;
Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR
3.5.30729; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 3.0.30729;
InfoPath.2; Creative AutoUpdate v1.40.01)SOFTWARE VERSION:
(Settings > General > About product)
Comment 1 Andre Klapper maemo.org 2010-01-14 20:47:01 UTC
Marking as duplicate - fixed in 2.2009.51-1

*** This bug has been marked as a duplicate of bug 6811 ***
Comment 2 Lucas Maneos 2010-01-14 22:00:14 UTC
Hm, it may well be FIXED (couldn't reproduce) but bug 6811 is about duplicate
entries while this one is about birthdays appearing a day earlier than they
should.
Comment 3 Lucas Maneos 2010-01-14 22:00:59 UTC

*** This bug has been marked as a duplicate of bug 6876 ***
Comment 4 Andrew Franklin (reporter) 2010-01-14 22:17:10 UTC
(In reply to comment #2)
> Hm, it may well be FIXED (couldn't reproduce) but bug 6811 is about duplicate
> entries while this one is about birthdays appearing a day earlier than they
> should.
> 

thats what i thought ... i did the steps i noted above this morning before new
firmware update to do this bug report then after update i tried it again and
was fixed?
i did check the firmware update 'improvments' list on a post and it didnt
mention anything to do with this issue being adddressed.
no problem though as the lor.....maemo moves in mysterious ways
Comment 5 pcerf 2010-03-28 01:52:43 UTC
i'm running 3.2010.02-8 and have the same problem. i recreated the smart
birthday calender several times without success, even rebooted several times in
between.

description once more:
created contact
synced with hermes
now birthday shows up one day too early even though the contact has got the
proper date