Bug 7938 - Connection dies immediately on Mac OS X 10.4.11
: Connection dies immediately on Mac OS X 10.4.11
Status: NEW
Product: BlueMaemo
General
: 0.3
: N810 Mac OS X
: Medium blocker with 6 votes (vote)
: ---
Assigned To: Valério Valério
: general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 23:24 UTC by ldezem
Modified: 2010-11-13 20:35 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description ldezem (reporter) 2010-01-13 23:24:19 UTC
Hi.

This is a potentially great tool but its not connecting to my Macbook nor
Macbook pro (both early releases MB1,1 and MacBookPro2,2. Apple Bluetooth
Software Version (in MBP) is 1.9.5f4 and firmware version 3.1965 (3.1965).

Bluemaemo show up as a paired and trusted device like this:
  NokiaN810:
  Name:    NokiaN810
  Address:    00-1d-6e-9d-2f-75
  Type:    Palm Sized PDA
  Services:    Headset Audio Gateway, OBEX Object Push, BlueZ HID mouse &
Keyboard
  Paired:    Yes
  Favorite:    Yes
  Connected:    No

BUT

It only opens up a second long connection. This opens the "wireless keyboard
setup assistant" on the Mac and asks to press "the key next to the shift (<)"..
How ever as many times as I have tried it does not configure or keep the
connection alive. 

In the "Setup bluetooth dialogue" (when connecting bluemaemo to the Mac) I
unchecked the "use device as a audio gateway (or something)" box. As was
suggested on a forum. This does not do the trick.

The n810 is running latest firmwares and updates os2008.

Is there any way to make bluemaemo support 10.4.11 Macbooks?
Comment 1 Ryan Abel maemo.org 2010-01-13 23:41:08 UTC
You didn't fill in the version field. I'm assuming it's 0.3+?
Comment 2 ldezem (reporter) 2010-01-14 01:50:12 UTC
(In reply to comment #1)
> You didn't fill in the version field. I'm assuming it's 0.3+?
>
Comment 3 Valério Valério maemo.org 2010-01-18 03:36:11 UTC
Hi,

the current version of BlueMaemo available for maemo4(diablo) is a little bit
limited :( . d
Did you tried the procedure described here:
http://talk.maemo.org/showpost.php?p=253682&postcount=196
Comment 4 ldezem (reporter) 2010-01-18 12:42:37 UTC
The procedure mentioned here:

http://talk.maemo.org/showpost.php?p=253682&postcount=196

Has no effect on os x 10.4.11. Everything goes "fine" in the os x end of
connection: 

Pairing up (setting pairing key), setting the "other device" to remotely
control the computer.  It even says that that the device is set up. 

BlueMaemo is all the time "Waiting for connection". Then the os x shuts the
bluetooth connection. And Blue is still waiting for connection. In the
"Bluetooth" Preferenceses it reads: n810, Device Services: Headset Audio
Gateway, OBEX Object Push, BlueZ HID mouse & Keyboard. But I cannot edit the
"Preferences of this connection" from the panel. 

Whats next?
Comment 5 Michael Secord 2010-06-10 05:37:28 UTC
I can actually confirm this with my N900 on OSX 10.6.3.

I've cleared pairings on both devices, and connected per both the wiki post:
http://wiki.maemo.org/Bluemaemo and the thread:
http://talk.maemo.org/showpost.php?p=253682&postcount=196.

I can get the devices paired without issue, but as soon as I connect with
bluemaemo, the keyboard setup pops up on my mac and within 3 seconds goes away
again. BlueMaemo will usually say that it was "Disconnected by the remote
device", though sometimes it takes too long and I'm impatient and close it. I
can reconnect and get into the same loop over and over.

This is BM 0.3.8. I'd love to use it with my MacBook Pro, but I cannot get it
to work for the life of me.
Comment 6 Fredrik Wendt 2010-10-06 12:02:25 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Fredrik Wendt 2010-10-06 12:06:44 UTC
I'm using an N900 and a PowerBook G4 which runs Mac OS X Version 10.4.11. The
devices can pair, but like reported before as soon as BlueMaemo establishes a
connection, the keyboard guide pops up on the Mac and goes away even before I
have time to hit the "Next" button in that guide.

It works just fine with my Ubuntu laptops.
Comment 8 karl.hauschild 2010-11-13 20:35:19 UTC
ditto mac os 10.6.4 on a macbook pro and n900 and maemo5.
same problem as noted in message 5.