Bug 7933 - Conversation IM window is not responding when Select contact dialog is displayed in background
: Conversation IM window is not responding when Select contact dialog is displa...
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: N900 Maemo
: Medium critical (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 22:21 UTC by lakshmi.p
Modified: 2010-03-15 20:52 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description lakshmi.p (reporter) 2010-01-13 22:21:29 UTC
SOFTWARE VERSION:
1.2009.44-1

EXACT STEPS LEADING TO PROBLEM: 
1) Two Google accounts (example: user1 and user2) are in contacts list of each
other
2) Account user1 configured on N900 and user2 configured on PC
3) Open conversations application
4) Open select contact dialog by tapping on 'New IM' button 
5) Send message from user2(PC) to user1(N900)
6) New message alert(Yellow box)is seen
7) Tap on the message alert box to see the message.
8) Open menu to clear the conversation
9) Tap outside the menu

EXPECTED OUTCOME:
- Tapping outside should close the menu.
- Window should respond properly 

ACTUAL OUTCOME:
Menu is not closed and window is not responding. 

REPRODUCIBILITY:
always
Comment 1 Andre Klapper maemo.org 2010-01-14 20:39:37 UTC
I cannot reproduce this here, running 2.2009.51-1.
Is this still an issue in this new version?
Comment 2 lakshmi.p (reporter) 2010-01-18 20:57:47 UTC
(In reply to comment #1)
> Is this still an issue in this new version?
Yes, this is reproducible on 2.2009.51-1.
Comment 3 Janne Kolehmainen 2010-01-21 22:35:23 UTC
(In reply to comment #1)

It is reprodusable at least with me. Main issue is that you have Select contact 
dialog open (step 4). After that you are not able to use conversation menu
anymore. In fact you don't even have to send any new message. Just open select
contact and then go to converstation to clear messages.
Comment 4 Andre Klapper maemo.org 2010-02-02 19:49:36 UTC
I tried this with exactly the steps in comment 1 in the internal version
2010.05-4 and everything is fine - IM conversation opens in a second window, I
click the menu bar, tap outside of it again, and everything works as expected.

Assuming that this has been fixed in the meantime.
Comment 5 Andre Klapper maemo.org 2010-03-15 20:52:23 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).