Bug 7919 - (int-163431) Add to Contacts (from POP3/Inbox) only offers to add myself but not sender
(int-163431)
: Add to Contacts (from POP3/Inbox) only offers to add myself but not sender
Status: NEW
Product: Email
General
: 5.0/(3.2010.02-8)
: N900 Maemo
: Unspecified normal with 2 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 18:09 UTC by Darryl L. Miles
Modified: 2010-07-06 16:50 UTC (History)
3 users (show)

See Also:


Attachments
Screenshot to illustrate issue (86.59 KB, image/png)
2010-03-24 15:00 UTC, Venomrush
Details
Screenshot demonstrating the bug (81.58 KB, image/png)
2010-03-26 01:13 UTC, Darryl L. Miles
Details
Screenshot of the email underneath (46.06 KB, image/png)
2010-03-26 01:16 UTC, Darryl L. Miles
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Darryl L. Miles (reporter) 2010-01-13 18:09:45 UTC
STEPS:

1) Setup a working POP3 account
2) Download an email from a 3rd party
3) While reading the email, click application menu, select "Add to Contacts".
4) The address offered in the pick-list widget is a single email address which
is myself (i.e. the account for which the POP3 account is setup for).

It is expected that the email addresses from the From: and CC: lines would be
offered in the pick-list visible at that point.  But they are not.  So the
function appears to be effectively useless (or misleading/non-intuitive).
Comment 1 Andre Klapper maemo.org 2010-01-22 21:14:02 UTC
Thanks for reporting this (and sorry for the late answers also on your other
reports, still catching up as we've got quite some reports in the last days).

I cannot reproduce this in the internal version 2010.03-8 with an email sent to
my email address only - it does not offer me adding my own address.

Does this still happen in 2.2009.51-1?
Are you the only recipient of that email?
Do you access your email account directly, or do you use Nokia Messaging
Service?
Comment 2 Darryl L. Miles (reporter) 2010-01-25 19:10:22 UTC
Just to update on this one.

The situation has changed, previously on 44-1 I never saw an email address
other than my own (the To: address) listed in the "Add to Contacts" function.


Now in 55-1 I can state the following observations:
 * Yes there are still  messages in my Inbox which exhibit this bug.  These
messages were previously received on 44-1.
 * This bug can also be observed in some new messages received since upgrading.
 I have an Exhibit A which I can add/send to my mailbox and it exhibits this
bug.
 * My own email address always shows up in the list.  This is to clarify my
interpretation of your comment that you *never* see your own email address
listed.  (I am not objecting to my own email address showing up in the list. 
This bug is about the From: and Cc: addresses not showing up.)
 * Most messages I receive are now working in an expected way.  If I was to
estimate for my own anecdotal POP3 usage then 60% of messages look ok.
 * Again anecdotally emails sent from MUA (MS Outlook, SeaMonkey) tend to
exhibit this bug more than automated emails (send from maemo.org and other
websites).


However the following is also observed:
 * Many messages that I previously (in 44-1) received that are still in my
Inbox no longer exhibit the bug.
 * I have at least one message where I can see the From: and Cc: listed, most
emails don't have Cc, so I can at least confirm that.


I can confirm that I am using a POP3 service.

I can confirm that I am the only recipient of the emails that continue to
exhibit the bug.



If you have a POP3 account (that is accessed directly) I can send you an email
that Exhibits this bug.  I have exactly 2 POP3 accounts setup in the N900, no
other email accounts in modest.

If you don't have a POP3 account I can provide a test one (if that helps).



I will continue to diagnose and am about a week away from getting the SDK
running well enough to debug with.



Exhibit A currently stands at (I keep chopping it down looking for a
pattern/problem) :

RETR 74
+OK
From: Test Miles <testmiles@darrylmiles.org>
To: Darryl Miles <darryl.miles@darrylmiles.org>
Subject: Test 10
Date: Sat, 23 Jan 2010 16:32:04 -0000
Message-Id: <20100123112720@mail.darrylmiles.org>

TEST Exhibit A
last line
.


I click "Add to Contacts" and all that appears is:

            Add to Contacts
Darryl Miles <darryl.miles@darrylmiles.org>


No other options.
Comment 3 Venomrush 2010-03-24 01:33:21 UTC
A rare situation adding ourselves to the To list, when the message can be
stored in Sent folder after you send them.

You can type in your own email address or select it (as long as you have your
own email as a contact in AddressBook, you'll be able to add 'you' in.)

Closing as WORSKFORME for the time being, but please feel free reopen if you
feel there's a need to address the issue further.
Comment 4 Darryl L. Miles (reporter) 2010-03-24 14:38:19 UTC
Huh who are you?  Please re-read the bug again your understanding seems to be
way off the mark.  tri@bcs.org.uk please don't modify my bugs without prior
consultation via email.
Comment 5 Venomrush 2010-03-24 14:59:29 UTC
Please tone it down. I felt being harassed.

1. From comment 1, Andre did say he could not reproduce in internal version
2010.03-8
2. I'm here to help with the bug reports.
3. I'm currently going through the bugs that have been idle for 2 months (yours
included)

I would appreciate if you refer to me as Venomrush rather than using my email
in your comment.
Comment 6 Venomrush 2010-03-24 15:00:21 UTC
Created an attachment (id=2521) [details]
Screenshot to illustrate issue
Comment 7 Venomrush 2010-03-24 15:06:51 UTC
Confirming for PR1.1.1

However it is expected that we can add any contacts in TO and CC fields,
including ourself when it's in the list.

A solution would be to match our setup email account address with the TO and CC
fields then remove it from from 'Add to Contacts'

Changing to enhancement base on this.
Comment 8 Darryl L. Miles (reporter) 2010-03-26 01:11:54 UTC
I'm sorry I also feel harassed and now offended by the fact you feel harassed. 
As I've taken offense that must trump your feeling of harassment, right ? 
Where are we going with this ?  I'm not sure this kind of public position is
suited for you, have you considered doing something else for the maemo
community ?


I replied to Andre's comment in comment #2 that information still stands but I
should again retest the situation against the current software release, since
there has been another major update since the time I wrote comment #2.

I'm sorry for citing your email address to reference you, but this is the only
information in the emailed copy of the bug comment updates which is my primary
method of reading your comments.  Unfortunately I can not commit to only
calling you by the name Venomrush in the future, since such things are soon
forgotten as more important stuff competes for brain cells.  But now you have
pointed out this matter and whilst I remember your request I shall call you by
the name you have requested.


I have no idea what your attached screen shot relates to but it certainly
doesn't demonstrate the bug.  Yes it is a bug not an enhancement, since the
intended reason for the "Add to Contacts" feature is to allow you to add the
addresses in the From: Cc: and To: fields to your phone contacts.  Presumably
your own address is one of at least the To: or Cc: fields and I could not care
less if that showed up.  This bug is certainly not about the lack of my own
address showing up, the bug is about the lack of all the other addresses from
showing up.

So all in all I don't think you have contributed anything useful to this bug
reported so far and have somewhat created a lot of useless noise.  Simply
because you have not read and understood the bug comments.  It would be a fair
point if the bug information was unclear but I have re-read my original report
and it does clearly state the steps I took to exhibit the bug, the observe
behavior and the expected behavior.

Since you are not the Reporter of the bug your interference has been somewhat
of an annoyance.  I hope you are not gaining any Karma points for any of this
since its purely wasting peoples time and energy on non production matters.  As
I have previously expressed maybe your concerns would have been better dealt
with by directly emailing the reporter to gain an understanding of the bug
before you proceeded to vandalize the bug report (in the name of doing your bit
for the community).



I can also confirm that I am able to still observe this bug, with emails
received via POP3 as recent within the past week.  As I previously stated on
comment #2 not all emails are affected just some.  I have not been able to find
a common factor, I have full access to the verbatim emails on the POP3 server
(since they are not deleted) including RFC850 (and its superseding
specification) headers.


The current N900 software version is 3.2010.02-8

libtinymail-1.0-0                                   1.0.0-svn4048+0m5
modest                                              3.1.18+0m5


Please find attached some screen shots illustrating the bug, I wasn't aware
they would help describe the problem better.   Also a verbatim copy of the
email including all header information.
Comment 9 Darryl L. Miles (reporter) 2010-03-26 01:13:40 UTC
Created an attachment (id=2528) [details]
Screenshot demonstrating the bug
Comment 10 Darryl L. Miles (reporter) 2010-03-26 01:16:13 UTC
Created an attachment (id=2529) [details]
Screenshot of the email underneath

Verbatim copy of the email headers.  I don't think anything in here is a secret
and Jeff Moe is a very active Maemo contributer doing useful work in the
community.


The bug is that his email address: <moe@blagblagblag.org>

does not show up when I use "Add to Contacts"


From moe@blagblagblag.org Mon Mar  8 06:24:52 2010
Received: from [200.45.48.9] ([200.45.48.9]:57807 "EHLO
        smtp-out-02c11.arnet.com.ar" smtp-auth: <none> TLS-CIPHER: <none>
        TLS-PEER-CN1: <none> rhost-flags-FAIL-FAIL-OK-OK)
        by mail-1.netbauds.net with ESMTP id S696136Ab0CHGYw (ORCPT
        <rfc822;darryl.miles@darrylmiles.org>);
        Mon, 8 Mar 2010 06:24:52 +0000
Received-SPF: none (ns1.netbauds.net: 200.45.48.9 is neither permitted nor
denied by domain of blagblagblag.org) client-ip=200.45.48.9;
envelope-from=moe@blagblagblag.org; helo=smtp-out-02c11.arnet.com.ar;
X-Arnet-Anti-Spam: Activado
X-Arnet-AV: Activado
Received: from unknown (HELO SMTP-CLIENT-03.ARNET.COM.AR) ([192.168.221.4])
  by smtp-route-02.arnet.com.ar with ESMTP; 08 Mar 2010 03:21:55 -0300
Received: from ploegsma.cwx.net (HELO donald.localnet) ([8.20.201.9])
  by smtp-client-03.arnet.com.ar with ESMTP; 08 Mar 2010 03:21:54 -0300
From:   Jeff Moe <moe@blagblagblag.org>
Organization: BLAG
To:     "Darryl L. Miles" <darryl.miles@darrylmiles.org>
Subject: Re: freemoe SDK
Date:   Sun, 7 Mar 2010 23:24:10 -0700
User-Agent: KMail/1.13.0 (Linux/2.6.32.9-67.fc12.x86_64; KDE/4.4.0; x86_64; ; )
References: <200912201529.54719.moe@blagblagblag.org>
<1268025098.21155.6.camel@Nokia-N900-51-1>
In-Reply-To: <1268025098.21155.6.camel@Nokia-N900-51-1>
MIME-Version: 1.0
Content-Type: Text/Plain;
  charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
Message-Id: <201003072324.10290.moe@blagblagblag.org>
Return-Path: <moe@blagblagblag.org>

On Sunday 07 March 2010 22:11:38 you wrote:
> Hi,
> 
> since kernel update the VDSO has been reenabled on freemoe.  please try to
> login to scratchbox to see error.

Fixed. Thanks for letting me know.

-Jeff
Comment 11 Brent S 2010-07-06 16:50:45 UTC
I have also just noticed this problem. I am using POP3, I do not have IMAP
email on the N900 so cannot confirm that it is also affected.
There's more to the problem than originally in the submission. If I send an
email before adding the recipient to my contacts, Modest only allows me to add
the details of the sender of the email, i.e. myself.
So to restate this, it appears that when Add to Contacts is selected on
received emails only recipients are offered for selection, and conversely on
sent emails only originators are offered.