Bug 7910 - (int-112527) Volumes keys in full screen flash video only adjusts volume by one notch before zooming page
(int-112527)
: Volumes keys in full screen flash video only adjusts volume by one notch befo...
Status: VERIFIED FIXED
Product: Browser
Plug-ins: Flash
: 5.0/(1.2009.44-1)
: N900 Maemo
: Low normal (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: adobe-flash-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 15:52 UTC by Cláudio F. Gil
Modified: 2010-01-18 12:43 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Cláudio F. Gil (reporter) 2010-01-13 15:52:55 UTC
SOFTWARE VERSION:
N900l, Maemo 5, 1.2009.44-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Browser and browse to youtube
2. Click a video
3. Click fullscreen button in the flash player
4. Use volume keys

EXPECTED OUTCOME:
Volume would be adjusted possibly without the volume level indicator overlaying
the video.

ACTUAL OUTCOME:
Volume changes by 1 notch, video exists full screen, page starts to zoom.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
- Add Block Plus

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.9.1.6)
Gecko/20091201 SUSE/3.5.6-5.1 Firefox/3.5.6
Comment 1 Andre Klapper maemo.org 2010-01-13 17:09:38 UTC
Thanks for reporting this.
This particular problem has already been reported into our bug tracking system,
but please feel free to report any further bugs you find. Also feel encouraged
to vote for the original bug report if interested.

Please feel free to search for existing reports first to avoid filing
duplicates.


*** This bug has been marked as a duplicate of bug 6396 ***
Comment 2 Cláudio F. Gil (reporter) 2010-01-13 17:45:26 UTC
Just one note. As indicated, I actually expect the volume to be adjusted when I
press the key. Exiting full screen and starting to zoom the web page is the
erroneous behavior, in my opinion. 

Bug #6342 is also related to the use of the volume keys in web pages and it's
even more general than this particular report. In this report I'm just focusing
on the specific use case of viewing a flash video in full screen. I believe
that, even if the volume keys keeps being used for zooming in web pages,
zooming should not take place when the video is in full screen as it makes no
sense (for me, off course).
Comment 3 tuukka.tolvanen nokia 2010-01-16 21:48:56 UTC
fixed in internal 2.2009.46-7