Bug 7898 - Search in media player - matches only song starting with, not substrings
: Search in media player - matches only song starting with, not substrings
Status: CLOSED DUPLICATE of bug 5879
Product: Media player
General
: 5.0/(1.2009.44-1)
: All Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 13:46 UTC by amitkankani
Modified: 2010-02-16 16:06 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description amitkankani (reporter) 2010-01-13 13:46:53 UTC
SOFTWARE VERSION:
(Settings > General > About product)
1.2009.44-1

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open Media player
2. Start typing a search term, for eg: "back"


EXPECTED OUTCOME:
If there were 2 songs say:
1. Backstreet's back alright
2. Gonna have you back

Then it should list both the songs with back in each highlighted

ACTUAL OUTCOME:

Only the song starting with the search string is listed.

REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)
always

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
When the number of songs increase, it becomes very difficult to remember the
exact 1st word the way it is stored in the device. However, remembering some
word of the song is more likely and should be searchable with substrings/or
atleast each "word"'s beginning in the song title/album/artist


User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US)
AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.25 Safari/532.0
Comment 1 Andre Klapper maemo.org 2010-01-13 14:01:55 UTC
Thanks for reporting this.
This particular problem has already been reported into our bug tracking system
and fixed internally, but please feel free to report any further bugs you find.

Please feel free to search for existing reports first to avoid filing
duplicates.


*** This bug has been marked as a duplicate of bug 5879 ***