Bug 7886 - (int-154367) Tapping 'Task Manager' shows 'Clear Conversation' option while in a conversation
(int-154367)
: Tapping 'Task Manager' shows 'Clear Conversation' option while in a conversation
Status: RESOLVED FIXED
Product: Chat & Call & SMS
Messaging
: 5.0/(2.2009.51-1)
: N900 Maemo
: Low normal with 1 vote (vote)
: 5.0/(10.2010.19-1)
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 07:03 UTC by Venomrush
Modified: 2010-04-13 00:53 UTC (History)
4 users (show)

See Also:


Attachments
latest hildon-desktop (222.26 KB, application/x-debian-package)
2010-01-26 14:17 UTC, Kimmo Hämäläinen
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Venomrush (reporter) 2010-01-13 07:03:10 UTC
SOFTWARE VERSION:
As above

EXACT STEPS LEADING TO PROBLEM: 
1. Have a SMS text message conversation open with a contact and keeping that
conversation in focus.
2. Lock the device (using side lock hardware)
3. Get another phone to send you a SMS text message, wait until text message
arrived and wait for about 15 seconds after that.
4. Unlock the device and tap the 'Task Manager'

EXPECTED OUTCOME:
Screen go back to main SMS conversations

ACTUAL OUTCOME:
'Clear Conversation' option pops up

REPRODUCIBILITY:
Always

OTHER COMMENTS:
In a normal situation, the only way to get Clear Conversation open was to tap
in top-middle section of the screen where the contact's detail is displayed.
Comment 1 Venomrush (reporter) 2010-01-13 07:04:25 UTC
Refine steps:

1. Have a SMS text message conversation open with a contact (Phone A) and
keeping that
conversation in focus.

3. Get another phone (Phone B, with a different number to phone A) to send you
a SMS text message, wait until text message
Comment 2 Andre Klapper maemo.org 2010-01-22 17:03:34 UTC
Has this happened again in version 2.2009.51-1?
Comment 3 Venomrush (reporter) 2010-01-23 16:43:51 UTC
(In reply to comment #2)
> Has this happened again in version 2.2009.51-1?
> 

Yup, still happening, now showing 'Open contact card' along with 'Clear
conversation'
Comment 4 Kimmo Hämäläinen nokia 2010-01-26 12:58:43 UTC
(In reply to comment #0)
...
> EXPECTED OUTCOME:
> Screen go back to main SMS conversations

You mean you expect to be in Task switcher after tapping on the top-left
button?
I tried this and it works...
Comment 5 Venomrush (reporter) 2010-01-26 13:17:31 UTC
(In reply to comment #4)

> I tried this and it works...
> 

Please follow the steps closely.
I can reproduce this everytime.
Comment 6 Kimmo Hämäläinen nokia 2010-01-26 13:27:02 UTC
could you answer my question then, so that I can do that?
Comment 7 Venomrush (reporter) 2010-01-26 13:53:49 UTC
(In reply to comment #6)
> could you answer my question then, so that I can do that?
> 

Sorry.

You mean you expect to be in Task switcher after tapping on the top-left
button? -> Yes (although I prefer it to go back to main SMS conversation)

By following my steps, it pops out the options, rather than going to Task
switcher if you have focus on a message from contact A, phone is locked, and
receive another message from contact B.
Comment 8 Kimmo Hämäläinen nokia 2010-01-26 14:12:55 UTC
ok, then this issue seems fixed in our git master already.. I don't know which
version has fixed it.
Comment 9 Kimmo Hämäläinen nokia 2010-01-26 14:17:22 UTC
Created an attachment (id=2134) [details]
latest hildon-desktop

Here is the newest hildon-desktop so you can try it yourself. Install as root
"dpkg -i hildon-desktop_2.2.130-1~unreleased_armel.deb" and restart the device.

Warning: you may mess up your device (e.g. system software update), so do this
only if you prepared to re-flash :P
Comment 10 Venomrush (reporter) 2010-01-26 14:27:45 UTC
(In reply to comment #9)

> Warning: you may mess up your device (e.g. system software update), so do this
> only if you prepared to re-flash :P
> 

Not willing to reflash :P
Marking as fixed, I'll verify in next FW update whenever that is..
Comment 11 Venomrush (reporter) 2010-02-04 01:21:55 UTC
I've installed hildon-desktop_2.2.130-1~unreleased_armel.deb

It seem to fixed the issue.
Although I noticed there is no extended application menu ("More..") anymore.
Everything in pack into a single Menu page.

Is this expected?
Comment 12 Andre Klapper maemo.org 2010-02-04 08:53:45 UTC
(In reply to comment #11)
> Is this expected?

See bug 5743
Comment 13 Andre Klapper maemo.org 2010-03-15 20:52:22 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 14 Frank Banul 2010-04-13 00:53:17 UTC
*** Bug 7987 has been marked as a duplicate of this bug. ***