Bug 7882 - Ring tone played through Bluetooth headset instead of internal speakers
: Ring tone played through Bluetooth headset instead of internal speakers
Status: RESOLVED FIXED
Product: Telephony
General
: 5.0/(1.2009.44-1)
: All Maemo
: Medium normal with 1 vote (vote)
: 5.0/(2.2009.51-1)
Assigned To: unassigned
: telephony-general-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-13 04:07 UTC by John Perez
Modified: 2010-01-14 21:17 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description John Perez (reporter) 2010-01-13 04:07:36 UTC
SOFTWARE VERSION: 1.2009.44-1.002

STEPS TO REPRODUCE THE PROBLEM: 

1. Pair a Bluetooth headset with the N900 
(Settings > Bluetooth On > Devices > New > Select Device > Set as Trusted
Device > Enter code > Pair)

2. Wait for in incoming call

EXPECTED OUTCOME: To hear ring tone from both Bluetooth headset and phone
internal speakers

ACTUAL OUTCOME: Ring tone is heard through Bluetooth headset only

REPRODUCIBILITY: Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS: There are occasions when it is necessary to remove a Bluetooth
headset, such as while sleeping, charging the headset, or as a courtesy while
having a face to face conversation.  At these times, incoming call ring tones
cannot be heard and those calls are often missed.  Previous Nokia products such
as the 9500 and E90 would play ring tones through both the phone's internal
speakers and Bluetooth headset, allowing the user to hear incoming calls even
if the headset was not being worn at that moment.  As the Bluetooth headset was
still connected, it was easy to put it back on and take the call.  

Suggestions that the headset could be switched off when not being worn are
problematic, due to increased likelihood of Bluetooth malfunction when
repeatedly disconnected and connected, sometimes requiring multiple tries or
rebooting the N900.  It can also be difficult to re-connect the Bluetooth
headset quickly while the phone is ringing, as some Bluetooth headsets take
several seconds to turn on.  It is not ideal to make the use of the product
more cumbersome, such as requiring one to manually switch peripherals on and
off, when this was not previously necessary.  

It is preferable to have the option to choose where ring tones are played
(phone speakers, headset, or both), or otherwise, always playing from the
phone's internal speakers.

See also related "Alarm played through Nokia BH-102 Bluetooth headset instead
of internal speakers", bug 6275 https://bugs.maemo.org/show_bug.cgi?id=6275

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2)
Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Comment 1 Andre Klapper maemo.org 2010-01-13 14:15:00 UTC
Thanks for reporting this.
A lot of updates have gone into the next software update for this area which
should be out really soon (version 2.2009.something), and a retest is highly
welcome then. :)
Comment 2 John Perez (reporter) 2010-01-14 21:16:21 UTC
Fixed as of version 2.2009.51-1.002

Pulseaudio: Ringtone is heard from the loudspeaker if BT connected.
Comment 3 Andre Klapper maemo.org 2010-01-14 21:17:50 UTC
Thanks for retesting!