Bug 7855 - Whole phone becomes slow and unresponsive after configuring large email account (IMAP)
: Whole phone becomes slow and unresponsive after configuring large email accou...
Status: RESOLVED DUPLICATE of bug 3762
Product: Email
General
: 5.0/(1.2009.44-1)
: N900 Maemo
: Low critical (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2010-01-12 17:54 UTC by Damien Mascord
Modified: 2010-01-23 18:22 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Damien Mascord (reporter) 2010-01-12 17:54:22 UTC
SOFTWARE VERSION: 1.2009.44-1
(Settings > General > About product)

EXACT STEPS LEADING TO PROBLEM: 
(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Configure IMAP email account to personal email (server is a debian server
with courier-imap).   (My email account has around 100 folders in the
structure, with around 10,000-30,000 emails per folder.)
2. Use the email client to browse folders.
3. Looking at the contents of folders is very slow, and even non-email portions
of the operating system slow down, any menu click can take many seconds to
response, battery is drained faster in this "slow" mode.
4. Remove configured email account, and the phone becomes responsive again.

EXPECTED OUTCOME:
1-2: As above.
3-4. No time delay between clicking on folders, and seeing the latest email
list.  No negative affect on the whole operating system due to IMAP email being
configured.

ACTUAL OUTCOME:
As above.

REPRODUCIBILITY: Always
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:
None.
OTHER COMMENTS:

The email client, Modest, is quite hard to use with large email boxes.   Things
that I have noticed so far:

1) Folder list is not cached, and takes quite some time (many seconds) to show.
2) Folder list is hard to browse if you have more than 10 folders.   If you
have many subfolders, browsing the folder tree is difficult as all sub folders
are expanded, and there is no way to quickly jump to the folder that you are
interested in.  (configurable of course)   Perhaps sorting the folder list
based on the latest received email, so that old folders, such as archive
folders don't clutter the display.
3) Once you have scrolled to the folder you are interested in, clicking on that
folder, requires you to wait a huge amount of time (over a minute) before it
will show any messages.
4) There is no way to configure any identities, such that you can respond to
certain emails using one email address, or another.   Say you have your work
email, and your personal email all collecting in different folders, the ability
to respond to the email with the correct email address is necessary.
5) Using the email client will drain the battery like crazy, as it does not
have IDLE support and will poll all folders.   If you have a lot of folders,
this becomes very expensive.
6) General slow down of the entire phone/operating system is not acceptable.  
Using desktop email clients do not experience this massive slowdown, and
neither should modest/tinymail.


User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/532.8
(KHTML, like Gecko) Chrome/4.0.296.0 Safari/532.8
Comment 1 Lucas Maneos 2010-01-15 19:17:57 UTC
Thanks for the bug report. This particular bug has already been reported into
our bug tracking system, but please feel free to report any further bugs you
find.

*** This bug has been marked as a duplicate of bug 3762 ***
Comment 2 Damien Mascord (reporter) 2010-01-15 19:20:19 UTC
Hi,

Could all of the comments below be reviewed in case a new bug needs to be
created for any of the items ?

Cheers,

Damien
Comment 3 Lucas Maneos 2010-01-23 18:22:22 UTC
(In reply to comment #2)
> Could all of the comments below be reviewed in case a new bug needs to be
> created for any of the items ?

In general, please file one bug report for each specific issue and do search
existing bugs first to avoid duplicates.

> 1) Folder list is not cached, and takes quite some time (many seconds) to show.

That's bug 7674.

> 2) Folder list is hard to browse if you have more than 10 folders.   If you
> have many subfolders, browsing the folder tree is difficult as all sub folders
> are expanded

Bug 8092.

> Perhaps sorting the folder list
> based on the latest received email, so that old folders, such as archive
> folders don't clutter the display.

Bug 2559.

> 3) Once you have scrolled to the folder you are interested in, clicking on that
> folder, requires you to wait a huge amount of time (over a minute) before it
> will show any messages.

This is essentially the issue reported here.

> 4) There is no way to configure any identities

Bug 3409 (bug 6424 is also related).

> 5) Using the email client will drain the battery like crazy, as it does not
> have IDLE support and will poll all folders.

Bug 3888.